Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
nfs-share mit easyVDR 2.0 mounten
#1
Hallo zamm,

ich habe meinen server mit buster neu aufgesetzt. Der Server stellt einen nfs-share zur Verfügung. Seitdem kann der seit Jahren klaglos funktionierende easyVDR 2.0 den nfs-share nicht mehr mounten.

Das ist die Fehlermeldung
Code:
mount.nfs: access denied by server while mounting server:/media/md0

inxi -v3 (easyVDR 2.0)
Code:
System:   Host: vdr Kernel: 3.12.0-7-generic x86_64 (64 bit, gcc: 4.8.2) Console: tty 2 Distro: easyVDR 14.04 trusty
Machine:  Mobo: ZOTAC model: NM10 Bios: American Megatrends version: 080016 date: 05/05/2011
CPU:      Dual core Intel Atom CPU D525 (-HT-MCP-) cache: 512 KB flags: (lm nx sse sse2 sse3 ssse3) bmips: 7183.06
          Clock Speeds: 1: 1795.767 MHz 2: 1795.767 MHz 3: 1795.767 MHz 4: 1795.767 MHz
Graphics: Card: NVIDIA GT218 [ION] bus-ID: 04:00.0
          X.org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) tty size: 148x33 Advanced Data: N/A for root out of X
Network:  Card-1: Realtek RTL-8110SC/8169SC Gigabit Ethernet driver: r8169 ver: 2.3LK-NAPI port: e800 bus-ID: 05:0b.0
          IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:01:2e:35:35:cc
          Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k bus-ID: 02:00.0
          IF: wlan0 state: down mac: 48:5d:60:92:64:e1
Drives:   HDD Total Size: 120.0GB (28.5% used) 1: model: ADATA_SSD_S510_1
Info:     Processes: 176 Uptime: 18 min Memory: 531.2/7983.9MB Runlevel: 2 Gcc sys: 4.8.4
          Client: Shell (bash 4.3.11) inxi: 1.9.17

Eintrag in der fstab (easyVDR 2.0)
Code:
server:/media/md0 /media/md0 nfs defaults 0 0

Eintrag in der exports des servers (buster, aktuell)
Code:
/media/md0 192.168.1.1/24(rw,sync,no_subtree_check,no_root_squash)

Andere Systeme, u. a. auch ein easyVDR 3.5, können den Server problemlos mounten. Was passt am easyVDR 2.0 nicht? Das Orakel hat nichts für mich passendes zutage gefördert. Hat jemand eine Idee?

Gruß dsat
Zitieren
#2
Hi, 
Ich vermute da passt ein Authentifizierungssystem nicht mehr weil veraltet und unsicher und deshalb nicht mehr supported(deaktiviert) . Aber auch nur raten. 
Bei ssh ist es ebenso. Der von mir genutzte Client geht auch nicht mehr, musste auch auf Winscp und putty umsteigen. 
Mfg Stefan
[size=x-small][b]Test-VDR1[/b]: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
[b]VDR4[/b]: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
[b]VDR5[/b]: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
[b]VDR6[/b]: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
[color=blue][url=http://tinyurl.com/ycx4qsv]Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal![/url][/color][/size]
Zitieren
#3
Ok, besten Dank. Dann werde ich wohl mal einen easyVDR 3.5 aufsetzen.

Gruß dsat
Zitieren
#4
Probier' einmal folgendes - NFS-Server:
Code:
[email protected]:~# exportfs -v
/media/easyvdr01/filme3
        thanner(ro,async,wdelay,insecure,root_squash,no_subtree_check,sec=sys,ro,insecure,root_squash,no_all_squash)
/media/easyvdr01/mp3
        thanner(ro,async,wdelay,insecure,root_squash,no_subtree_check,sec=sys,ro,insecure,root_squash,no_all_squash)
[email protected]:~# cat /etc/exports | grep -v  ^#
/media/easyvdr01/filme3 thanner(ro,async,no_subtree_check,insecure)
/media/easyvdr01/mp3    thanner(ro,async,no_subtree_check,insecure)
[email protected]:~# ping thanner
PING thanner (192.168.1.10) 56(84) Bytes Daten.
64 Bytes von thanner (192.168.1.10): icmp_seq=1 ttl=64 Zeit=0.566 ms
64 Bytes von thanner (192.168.1.10): icmp_seq=2 ttl=64 Zeit=0.556 ms
^C
--- thanner ping statistics ---
2 Pakete übertragen, 2 empfangen, 0% Paketverlust, Zeit 1023ms
rtt min/avg/max/mdev = 0.556/0.561/0.566/0.005 ms
[email protected]:~# grep thanner /etc/hosts
192.168.1.10    thanner    thanner.fritz.box
[email protected]:~#

Und auf dem NFS-Client:
Code:
[email protected]:~# mount -F nfs schimi:/media/easyvdr01/mp3 /mnt/media/easyvdr01/mp3
mount: fehlerhafter Aufruf
Rufen Sie „mount --help“ auf, um weitere Informationen zu erhalten.
[email protected]:~# mount -t nfs schimi:/media/easyvdr01/mp3 /mnt/media/easyvdr01/mp3
[email protected]:~# ls /mnt/media/easyvdr01/mp3/
audiorecorder  @current.m3u  Musik  my_radio  ripit  stream-ripper  tar_rar_usw  tmp
[email protected]:~#
Debugging via showmount (auf dem NFS-Client thanner):
Code:
[email protected]:~# showmount -e schimi
Export list for schimi:
/media/easyvdr01/mp3    thanner
/media/easyvdr01/filme3 thanner
[email protected]:~#

Dann wäre da noch das ID-Mapping etc.

Tschau

Gunther
Mostly Harmless: Grotendeels ongevaarlijk

EasyVDR1: Mainboard Asus P8Z77-V (oder ähnlich), NVidia GK208 bzw. GT 630 Rev. 2 passiv, DVB: WinTV Nova HD S2, Technisat SkyStar2 (nur DVB-S), USB-Bootstick/ext4 ohne Journal für VDR, Mediaplatte WDC WD40EFRX, FB One-for-All URC 1280 mit Code 1272 als MS-MCE für SAT (via WinTV Nova HD S2) - Prod auf EA3.5, Test auf EA5
EasyVDR2: Mainboard MSI Z370M-GAMING-PRO-AC, NVidia GK208 bzw. GT 630 Rev. 2 passiv, DVB: Digital Devices Octopus Cine C2T2S2 , SSD-Bootplatte mit EasyVDR5 Focal, EasyVDR4 Focal,... , VNSI gegen EasyVDR1, keine FB, Tastatur Funk Logitech und "Microdia RF Controller" via HID - Test auf EA5 - (Netflix, Youtube...)
Zitieren
#5
@grumpf

sinngemäß habe ich das alles vorher schon ausprobiert. Ich kann den vdr anpingen und ich kann mich per putty draufsetzen. Alles was nicht funktioniert ist mounten des nfs-shares.

Gruß dsat
Test | ea5a10 | ASRock H67M B3 | Intel Quad Core i5-2400 | Zotac NVIDIA GK208B [GeForce GT 710] passiv | DD Cine S2 V6 + CI
vdr1 | ea35 | ASRock B250M Pro4 | Intel Celeron CPU G3900TE | Zotac GeForce GT 710 (passiv) | TT-budget S2-3200 HDTV-S2 CI
vdr2 | ea35 |Zotac IONITX-T (NM10) | Intel Atom D525, 2x1.80GHz (onboard) | GeForce G210, 512MB DDR3 (nVIDIA NextGen ION) (onboard) | DD cineS2 V6
Zitieren
#6
Deswegen ja... auf Client "showmount -e SEVER" liefert dir die exportierten Verzeichnisse, auf dem Server beim "exportfs -v" sollte ein "insecure" auftauchen, und die Namensauflösung muss passen...
brave new world der security
Mostly Harmless: Grotendeels ongevaarlijk

EasyVDR1: Mainboard Asus P8Z77-V (oder ähnlich), NVidia GK208 bzw. GT 630 Rev. 2 passiv, DVB: WinTV Nova HD S2, Technisat SkyStar2 (nur DVB-S), USB-Bootstick/ext4 ohne Journal für VDR, Mediaplatte WDC WD40EFRX, FB One-for-All URC 1280 mit Code 1272 als MS-MCE für SAT (via WinTV Nova HD S2) - Prod auf EA3.5, Test auf EA5
EasyVDR2: Mainboard MSI Z370M-GAMING-PRO-AC, NVidia GK208 bzw. GT 630 Rev. 2 passiv, DVB: Digital Devices Octopus Cine C2T2S2 , SSD-Bootplatte mit EasyVDR5 Focal, EasyVDR4 Focal,... , VNSI gegen EasyVDR1, keine FB, Tastatur Funk Logitech und "Microdia RF Controller" via HID - Test auf EA5 - (Netflix, Youtube...)
Zitieren
#7
Mir schien es sinnvoller neu zu installieren, als an einem älteren System herumzufrickeln. Inzwischen läuft ein easyVDR 3.5. Insofern ist das Thema gelöst. Besten Dank nochmal.

Gruß dsat
Test | ea5a10 | ASRock H67M B3 | Intel Quad Core i5-2400 | Zotac NVIDIA GK208B [GeForce GT 710] passiv | DD Cine S2 V6 + CI
vdr1 | ea35 | ASRock B250M Pro4 | Intel Celeron CPU G3900TE | Zotac GeForce GT 710 (passiv) | TT-budget S2-3200 HDTV-S2 CI
vdr2 | ea35 |Zotac IONITX-T (NM10) | Intel Atom D525, 2x1.80GHz (onboard) | GeForce G210, 512MB DDR3 (nVIDIA NextGen ION) (onboard) | DD cineS2 V6
Zitieren
#8
Hi, 
Du hättest auch mal mit der 5 alpha testen können direkt. 
Mfg Stefan
[size=x-small][b]Test-VDR1[/b]: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
[b]VDR4[/b]: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
[b]VDR5[/b]: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
[b]VDR6[/b]: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
[color=blue][url=http://tinyurl.com/ycx4qsv]Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal![/url][/color][/size]
Zitieren
#9
Hi,

das werde ich auch machen aber dazu muss ich noch etwas Infrastruktur zurecht machen.

Die andere Kiste muss einfach funktionieren.

Gruß dsat
Test | ea5a10 | ASRock H67M B3 | Intel Quad Core i5-2400 | Zotac NVIDIA GK208B [GeForce GT 710] passiv | DD Cine S2 V6 + CI
vdr1 | ea35 | ASRock B250M Pro4 | Intel Celeron CPU G3900TE | Zotac GeForce GT 710 (passiv) | TT-budget S2-3200 HDTV-S2 CI
vdr2 | ea35 |Zotac IONITX-T (NM10) | Intel Atom D525, 2x1.80GHz (onboard) | GeForce G210, 512MB DDR3 (nVIDIA NextGen ION) (onboard) | DD cineS2 V6
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste