Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
EasyVDR 3.5
#1
Hey,
ich hatte heute lange Weile und habe auf der DVB-T2 Kiste mal die 3.5 installiert. Natürlich keine Lange Weile, ich wollte wissen ob ich das imon LCD zum laufen bekomme, etwas was definitiv bei der letzten Installation der 3.5 funktioniert hatte. Was liegt also näher, also zu schauen, was die Unterschiede sind zur EA5.

Aaaaaalso zunächst, was ist da passiert ? Derartigen Trouble hatte ich bisher noch nie ? Und ich weiß, dass die mal funktioniert hat, ich habe die breits einmal installiert - damals noch mit dem Sempron, der jetzt rausgeflogen ist.

1. Installation läuft durch - ok
2. Setup läuft ganz und gar schief !

dddvb-dkms (Digital Devices Treiber) lassen sich (noch) installiere
nvidia 387.x auch ....

aber dann:

System unterstützt nur Softwaredekodierung über xinelibout-plugin ...
WTF !? Wieso nicht vdpau ??? Ähm ...

Egal was ich hier anstelle, der will um´s Verrecken nicht vdpau installieren !

Dann habe ich die Geschichte mit dem Kernel gelesen und das System aktualisiert (Merkwürdig, bereits bei >Install< hat er easyvdr neu gezogen / aktualisiert) und bin auch auf den 4.4.9-137 gegangen. In dem entsprechenden Thread hat mango das richtig gut beschrieben (+ Danke), dann reboot und ein paar Einstellungen übers easyPortal getätigt.
Allerdings ... einen vdr bekomme ich nicht zu Gesicht ! 

Ich brauch erst mal einen Kaffee ! Das etwas mal nicht klappt gut, aber was hier passiert, dass hatte ich mit easyvdr bisher noch nie. Ich kann mich noch erinnern, dass Bleifuss damals gerade das PulsAudio Dingens gebaut hat, das war anfangs ein Problem, aber das konnte gelöst werden.

Was mir aufgefallen ist, die ganze Sache lief genauso wie das Amana hier beschrieben hat. Danach geht gar nix mehr, also nichts was irgendwie relevant ist um einen vdr an den Start zu bringen. Ich verzichte an dieser Stelle mal darauf, irgendwelche log´s zu posten, ich werde das noch mal machen und dann mitschreiben / protokollieren.

Nachtrag:

eben noch mal neu gestartet und mich mit Alt+Strg+F2 eingeloggt, noch mal das Setup angestossen, diesmal konnte ich vdpau auswählen - Leute es ist echt zu heiß um hier mitzudenken - wieso geht das jetzt und nicht vorher ??  Kernel ? Dann hätte es die vorigen Versuche schon funktionieren müssen ! Keine Ahnung ...

2 Kaffee + 1 grosses Eis weiter ... Jetzt will ich es wissen !

reboot & First Setup noch mal ...

dddvb-dkms mal (dunkle Ahnung) abgewählt, Nvidia 38x, vdpau (Erstaunlich, jetzt geht das ...), Setup des Bildschirms, PulseConfig -> ok, FB getestet und für PChanger eingerichtet - Fein ! Setup ist (mal) durchgelaufen ...

vdr gestartet .... nichts ! Dunkler Schirm mit Mauszeiger ...
FB -> Programchanger -> vdr Frontend mit "1" auf FB gestartet ... voilá !!

Endlich BILD + TON ... das war eine sehr schwere Geburt ! Mannoman ...

gut, ich kann weitertesten...

Schade, warum funktioniert der Mist nicht ??? Bei dem imon LCD finde ich den gleichen Fehler wie bei der EA5. Das hat schon mal ootb funktioniert.

Aug 15 16:50:46 easyVDR vdr: [28236] iMonLCD: using Device /dev/lcd0, with 15c2:0038
Aug 15 16:50:46 easyVDR vdr: [28236] iMonLCD: ERROR opening /dev/lcd0 (Datei oder Verzeichnis nicht gefunden).
Aug 15 16:50:46 easyVDR vdr: [28236] iMonLCD: Did you load the iMON kernel module?

--> ääähhm ja !?


Code:
[email protected]:~# lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 15c2:0038 SoundGraph Inc. GD01 MX LCD Display/IR Receiver
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0461:4e6e Primax Electronics, Ltd
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 002: ID 24ae:2013
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[email protected]:~# modprobe imon
[email protected]:~# modprobe -v imon
[email protected]:~# modinfo imon
filename:      /lib/modules/4.4.0-137-generic/kernel/drivers/media/rc/imon.ko
license:        GPL
version:        0.9.4
description:    Driver for SoundGraph iMON MultiMedia IR/Display
author:        Jarod Wilson <[email protected]>
srcversion:    69E887DD9B7E915A2BBB8A1
alias:          usb:v15C2p0046d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0045d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0044d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0043d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0042d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0041d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0040d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p003Fd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p003Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p003Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p003Cd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p003Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p003Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0039d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0038d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0037d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0036d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0035d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2p0034d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v15C2pFFDCd*dc*dsc*dp*ic*isc*ip*in*
depends:        rc-core
retpoline:      Y
intree:        Y
vermagic:      4.4.0-137-generic SMP mod_unload modversions retpoline
parm:          debug:Debug messages: 0=no, 1=yes (default: no) (bool)
parm:          display_type:Type of attached display. 0=autodetect, 1=vfd, 2=lcd, 3=vga, 4=none (default: autodetect) (int)
parm:          pad_stabilize:Apply stabilization algorithm to iMON PAD presses in arrow key mode. 0=disable, 1=enable (default). (int)
parm:          nomouse:Disable mouse input device mode when IR device is open. 0=don't disable, 1=disable. (default: don't disable) (bool)
parm:          pad_thresh:Threshold at which a pad push registers as an arrow key in kbd mode (default: 28) (int)

Gut ... erst mal Schluß für jetzt, der WAF sinkt sonst in´s Bodenlose ...

Euch allen einen schönen Samstag Abend !
Gruss pritt
[color=#9A00B2][size=small]Silverstone CW03 mit 7" Touch TFT, easyVDR 3.0, ASUS M5A87, AMD FX 4300, nVidia VDPAU / SoftHDDevice, Digital Devices Octopus Bridge, 2 x Digital Devices Duoflex S2 (4 Tuner), SanDisk SDSSDX12, 1 x 3 TB (Media), 2 x 1,5 TB (Media), Unicable System || Thermaltake DH 101, ASUS  M5A87, [color=black]AMD FX-6300 Six-Core Processor[/color], 8 GB RAM, [/size][/color][color=#9A00B2][size=small]easyVDR 5.0 (alpha), [/size][/color][color=#9A00B2][size=small]nVidia GT 1030, SoftHDDevice,  Digital Devices Octopus Bridge, 2 x Digital Devices DuoFlex C/T2 (4 Tuner), SanDisk SDSSDX12, 2 x 1,5 TB (Media) || Fractal Design Node 304 mit NAS Openmediavault (RAID 5) 12 TB, Raspberry II mit Debian Wheezy Kartenleser, HD+, ...[/size][/color]
Zitieren
#2
Guten Morgen in die Runde ...

☕ + ☕ erhöht das Denkvermögen ...

Nachdem ich den Link https://www.easy-vdr.de/thread-17604-pos...#pid170905 gefunden habe konnte ich das Problem mit dem doofen iMon LCD endlich lösen, was recht einfach war, nachdem mango das wieder perfekt erklärt hat. ich werde dann bei der EA5 Installation genauso verfahren, weil das Problem /dev/lcd0 statt /dev/lcd1 genau das gleiche ist. Herausgefunden, dass dort statt lcd0 ein lcd1 erwartet wird, dass hatte ich bereits, das in sysconfig und setup.xml zu ändern ist schnell und einfach möglich, wenn man das bei gestoppten vdr wie in dem thread beschrieben durchführt.

@Entwickler: Wo kommt der Fehler her ? Wer verursacht(e) diesen ? ich weiß hundertprozentig, dass dies bei der letzten Installation der EA3.5 ootb funktionierte. Kann das bitte geändert werden in EA 3.5 und EA5 alpha + folgende ? Das wäre lieb, weil es erspart eine Unmenge Frust. Die Displays sind schon recht verbreitet. Dankeschön.

Gruss pritt
[color=#9A00B2][size=small]Silverstone CW03 mit 7" Touch TFT, easyVDR 3.0, ASUS M5A87, AMD FX 4300, nVidia VDPAU / SoftHDDevice, Digital Devices Octopus Bridge, 2 x Digital Devices Duoflex S2 (4 Tuner), SanDisk SDSSDX12, 1 x 3 TB (Media), 2 x 1,5 TB (Media), Unicable System || Thermaltake DH 101, ASUS  M5A87, [color=black]AMD FX-6300 Six-Core Processor[/color], 8 GB RAM, [/size][/color][color=#9A00B2][size=small]easyVDR 5.0 (alpha), [/size][/color][color=#9A00B2][size=small]nVidia GT 1030, SoftHDDevice,  Digital Devices Octopus Bridge, 2 x Digital Devices DuoFlex C/T2 (4 Tuner), SanDisk SDSSDX12, 2 x 1,5 TB (Media) || Fractal Design Node 304 mit NAS Openmediavault (RAID 5) 12 TB, Raspberry II mit Debian Wheezy Kartenleser, HD+, ...[/size][/color]
Zitieren
#3
Moin pritt,
du hast auf einer Testplatte, Testssd installiert? WAF Faktor
Ich dachte Du wolltest mitschreiben. schwitz röchel, ich weiß ist uncool. Nicht hauen, komme von der Hardware Schiene

hier mal meine uncoole Doku easyVDR 3.5.02
Medion MD883, MS-7318 ver. 1.1   BIOS SATA MODE AHCI,    LEGACY MODE,  F8 Bootmenue
CPU XEON 340 1,8/2M/1066  CPU Mark 1281, TDP 65W
Nvidia G86[Quadro NVS290] rev. a1 Monitor an DVI, Treiber 304.135
Sound VT1708/A
CTX948 TV/ DVB-T/DVB-S Combo v. 1.1.1 grüner oder blauer PCI Slot
Installation Internet per Lan Kabel:
Testplatte 500GB WD SATA magnetisch
- DVD V3.5.02 Legacy  stable    Kernel 4.4.0-96
- DVD raus neustart
- Setup durchlaufen
- Nvidia Treiber 304.135
- vdpau OK, wenn nicht erkannt wird, ist der Nvidia Treiber noch nicht geladen => Durchlaufen => Neustart => Setup nochmal
- Pulseaudio analog
- Fernbedienung X10 => Medion X10 Fernbedienung  doppeldrückproblem Kodi (advancedsettings Remoterepeat 2400 und Delay 4)VDR
- Medion FB X10 20029725 Sender
- Kodi 17.6 deutsch
     doppeldrückproblem Kodi (advancedsettings Remoterepeat 2400 und Delay 4) OK
- vnsi installiert und aktiviert (VDR) im easyportal kontrollieren!!!!!!!!!
- Kodi vnsi Install mit:
  apt-get install vdr-plugin-vnsiserver kodi-pvr-vdr-vnsi

  auf der Eingabekonsole mit Admin Rechten / Administrator Terminal

In Kodi dann:
OPTIONEN / Einstellungen / Addons / Benutzer-Addons / PVR-Clients / VDR VNSI Client dann Aktivieren
Einzustellen braucht Du sonst nichts. Spätestens bei einem Neustart von Kodi wird Deine Kanalliste eingelesen.

Kanallogos gibt es auch unter:
OPTIONEN / Einstellungen / PVR & TV / Menü-OSD / Ordner mit Kanalsymbolen / Root-Dateisystem / usr / share / vdr-skins /
liquid-logos4anthra_HD / und OK Taste für Auswahl
mehr Logos gibt es mit -> /usr/share/vdr-skins/skinnopacit
. stopvdr
- sudo apt-get update
- sudo apt-get upgrade
- sudo apt-get dist-upgrade
- Neustart


Funktionstest => OK  Aufnehmen Abspielen kodi 17.6 4.4.0-96 Kernel

Erst wenn das Maschinegerät ordentlich funktioniert. Backup anlegen. Bei zickigen fällen mache ich auch zwischenbackups.
- Nun könnte man den Kernel erneuern (eigenes Risiko). Ich habe ja ein Backup.
- etzter Kernel bei dem sich noch etwas Compilieren lässt (EOL) geht jetzt 16.08.2020 nicht mehr.
Code:
apt-get install linux-headers-4.4.0-137 linux-headers-4.4.0-137-generic linux-image-4.4.0-137-generic linux-image-extra-4.4.0-137-generic linux-lts-xenial-tools-4.4.0-137

Neustart
Test => OK

Allgemein: Never Change A Running System

Schönen Sonntag noch. Mache uns jetzt lecker Salat

MfG
Markus
[b]VDR1 easyVDR 08.6:[/b] P4 2,8 GHz mit TT-Premium SAT an Sony Röhre
[b]VDR2 easyVDR 3.0:[/b] Medion MD8800 MS-7204 P4 3,4 GHz; 2GB DDR2; 2 TB  HD; LCDProc mit VFD Display
[size=small][b]B-PLAN easyVDR 3.0:[/b] MSI G31M MS-7279 ver4 CPU Intel Core 2 Quad Q9300; 2GB DDR2[/size][size=small]; [/size][size=small]X11 Receiver; Medion FB; ASUSNvidia GT630[/size]
[size=small][b]Test [url=https://ftp.gwdg.de/pub/linux/easyvdr/5.0/alpha/easyvdr-5-alpha-010.iso]easyvdr-5-alpha-010 stable[/url]: [/b][/size]GA-H55M-UD2H Bios F11 TX7 LGA 1156 Intel Core i3-550 3,2 GHz 4M Cache 73W CPU Mark 2829 4 GB DDR3[size=small][size=small]; 4 [/size][/size][size=small]T[/size][size=small]B HD; ASUS GT1030 => HDMI Philips 40", Marantz optisch digital vom MB, X11 Receiver; Medion FB[color=black] X10 20029725[/color]; [/size][size=small]Edison Optimus DVB Combo [size=small]mit DVB-T2[/size][/size]
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste