Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst] Fernbedienung "j1rie IRMP_STM32" läuft noch nicht
#1
Hallo ihr Lieben!

das war ja eine Überraschung als ich vor paar Tagen sah, dass es eine 5er (Alpha) gibt....

Mein "neues" System: älterer Terra-PC, FUJITSU D3041-A1, Pentium Dual-Core E5800 3.20GHz; 6GB RAM, NVIDIA GT-710, und eine Digital Devices Cine S2 V7A Dual-Karte.

Das lief mehr oder weniger Out-of-the-Box, beim VDR-Setup hatte ich als zusätzliche Treiber zuerst Digital Devices ausgewählt, was zu Fehlern führte, hier waren "keine" zusätzlichen Treiber nötig. Nach Reboot hatte ich bereits HD-TV Empfang per VDPAU Ausgabe über die GT710.

Jetzt fehlt noch die Fernbedienung. Ich habe eine vom "Kollegen aus dem Nachbarforum", ein IR-USB Selbstbau von Jirie, die wird per lsusb auch gefunden:

Code:
[email protected]:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 1209:4444 Generic j1rie IRMP_STM32
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Als Fernbedienung habe ich eine Logitech Harmony 650. Beides, IR-USB Empfänger und die Harmony, hatte ich zuvor am easyVDR 3.5, siehe Signatur, dessen Konfiguration liegt noch auf Festplatte.
Bei den möglichen Tests der Fernbedienung über "Erweiterte Einstellung" erscheinen auch entsprechend der gedrückten Taste bestimmte Codes am Bildschirm.  Die Möglichkeit des manuellen Anlernens habe ich nicht gefunden.

Was ich bisher gemacht habe:

Code:
install lirc-drv-irman

Im SETUP wird eine:
Code:
4   USB IRMP
gefunden.
Bei der anschließenden Auswahl der Schnittstelle allerdings gibt es nur

Code:
Karte 0 (Intel), Capture-Quelle 0 'Front_Mic'
Karte 0 (Intel), Capture-Quelle 0 'Rear_Mic'
Karte 0 (Intel), Capture-Quelle 0 'Line'
weitere Systemausgaben weiter unten

Bisher bekomme ich die FB nicht an den Start,
hat jemand einen Tipp?

Danke Euch für die Tolle Arbeit,

maxprox
-----------------------------------------------

Hier noch ein paar Ausgaben:
zum Beispiel führt "systemctl start lircd.service" zur Fehlermeldung...


Code:
[email protected]:~# evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:      Power Button
/dev/input/event1:      Power Button
/dev/input/event2:      AT Translated Set 2 keyboard
/dev/input/event3:      PIXART USB OPTICAL MOUSE
/dev/input/event4:      HDA NVidia HDMI/DP,pcm=3
/dev/input/event5:      HDA NVidia HDMI/DP,pcm=7
/dev/input/event6:      HDA Intel Front Mic
/dev/input/event7:      HDA Intel Rear Mic
/dev/input/event8:      HDA Intel Line
/dev/input/event9:      HDA Intel Line Out
/dev/input/event10:     HDA Intel Front Headphone

[email protected]:~# irw
070015000f00 0 070015000f00 IRMP
070015002300 0 070015002300 IRMP
...

[email protected]:~# ll /dev/input/
insgesamt 0
...
crw-rw----  1 root input 13, 64 Jul 31 17:39 event0
crw-rw----  1 root input 13, 65 Jul 31 17:39 event1
crw-rw----  1 root input 13, 74 Jul 31 17:39 event10
...
lrwxrwxrwx  1 root root      10 Jul 31 17:39 ir-auto_dtc -> ../hidraw0
...

[email protected]:~# ll /dev/
...
crw-rw----   1 root vdr     242,   0 Jul 31 17:39 hidraw0
...

[email protected]:~# systemctl status lircd.service
● lircd.service - Flexible IR remote input/output application support
     Loaded: loaded (/lib/systemd/system/lircd.service; disabled; vendor preset: enabled)
     Active: inactive (dead)
       Docs: man:lircd(8)
             http://lirc.org/html/configure.html

[email protected]:~# systemctl start lircd.service
Job for lircd.service failed because the control process exited with error code.
See "systemctl status lircd.service" and "journalctl -xe" for details.
[email protected]:~# systemctl status lircd.service
● lircd.service - Flexible IR remote input/output application support
     Loaded: loaded (/lib/systemd/system/lircd.service; disabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Fri 2020-07-31 22:51:25 CEST; 10s ago
       Docs: man:lircd(8)
             http://lirc.org/html/configure.html
    Process: 2943 ExecStart=/usr/sbin/lircd --nodaemon (code=exited, status=1/FAILURE)
   Main PID: 2943 (code=exited, status=1/FAILURE)

Jul 31 22:51:25 easyVDR lircd[2943]: tira_raw
Jul 31 22:51:25 easyVDR lircd[2943]: udp
Jul 31 22:51:25 easyVDR lircd[2943]: uirt2
Jul 31 22:51:25 easyVDR lircd[2943]: uirt2_raw
Jul 31 22:51:25 easyVDR lircd[2943]: usb_uirt_raw
Jul 31 22:51:25 easyVDR lircd[2943]: usbx
Jul 31 22:51:25 easyVDR lircd[2943]: zotac
Jul 31 22:51:25 easyVDR systemd[1]: lircd.service: Main process exited, code=exited, status=1/FAILURE
Jul 31 22:51:25 easyVDR systemd[1]: lircd.service: Failed with result 'exit-code'.
Jul 31 22:51:25 easyVDR systemd[1]: Failed to start Flexible IR remote input/output application support.



[email protected]:~# DISPLAY=:0 xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PIXART USB OPTICAL MOUSE                  id=8    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]


Angehängte Dateien
.zip   easyinfo_20200731.zip (Größe: 112,22 KB / Downloads: 0)
easyVDR 3.5 auf: Digital Device Cine S2 V7; altes Fujitsu Esprimo Board mit NVidia Chipsatz und AMD Athlon 4000+ u. 2GB RAM; PNY NVidia GF-710
Zitieren
#2
Hi Max..
Auswahl Usb Irmp als FB Empfänger in Setup ist Ok
Als Sender würde ich den Code von MS_MCE
 Nehmen
Dazu die Harmony mit den MS MCE Code programieren
Wenn die Harmony umgestellt ist auf den Microsoft Code
Im Fernbedienungs Setup von EasyVdr unter (Sender) den .
Code von SMK RC MCE 50GB nehmen.
Dann müsste es nach einem Neustart funktionieren
Gruss Helmut
Siehe auch in meinen Verkaufstread
Unter Suche/Biete / STM32 USB Empfänger
https://www.easy-vdr.de/thread-18755.html

Gruss Helmut
EA5 Test-VDR : Lintec3 Senior Gehäuse - MSI G41M-P25 Board - Intel P4 E6850 / 775 Dual Core CPU - 2x2GB DDR3 RAM - MSI GT 710 PCI-e HDMI Grafik - DVB Technisat Skystar S2 SAT PCI + Tevii S2 471 PCI-e x1 - 120GB SSD + 1 TB Test-HDD - Asus DRW-24D5MT DL DVD - USB-STM32 V2 Stick (36kHz) mit SMK RC6 MCE 50GB Fernbedienung - EasyVDR 5.0 Alpha ISO 010 - Softhddevice mit Pulseaudio + estuary4vdr OSD - Kodi 18.7 mit Confluence Skin
VDR-Client,s : Media MVP Scart, VIP BOX 1903, 1910 , EasyStream 0.6-18 für WIN 10, Raspberry PI 3 mit OpenElec 7.01 und TotalControl FB Code 0104 Lirc an Tsop 31238
Zitieren
#3
Danke Helmut,

das war ja einfacher als gedacht, hat also funtktioniert, die Fernbedienung scheint mit dem MS MCE Code besser eingerichtet als zuvor mit dem KLS Code. Einzig die Menütaste geht ein Schritt zu weit und landet gleich im Timer.
EDIT:
übrigens gibt es im easyVDR Setup "Fernbedienung" neben der Auswahl "SMK RC MCE 50GB" auch eine (grob aus dem Kopf): "Lgt Harmony MS-MCE" oder ähnlich, die haben bei mir aber beide nach der Umprogramierung der Harmony funktioniert.


Fühlt sich nicht wie Alpha an ;-)

Trotzdem muss ich evtl. bei der Fernbedienung noch über die Einrichtungssoftware noch nachjustieren.
Beim Testen der Fernbedieung, über die erweiterten Einstellungen im SETUP werden alle Klicks auf der FB zweimal übertragen.
Obwohl auf dem TV alles normal aussieht und ich zB Programm für Programm weiter schalten kann usw. erscheint im Log nach jedem Schalten auch ein ERROR:
Code:
Aug  1 08:58:55 easyVDR vdr: [4420] switching to channel 4 (ProSieben)
Aug  1 08:58:55 easyVDR vdr: [4746] ERROR (common.c,98): Unbekannter Fehler 524
Aug  1 08:58:55 easyVDR vdr: [4746] ERROR (common.c,112): Unbekannter Fehler 524
Aug  1 08:58:55 easyVDR vdr: [4746] ERROR (common.c,98): Unbekannter Fehler 524
Aug  1 08:58:55 easyVDR vdr: [4746] ERROR (common.c,112): Unbekannter Fehler 524
Aug  1 08:58:58 easyVDR vdr: [4420] switching to channel 5 (SAT.1)
Aug  1 08:59:02 easyVDR vdr: [4420] switching to channel 6 (RTL2)
Aug  1 08:59:02 easyVDR vdr: [4746] ERROR (common.c,98): Unbekannter Fehler 524
Aug  1 08:59:02 easyVDR vdr: [4746] ERROR (common.c,112): Unbekannter Fehler 524
Aug  1 08:59:04 easyVDR vdr: [4420] switching to channel 7 (VOX)
Aug  1 08:59:04 easyVDR vdr: [4746] ERROR (common.c,98): Unbekannter Fehler 524
Aug  1 08:59:04 easyVDR vdr: [4746] ERROR (common.c,112): Unbekannter Fehler 524
Aug  1 08:59:04 easyVDR vdr: [4746] ERROR (common.c,98): Unbekannter Fehler 524
Aug  1 08:59:04 easyVDR vdr: [4746] ERROR (common.c,112): Unbekannter Fehler 524

Vielen Dank euch
easyVDR 3.5 auf: Digital Device Cine S2 V7; altes Fujitsu Esprimo Board mit NVidia Chipsatz und AMD Athlon 4000+ u. 2GB RAM; PNY NVidia GF-710
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste