Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Braucht noch einer die /etc/grub.d/42_custom_override_settime?
#1
Hallo zusammen,

wenn ich den VDR starte, dann möchte ich gerne mit 7 Sekunden timeout vom grub2 ein normales Menue angezeigt bekommen... aber jedesmal (VDR 3, 3.5, 4 und 5) habe ich Stress, genau das vi /etc/default/grub einzustellen.

Ich lande immer bei der Datei bzw. Konfiguration /etc/grub.d/42_custom_override_settime:
Code:
[email protected]:~# diff /etc/grub.d/42_custom_override_settime 42_custom_override_settime
11d10
< set timeout=7
[email protected]:~# dpkg -S /usr/bin/passwd
passwd: /usr/bin/passwd
[email protected]:~# dpkg -S /etc/grub.d/
grub-common: /etc/grub.d
[email protected]:~# dpkg -S /etc/grub.d/42_custom_override_settime
dpkg-query: Kein Pfad gefunden, der auf Muster /etc/grub.d/42_custom_override_settime passt
[email protected]:~#

Wenn ich das oben korrekt interpretiere, landet die 42_custom_override, die ich auf 7 Sekunden fest ganz am Ende getrimmt habe, nicht via dpkg/apt auf der Maschine.

Wenn ich https://www.easy-vdr.de/archive/index.ph...994-2.html lese, inkl. der Verweise auf https://www.vdr-portal.de/forum/index.ph...1-gesetzt/ (toter Link http://bkp.easy-vdr.de/forum/index.php?topic=15073.0) .....

dann bin ich immer noch der Meinung, dass die 42_custom_override_settime eine Leiche ist... also habe ich's weggeschoben und folgendes getestet:
Code:
[email protected]:~# mv /etc/grub.d/42_custom_override_settime 42_custom_override_settime.new
[email protected]:~# grep TIMEOUT /etc/default/grub | grep -v ^#
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=13
[email protected]:~# update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
GRUB-Konfigurationsdatei wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-33-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-33-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-26-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-26-generic
grub-probe: Fehler: Für /dev/sdb1 konnte kein GRUB-Laufwerk gefunden werden. Überprüfen Sie Ihre device.map.
Ubuntu 18.04.4 LTS (18.04) auf /dev/sda4 gefunden
Ubuntu 18.04.4 LTS (18.04) auf /dev/sda5 gefunden
Adding boot menu entry for UEFI Firmware Settings
erledigt
[email protected]:~#  systemctl reboot

und siehe da - wenn die 42_custom_override_settime weg ist, dann macht der grub2 genau das, was er soll (hier mit 13 Sekunden...) und man ist wieder näher am Standard-Debian/-Ubuntu...

Woher kommt die 42_custom_* eigentlich?

Thema verschieben ist auch gut - ist ja eigentlich ein LINUX-Ding und nicht spezifisch für EASY 5.

Gunther
Mostly Harmless: Grotendeels ongevaarlijk
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste