Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
KODI will nicht mit nvidia-390
#1
Hallo,

ich habe mir bei der EA-3.0 den nvidia-390 Treiber aus Mango's ppa (https://launchpad.net/~mango-vdr/+archiv.../my-nvidia) installiert (Grund: ich wollte einen zweiten TV an den DisplayPort Anschluss der Geforce 1030 anschliessen, bei nvidia-384 funktioniert offenbar aufgrund eines Treiber Bugs die Audio-Ausgabe über den DP nicht).
Der VDR läuft auch problemlos damit, allerdings verweigert KODI seither das Abspielen von Videos (es gibt nur ein "Standbild").

Folgende Pakete aus Mangos ppa sind installiert:

libcuda1-390
nvidia-390
nvidia-opencl-icd-390
nvdia-settings
libxnvctrl0
libvdpau1

Ich habe mal ein kodi.log von so einem gescheiterten Abspielversuch angehängt, ich selbst kann da allerdings nichts sehen, was mir irgendwie weiterhilft.
Ich hänge auch mal eine easyinfo an, wobei ich zumindest im syslog überhaupt keine Meldungen finde.
Die KODI Einstellungen auf "Standard" zurücksetzen hat nicht geholfen.

Hat jemand eine Idee, woran das liegen könnte?

Schöne Grüsse, und bleibt gesund!
Michael
easyvdr-3.0; MB: Asus M2N-X Plus; DVB: TT-3200, Hauppauge NovaS2; Graka: Geforce GT1030
Zitieren
#2
Oops, Anhänge unterwegs verloren.


Angehängte Dateien
.zip   easyinfo.zip (Größe: 58,16 KB / Downloads: 0)
.log   kodi.log (Größe: 99,92 KB / Downloads: 1)
easyvdr-3.0; MB: Asus M2N-X Plus; DVB: TT-3200, Hauppauge NovaS2; Graka: Geforce GT1030
Zitieren
#3
Hi,

(26.03.2020, 16:32)klappnase schrieb: Folgende Pakete aus Mangos ppa sind installiert:
mit nvidia-390 hatten alle die nee GT 630 im System hatten nur Probleme.Deshalb nutze ich nur
nvidia-387.Die Pakete bbswitch & dkms benötigen einen neuern Compiler.
Nich umsonst steht im my-nvidia PPA zu lesen:
"This is my personal Test-PPA - install only if you know what you're doing!"
Poste mal Bitte die Ausgabe von "dkms status"

Gruss
Wolfgang

Zitieren
#4
Hi,

danke für die Rückmeldung!

Zitat:Nich umsonst steht im my-nvidia PPA zu lesen:

"This is my personal Test-PPA - install only if you know what you're doing!"


Ja, hab ich gesehen... eigentlich dachte ich, ich wüsste das auch... :-)

Zitat:Die Pakete bbswitch & dkms benötigen einen neuern Compiler.
Das hatte ich gesehen. So wie ich das verstanden habe, braucht man die nur für neuere 4.x oder vermutlich auch 5.x Kernel, deswegen hatte ich die hier weggelassen (nutze hier selbst den 3.16.80, ein default 4.4 ist auch noch installiert).

Die Ausgabe von "dkms status" sieht so aus (ich denke da sollte alles ok sein, ich hatte zumindest während der Installation schon aufgepasst, ob evtl. irgendwelche Fehler auftauchen):

Code:
# dkms status
bbswitch, 0.7, 3.13.0-170-generic, x86_64: installed
bbswitch, 0.7, 3.16.80-031680-generic, x86_64: installed
bbswitch, 0.7, 4.4.0-45-generic, x86_64: installed
nvidia-390, 390.48, 3.16.80-031680-generic, x86_64: installed
nvidia-390, 390.48, 4.4.0-45-generic, x86_64: installed
Ich hab dann mal deinen Rat beherzigt und probiert wie es mit nvidia-387 aussieht, gleiches Problem. Bin dann wieder zurück auf nvidia-384, immer noch gleiches Problem. Danach hab ich im Setup bei ausgestöpseltem DisplayPort-Anschluss die Ausgabe wieder zurück auf nur hdmi gestellt, jetzt geht's wieder so wie vorher :-)
Scheint also irgendwie, als hätte KODI entweder grundsätzlich ein Problem mit der Ausgabe auf zwei Graka-Ausgänge oder aber irgendwas an den Einstellungen hat nicht gestimmt.
Zum Testen hatte ich auch mal das Setup mit zusätzlich aktivierten DP bei meiner EA-4.0 Installation probiert (gleicher Kernel mit nvidia-390), da hat das prinzipell funktioniert, auch mit KODI. Vllt. liegt's ja auch an der neueren KODI Version in der 4.0 .

Immerhin, zumindest weiss ich jetzt, dass der Weg zurück offen steht, hatte schon befürchtet, dass das komplett eine Bastelei Marke "wenn's dem Esel zu gut geht" war :-)

Beste Grüsse

Michael
easyvdr-3.0; MB: Asus M2N-X Plus; DVB: TT-3200, Hauppauge NovaS2; Graka: Geforce GT1030
Zitieren
#5
Hattest du denn nach Änderung der Graka Treiber das Monitor_Layout Video_Details und pulseaudio Setup durchlaufen? Das ist wichtig, da sich von Treiber zu Treiber einiges ändert.

Gruss Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#6
Hi,

Monitor Layout und Audio ja, musste ich ja sowieso machen um das Signal auf den DP zu bringen. Video Details ehrlich gesagt nicht, ich glaube eigentlich auch nicht, dass sich da jetzt etwas ändert (hab's grad nicht mehr genau im Kopf, sage ich da nicht nur "VDPAU verwenden"?), der VDR lief ja auch auf beiden Ausgängen einwandfrei.

Gruss

Michael
easyvdr-3.0; MB: Asus M2N-X Plus; DVB: TT-3200, Hauppauge NovaS2; Graka: Geforce GT1030
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste