Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Installation von easyvdr3.5.02 funktioniert nicht
#26
Hallo
Hat zwar etwas länger gedauert, aber bei der Hitze in den letzten Wochen und Dank eines Krankenscheins, war es draußen im Garten und am Pool doch angenehmer als im Haus.
Heute musste ich leider feststellen, dass an meinem Board die 3 PCI Steckplätze wohl defekt sind, bzw. wohl eher ein Controller, der diese steuert.
Also mach ich wieder auf die Suche nach einem Board mit mindestens 2 PCI Steckplätzen.

Erst einmal Danke für eure Hilfe bis hierhin!

Roland
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren
#27
So, ein neues Board ist da (Sig. 3.VDR) und hab nun eine 120GB SSD und eine 1TB HD daran hängen.
Bei der Installation habe ich aber bei der manuellen Partitionierung die 1TB Platte, die als Mediaplatte dienen soll in /srv eingehängt.
Meine Fragen

1. Wie kann ich dies so ändern, dass diese als Mediaplatte im Standard Mediaverzeichnis, also /media/easyvdr01  mountet?
2. Wie kann ich danach überprüfen, ob das auch so funktioniert?
3. Gibt es irgendwas zu beachten bei der Nutzung der SSD als Bootplatte (das ist die erste SSD überhaupt für mich) und wie kann ich verhindern, dass dort zuviel unnötig drauf geschrieben wird? Also z.B. muss ich wohl verhindern, dass Aufnahmen darauf landen. Aber wie?

Danke
Roland
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren
#28
HI Roland
Manuelle Installation ist schon mal OK
Die Systempartition kommt nach  /       
die Medien ( Aufnahmen ) etc. kommen nach /media/easyvdr01

hierbei die Festplatten bezeichnungen beachten ,  sda  für /   und oder sdb  fuer die Medien
kann bei Dir aber auch anders heißen.

Gruß Oberlooser
Test-VDR : Digitainer I Gehäuse - ASRock A75M-HVS Board - AMD A4 3300 FM1 CPU - 2x1GB DDR3 RAM - MSI GT 710 PCI-e HDMI - TT S2 1600 PCI + Skystar 2.6D - 1TB W.D. Green HDD - Sony Optiarc DVD - CIR Nuvoton mit SMK RC6 MCE 50GB Fernbedienung - EasyVDR 3.5-64 Stable  - Softhddevice mit Pulseaudio und estuary4vdr OSD - Kodi 17.6 Final mit Confluence Skin
VDR-Client,s : Media MVP Scart, VIP BOX 1903, 1910 , EasyStream 0.6-18 für WIN 10, Raspberry PI 3 mit OpenElec 7.01 und TotalControl FB Code 0104 Lirc an Tsop 31238
Zitieren
#29
Also prinzipiell funktioniert ja alles. Das System ist auf der SSD.
Jedoch hatte ich bei der Installation irgendwie meinen Openmediavault Server im Kopf, und der mountet zusätzliche Datenträger nach /srv
Deshalb hatte ich den Pfad bei der Installation angegeben....  Cry
Es geht jetzt eigentlich darum, dass die 1TB HD als Medienpartition bzw. komplett als Medienplatte gemountet werden soll, ohne nochmal neu zu installieren.
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren
#30
Hi

Wegen Haltbarkeit der SSD musst du dir keine Sorgen machen außer die ist immer zu 99% voll.

Deine Änderung müsste in der FSTAB möglich sein.

Setup -> Admin Terminal

sudo mcedit /etc/fstab

Da die Zeile mit Video anpassen (vorher aber alles was auf /mnt/easyvdr ist auf die neue Platte kopieren) wenn die Verzeichnisse fehlen startet der VDR nicht.

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#31
Hallo,

(26.08.2018, 22:42)rolando schrieb: Bei der Installation habe ich aber bei der manuellen Partitionierung die 1TB Platte, die als Mediaplatte dienen soll in /srv eingehängt.
Meine Fragen

1. Wie kann ich dies so ändern, dass diese als Mediaplatte im Standard Mediaverzeichnis, also /media/easyvdr01  mountet?
Bitte "/etc/fstab" anhängen!

(26.08.2018, 22:42)rolando schrieb: 3. Gibt es irgendwas zu beachten bei der Nutzung der SSD als Bootplatte (das ist die erste SSD überhaupt für mich) und wie kann ich verhindern, dass dort zuviel unnötig drauf geschrieben wird? Also z.B. muss ich wohl verhindern, dass Aufnahmen darauf landen. Aber wie?
Aufnahmen schaden der SSD nicht. nur solltest du Ramdisk aktivieren und VTX in die Ramdisk legen.
..ist für Plgin osdteletext wichtig, da hier alle paar Sekunden ein Zugriff auf die Platte erfolgt.

P.S
Sieht bei mir so aus!
"/etc/fstab"
Code:
# /media/easyvdr01 was on /dev/sdb1 installation
UUID=ff97b8d6-ec02-4baf-8bf0-ed0c29376906  /media/easyvdr01  xfs  noatime,defaults  0  2

Code:
root@easy5:~# blkid
## 30GB SSD -> / Partition
/dev/sda1: UUID="7f3724c2-3cf6-42f6-a520-8beb0856457d" TYPE="ext4"
/dev/sda5: UUID="3fc3de65-471d-4dda-9b5c-ca600faa59a3" TYPE="swap"
## 1TB Platte als video0
/dev/sdb1: UUID="ff97b8d6-ec02-4baf-8bf0-ed0c29376906" TYPE="xfs"


Code:
Laufwerksbelegung:
Mounted      Capacity -----------------------------------
/dev           1% -----------------------------------
/run           1% -----------------------------------
/             37% ||||||||||||-----------------------
/sys/fs/cgroup   0% -----------------------------------
/run/lock      0% -----------------------------------
/run/shm       1% -----------------------------------
/run/user      1% -----------------------------------
/media/easyvdr01  20% |||||||----------------------------
/easyvdr_ramdisk  13% ||||-------------------------------

Damit liegen die Aufnahmen auf der 1TB Platte. Es ist aber in diesem Fall
nötig, die Struktur der Verzeichnisse auf der 1TB Platte gleich anzulegen wie sie bei der Installation
unter /media/easyvdr01/* angelegt wurden.
Nachdem die Platte eingehängt ist, muss der Symlink /video0 gelöscht
und neu erstellt werden & User Rechte müssen passen

Code:
sudo rm -f /video0  >/dev/null 2>&1
sudo ln -f -s   /media/easyvdr01/video0 /video0  >/dev/null 2>&1
sudo chown -R vdr:vdr  /media/easyvdr01/video0  >/dev/null 2>&1

Gruss
Wolfgang

Zitieren
#32
Hallo
Ich habe vor mangos Antwort vorhin alle Verzeichnisse aus /media (also easyvdr01 mit allen Unterverz. und alle USB Verzeichnisse) nach /srv kopiert (ursprünglicher Mountpoint der HD)

Dann habe ich in der fstab die Einträge für /dev/sdb1 so geändert:
Meine fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=77fefc07-9924-4a55-bf2e-2bb9bd7999ba  /  ext3  noatime,errors=remount-ro  0  1
# /srv was on /dev/sdb1 during installation
# UUID=651a1047-5633-41d2-a63d-e9e996ad3050 /srv            ext4    defaults        0       2
# /media was on /dev/sdb1 during installation
UUID=651a1047-5633-41d2-a63d-e9e996ad3050 /media            ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=847115c9-0f54-4bf6-ac40-15491a12f830 none            swap    sw              0       0

Eine gestartete Aufnahme wurde auch nach /media/easyvdr01/video0 geschrieben.
Also das sollte ja dann OK sein.
Bei der letzten Beschreibung, um den Symlink neu anzulegen, hätte nach der ersten Anweisung nicht der Sysmlink /~video0 gelöscht sein müssen? Dieser hat auch immer noch das Datum von gestern.
Ich habe die Prozedur auf jeden Fall so wie beschrieben durchgeführt und es kamen auch keine Fehlermeldungen.

Ist das ext4 Dateisystem dafür auch OK. Auf dem alten VDR befindet sich das media Verzeichnis auf der Systemplatte und dort steht wie bei mango ein xfs dahinter...?

Das mit der Ramdisk erstellen und VTX aktivieren weiß ich noch nicht wie das funktioniert...
Geht das über das Webportal?
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren
#33
Hallo Roland,

(27.08.2018, 14:46)rolando schrieb: Bei der letzten Beschreibung, um den Symlink neu anzulegen, hätte nach der ersten Anweisung nicht der Sysmlink /~video0 gelöscht sein müssen? Dieser hat auch immer noch das Datum von gestern.
wie ist denn die Ausgabe von
Code:
ls -l /video0
bei mir
Code:
root@easy5:~# ls -l /video0
lrwxrwxrwx 1 root root 23 Sep 30  2017 /video0 -> /media/easyvdr01/video0

(27.08.2018, 14:46)rolando schrieb: Ist das ext4 Dateisystem dafür auch OK. Auf dem alten VDR befindet sich das media Verzeichnis auf der Systemplatte und dort steht wie bei mango ein xfs dahinter...?
EXT4 ist auch Ok ...XFS ist halt für grössere Dateien die bessere Wahl!

(27.08.2018, 14:46)rolando schrieb: Das mit der Ramdisk erstellen und VTX aktivieren weiß ich noch nicht wie das funktioniert...
Geht das über das Webportal?
...über OSD-Menu -> System & Einstellungen -> VDR-Einstellungen -> Laufwerke oder so ähnlich Wink

Gruss
Wolfgang

Zitieren
#34
easyvdr@ASUSVDR:~$ ls -l /video0
lrwxrwxrwx 1 root root 23 Aug 26 18:42 /video0 -> /media/easyvdr01/video0

scheint ja dann OK zu sein.

Wie könnten sich Probleme bei ext4 zu xfs bemerkbar machen?
Normalerweise werden bei den Aufnahmen ja "nur" 2GB große Dateien erstellt.

Ramdisk habe ich erstellt, Größe auf 512MB gestellt und "VTX Daten in Ramdisk legen" angewählt.
Was ist mit den EPG Daten und EPG Images? Sollen die auch in die Ramdisk?
Reichen die 512 MB?

Roland
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren
#35
Hallo,

(27.08.2018, 15:18)rolando schrieb: easyvdr@ASUSVDR:~$ ls -l /video0
lrwxrwxrwx 1 root root 23 Aug 26 18:42 /video0 -> /media/easyvdr01/video0

scheint ja dann OK zu sein.
ja passt!!

(27.08.2018, 15:18)rolando schrieb: Wie könnten sich Probleme bei ext4 zu xfs bemerkbar machen?
am Besten mal Tante google befragen. Alles hat seine vor/nachteile.
z.B XFS löschen von 10GB ca.1sec, früher war der Filesystemcheck viel schneller als mit EXT!

(27.08.2018, 15:18)rolando schrieb: Normalerweise werden bei den Aufnahmen ja "nur" 2GB große Dateien erstellt.
den Splitt bei 2GB braucht am auch nicht mehr,kannst du über das OSD-Menu auf 18GB(18000) stellen.
Will man eine Aufnahme weitergeben, braucht man mit cat die Stücke nicht wieder zu einem File zusammenfügen.

(27.08.2018, 15:18)rolando schrieb: Ramdisk habe ich erstellt, Größe auf 512MB gestellt und "VTX Daten in Ramdisk legen" angewählt.
Was ist mit den EPG Daten und EPG Images? Sollen die auch in die Ramdisk?
Reichen die 512 MB?
EPG-Daten kannst du auch in die  Ramdisk legen, muss man aber nicht.
EPG-Images nur, wenn du externe Anbieter(z.B epgData) nutzt!

Gruss
Wolfgang

Zitieren
#36
Erst einmal vielen Dank für die Hilfe!
Da ich ja noch am Einrichten bin und wenn die Hardware solange mitspielt, wird dieser wohl auch wieder einpaar Jahre seinen Dienst tun.
Deshalb würde ich gerne der Platte gern das xfs Dateisystem verpassen.
Ist dies mit Boardmitteln möglich? fdisk gibt mir keine entsprechende Optionen aus.
Kann das sein, dass fdisk bei älteren vdr Versionen "mächtiger" war?
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren
#37
Hallo,

(27.08.2018, 16:56)rolando schrieb: Deshalb würde ich gerne der Platte gern das xfs Dateisystem verpassen.
Ist dies mit Boardmitteln möglich?
Konsole:
Code:
sudo mkfs.xfs -f /dev/sdb1

Siehe auch
Code:
man mkfs

Gruss
Wolfgang

Zitieren
#38
Ich habe dann doch die für mich einfachere Variante mit GetParted Boot DVD gewählt und die HD mit xfs formatiert.

Beim Starten kam dann die Fehlermeldung:
Lauferk für /media nicht bereit oder nicht vorhanden
Weiter warten, Einhängen mit >>S<< überspringen oder manuelle Wiederherstellung mit >>M<< starten.

Ich habe Option >>S<< gewählt, 
dann das Laufwerk manuell gemountet, 
alle benötigten Verzeichnisse in /media erstellt, 
den Symlink für /video0 erneuert, 
in der fstab in der Zeile

UUID=651a1047-5633-41d2-a63d-e9e996ad3050 /media            ext4    defaults        0       2

ext4 auf xfs geändert, 
zum Test eine Aufnahme nach /media/easyvdr01/video0 kopiert, 
über OSD das Aufnahmerverzeichnis neu eingelesen und die Aufnahme wurde auch angezeigt.

Jedoch bei jedem Neustart kommt diese Fehlermeldung und die HD ist NICHT gemountet.
Nach dem manuellen mounten sind aber alle Verzeichnisse noch vorhanden.

Irgendwo habe ich wohl noch was vergessen.... Aber wo und was?

Außerdem kam beim booten eine Fehlermeldung bezüglich Logo in /usr/share/easyvdr/images
Dort ist die Datei easyvdr-logo.png mit vorangestelltem ! und im MC wird sie rot dargestellt...!

Kann es sein, dass durch die Neuformatierung die UUID der Platte geändert hat? Wenn ja, wie bekomme ich die neue heraus?
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren
#39
Hallo,

(28.08.2018, 16:25)rolando schrieb: Irgendwo habe ich wohl noch was vergessen.... Aber wo und was?
wie ist die Ausgabe von ...wenn mounted
Code:
ls -l /video0

P.S
Auf der Platte muss nur das Verzeichnis easyvdr01 plus alle unterverzeichnisse erstellt werden.
In der fstab muss nach
Code:
UUID=xxxxxxxxxxxxxxxxxxx  /media/easyvdr01  xfs  noatime,defaults  0  2
gemounted werden.

Gruss
Wolfgang

Zitieren
#40
Auf der Suche nach anderen Problemen habe ich gefunden, wie ich die UUID der HD ermitteln kann
sudo blkid

Die so ermittelte UUID habe ich in der fstab eingetragen und schon funktioniert (zumindest) das wieder.

Die anderen Probleme versuche ich erstmal selbst zu lösen, aber wenn ich nicht weiter komme, werde ich mich nochmal melden.
1.VDR: Asus P8H67-V / CPU i5-2500 / 8GB RAM / GT 730 (GK208) / TS Skystar HD2 / TT S2-3200 / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
2.VDR: HP Vectra VL400 / P3 933MHz / 512MB RAM / Haupauge Nexus Ver.2.3 mit FB Nova t45 die hier 80GB HD / easyVDR 0.6.10
3.VDR: Acer M670G / Core2Duo E8400 2,336GHz / 4GB RAM  / TS Skystar HD2 / Zotac GT630 Zone Edition / IR STM32 Empfänger / Haupauge-A415-HPG-WE (T45) / easyVDR 3.5
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste