Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Bluetooth Headset mit intel NUC6CAYH
#1
Hallo,
ich habe mir letztens BT Kopfhöhrer gegönnt, und mein intel NUC hat ja ein eingebautes BT Modul.
Hat jemand eine idee wie die beide gepairt bekomme?
Gruß Axel
Zitieren
#2
Hi, 
Dazu hat Ubuntu einen Manager. 
Den solltest du auf dem Desktop ( via PChanger) erreichen können. 
MfG Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#3
Bluetooth und Wifi geht anscheinend erst ab der 4.6er Kernel.
Siehe http://nucblog.net/2017/01/apollo-lake-n...nclusions/
Schade. Undecided
Ich habe den gepachten Kernel damit beide Tuner der Haupauge Win TV dual-HD funktionieren.
Ist es möglich den 4.8er zu verwenden und den patch für die dual hd selbst einzubauen, oder funktioniert das aufgrund anderer Abhänigkeiten nicht?
Danke und Gruß Axel
Zitieren
#4
Hi,
ist der nicht gerade in den Kernel gewandert (4.16rc) Ich glaub ja, da stand irgendwo hier oder im Portal was...

Patches hier:
https://www.linuxtv.org/wiki/index.php/H...nTV-dualHD

Kernel für trusty gibts hier:
https://www.vdr-portal.de/forum/index.ph...ost1293370


MfG,
Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#5
Hallo Axel,

wenn du den Kernel patchen & neu übersetzen kannst findest du
hier -> https://patchwork.kernel.org/patch/10145805/ einen Patch für den
2ten Tuner. Patch stammt von Brad Love der auch den Kernel für Hauppauge
in unserm PPA gebaut hat. ...und ja, du kannst Kernel 4.6 oder 4.8.12 installieren,
allerdings musst du auch gcc-5.0 installieren. Dazu hatte ich mal ein HowTo
geschrieben, meine das ist auch im easyVDR Wiki gelandet.

P.S
lässt sich das bluetooth Modul denn laden oder fehlt nur die Firmware??
...gibt es dazu nee Meldung im syslog/dmseg?

Bei mir mit Desktop LXDE(normal bluetooth mit Smartphone) - Installiert:
Code:
root@easy5:~# dpkg -l *blue* | grep ii
ii  bluez                        4.101-0ubuntu13.3              amd64   Bluetooth tools and daemons
ii  bluez-alsa:amd64             4.101-0ubuntu13.3              amd64   Bluetooth ALSA support
ii  bluez-cups                   4.101-0ubuntu13.3              amd64   Bluetooth printer driver for CUPS
ii  gir1.2-gnomebluetooth-1.0    3.8.2.1-0ubuntu4.2             amd64   Introspection data for GnomeBluetooth
ii  gnome-bluetooth              3.8.2.1-0ubuntu4.2             amd64   GNOME Bluetooth tools
ii  indicator-bluetooth          0.0.6+14.04.20140207-0ubuntu2  amd64   System bluetooth indicator.
ii  libbluetooth3:amd64          4.101-0ubuntu13.3              amd64   Library to use the BlueZ Linux Bluetooth stack
ii  libgnome-bluetooth11         3.8.2.1-0ubuntu4.2             amd64   GNOME Bluetooth tools - support library
ii  pulseaudio-module-bluetooth  1:4.0-0ubuntu11.1              amd64   Bluetooth module for PulseAudio sound server
ii  python-bluez                 0.18-2                         amd64   Python wrappers around BlueZ for rapid bluetooth development

Service läuft...
Code:
easyvdr@easy5:~$ lsusb | grep Bluetooth
Bus 008 Device 008: ID 0a5c:2101 Broadcom Corp. BCM2045 Bluetooth

Siehe auch -> https://wiki.ubuntuusers.de/Bluetooth/Ei.../#Pruefung

@Stefan
(07.04.2018, 12:12)SurfaceCleanerZ schrieb: Kernel für trusty gibts hier:
https://www.vdr-portal.de/forum/index.ph...ost1293370
...diesen Kernel haben wir ja im PPA und Axel nutzt diesen bereits!!

@Axel
Neuer Hauppauge-Kernel-4.4.0 im PPA!

Gruss
Wolfgang

Zitieren
#6
Hallo,
bevor ich mich ans patchen mache, wollte ich erst einmal den 4.8.12er Kernel installieren, um die BT Verbindung zu testen.
Also das sehr gute tutorial für den Kernel verwendet, sowie:


Code:
wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-3168-ucode-22.361476.0.tgz
tar xvf iwlwifi-3168-ucode-22.361476.0.tgz
cd iwlwifi-3168-ucode-22.361476.0
sudo cp iwlwifi* /lib/firmware
sudo modprobe -v iwlwifi

Der Weg über den Pchanger ist etwas komisch. Ich bekomme hier einen graue Box und es gehrt nicht weiter.
Also Kontextmenü und openbox beenden.
Dann sehen ich einen Desktop, mit einen Login als Gast oder VDR user.
Muss man sich hier irgendwie anmelden?
Im Menü kann ich kein BT entdecken, aber wifi (ist ja eine mini pci kombi karte)
Wenn ich mich über wlan bei mir anmelden will gibt es nur ein insufficient authorization?!
(hier fehlt nicht der wpa key, ich glaube hier fehlt die Berechtigung eine Verbindung herstellen zu können oder irgend etwas anderes)

Also zurück zur command line
Code:
root@easyVDR:~#  dpkg -l *blue* | grep ii
ii  blueman                                               1.23-git201403102151-1ubuntu1                       amd64        Graphical bluetooth manager
ii  bluetooth                                             4.101-0ubuntu13.3                                   all          Bluetooth support
ii  bluez                                                 4.101-0ubuntu13.3                                   amd64        Bluetooth tools and daemons
ii  bluez-alsa:amd64                                      4.101-0ubuntu13.3                                   amd64        Bluetooth ALSA support
ii  bluez-cups                                            4.101-0ubuntu13.3                                   amd64        Bluetooth printer driver for CUPS
ii  bluez-gstreamer                                       4.101-0ubuntu13.3                                   amd64        Bluetooth GStreamer support
ii  bluez-tools                                           0.1.38+git662e-3                                    amd64        Set of tools to manage Bluetooth devices for linux
ii  gir1.2-gnomebluetooth-1.0                             3.8.2.1-0ubuntu4.2                                  amd64        Introspection data for GnomeBluetooth
ii  gnome-bluetooth                                       3.8.2.1-0ubuntu4.2                                  amd64        GNOME Bluetooth tools
ii  indicator-bluetooth                                   0.0.6+14.04.20140207-0ubuntu2                       amd64        System bluetooth indicator.
ii  libbluetooth3:amd64                                   4.101-0ubuntu13.3                                   amd64        Library to use the BlueZ Linux Bluetooth stack
ii  libbluetooth3:i386                                    4.101-0ubuntu13.3                                   i386         Library to use the BlueZ Linux Bluetooth stack
ii  libgnome-bluetooth11                                  3.8.2.1-0ubuntu4.2                                  amd64        GNOME Bluetooth tools - support library
ii  pulseaudio-module-bluetooth                           1:4.0-0ubuntu11.1                                   amd64        Bluetooth module for PulseAudio sound server
ii  python-bluez                                          0.18-2                                              amd64        Python wrappers around BlueZ for rapid bluetooth development

Code:
root@easyVDR:~# dmesg | grep Bluetooth
[    6.325649] Bluetooth: Core ver 2.21
[    6.325717] Bluetooth: HCI device and connection manager initialized
[    6.325724] Bluetooth: HCI socket layer initialized
[    6.325728] Bluetooth: L2CAP socket layer initialized
[    6.325737] Bluetooth: SCO socket layer initialized
[    6.351712] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    6.351714] Bluetooth: BNEP filters: protocol multicast
[    6.351723] Bluetooth: BNEP socket layer initialized
[    6.356848] Bluetooth: RFCOMM TTY layer initialized
[    6.356858] Bluetooth: RFCOMM socket layer initialized
[    6.356868] Bluetooth: RFCOMM ver 1.11
[    6.420524] Bluetooth: hci0: read Intel version: 370810225019140f00
[    6.423771] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.8                                                                                                                                                                  .10-fw-22.50.19.14.f.bseq
[    6.706139] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
hcitool scan
Scanning ...
        00:19:93:11:99:DE       HD 4.50BTNC

Das sieht doch schon einmal gut aus, der Kopfhörer wurde gefunden.
Was nicht geht ist das pairen z.b mit
bt-audio -c 00:19:93:11:99:DE

oder
hcitool cc 00:19:93:11:99:DE; hcitool auth 00:19:93:11:99:DE

Komisch ist auch:
bt-device -l
No devices found

Und root@easyVDR:~# bluetoothctl
bluetoothctl: Befehl nicht gefunden.

Ich weiß jetzt auch nicht mehr was hier noch fehlt, oder welche tools ich ausprobien kann?
Irgendwelche Ideen?

Danke und Gruß Axel
Zitieren
#7
Hi,

(08.04.2018, 18:17)ako400 schrieb: Komisch ist auch:
bt-device -l
No devices found
nee Ausgabe bekommst du nur wenn schon gepairt wurde!
Code:
root@easy5:~# bt-device -l
Added devices:
SANWU Audio (00:13:EF:D2:1D:9F)
MotoG3 (40:88:05:C4:49:4E)
Moto G (B4:F1:C0:F0:8D:17)

(08.04.2018, 18:17)ako400 schrieb: Und root@easyVDR:~# bluetoothctl
bluetoothctl: Befehl nicht gefunden.
den Befehl "bluetoothctl" gibt es erst ab "bluez 5" Trusty hat noch"bluez 4"
vllt. hilft dir dieses PPA ja weiter.

Gruss
Wolfgang

Zitieren
#8
Hi

Du musst das mit dem Networkmanager erledigen, ist glaube ich auch im Pchanger, schau mal im Pchanger setup.
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#9
(08.04.2018, 22:11)mango schrieb: den Befehl "bluetoothctl" gibt es erst ab "bluez 5" Trusty hat noch"bluez 4"
vllt. hilft dir dieses PPA ja weiter.

Mit Kernel 4.8.12 und dem PPA habe ich das pairen jetzt hinbekommen.
Aber irgendetwas geht beim connecten noch schief:
Code:
[NEW] Device 00:16:94:22:99:DE HD 4.50BTNC
[bluetooth]# trust 00:16:94:22:99:DE
[CHG] Device 00:16:94:22:99:DE Trusted: yes
Changing 00:16:94:22:99:DE trust succeeded
[CHG] Device 00:16:94:22:99:DE Modalias: bluetooth:v0A12p0001d0000
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000110d-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000110f-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 00001131-0000-1000-8000-00805f9b34fb
[bluetooth]# connect 00:16:94:22:99:DE
Attempting to connect to 00:16:94:22:99:DE
[CHG] Device 00:16:94:22:99:DE Connected: yes
[CHG] Device 00:16:94:22:99:DE UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:16:94:22:99:DE UUIDs: 00001200-0000-1000-8000-00805f9b34fb
Failed to connect: org.bluez.Error.Failed
[CHG] Device 00:16:94:22:99:DE Connected: no
[CHG] Device 00:16:94:22:99:DE RSSI: -74
[CHG] Device 00:16:94:22:99:DE RSSI: -55
[CHG] Device 00:16:94:22:99:DE RSSI: -65
[bluetooth]#

Ich glaube ich gebe es langsam auf :-)
Ich kann den 4.8.12 Kernel eh nur nutzen wenn er für die Hauppauge Dual HD gepacht ist. Ich habe die entsprechenden Treiberdateien angepasst, aber da waren ein paar i2c Methodenaufrufe drin die ich nicht umgestellt bekomme habe.
Vielleicht hole ich mir einfach eine andere m2 BT Karte die bereits mit dem gepachten Kernel funktioniert.
Gruß Axel
Zitieren
#10
Ich habe da einen 5€ USB Stick geht Problemlos.
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste