Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
VDR 4K Auflösung
#1
Hi,

wie kann ich beim VDR (xorg) die Auflösung auf "4K" (3840 × 2160 ) stellen ? 

Vielen Dank ... 

easyvdr 3.0 stable Nvidia 38x mit Nvidia 1030
SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac GT630 (Kepler) ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
4 DVB-C Tuner L4M-Flex + Twin CT. Qnap 469 Pro per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-3313.
Zitieren
#2
Poste mal die Ausgabe xrandr
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#3
Ich kapere mal diesen Thread- mit dem Unterschied, dass ich mit Intel-Grafik am Start bin (siehe Signatur).
Auf der Konsole werden mir beim Monitor_Layout lediglich folgende Auflösungen angeboten:


Zitat:1920x1080_100.0Hz_p
1920x1080_50.0Hz_p
1920x1080_25.0Hz_p
1280x720_50.0Hz_p

...


xrandr produziert folgenden Output:

Zitat:Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   3840x2160      60.0 +   30.0     25.0     24.0     30.0     24.0  
   4096x2160      24.0     24.0  
   1920x1080     120.0    100.0*   119.9     60.0     50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080i     60.1     50.0     60.0  
   1280x1024      60.0  
   1360x768       60.0  
   1152x864       60.0  
   1280x720       60.0     50.0     59.9  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        60.0     59.9  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)


Die angebotenen Bildwiederholraten in 4k sind ja eher suboptimal- obwohl der HDMI-Anschluss ja zumindest nach Informationen auf der Homepage von Asrock 60Hz machen soll. 50Hz sollten dann doch wohl auch gehen, oder?
Was mache ich falsch?

Viele Grüße,
MrMoe
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#4
Hi,
s. dort auch:
dort probiert Presskopf quasi dasselbe.
https://www.vdr-portal.de/forum/index.ph...ost1304315

Mach das Kernelupdate, dann sehen wir weiter...

Und die 60 Hz werden doch angeboten... 50 btw. nicht!

MfG,Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#5
Wie hast den den Bildschirm angeschlossen, sieht nach DVI aus, das geht eher nicht.
Sollte xrandr die passenden werte ausgeben, dann hier posten, dann kann man das einbauen.
Zur Not geht auch 25 Hz.
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#6
Hallo zusammen!

Im Moment bin ich auf Kernel 4.8.12. Sollte ich dann trotzdem noch weiter updaten? Verfügbar scheint 4.16.3 zu sein.
Den Fernseher (LG 55c7d) habe ich ziemlich sicher via HDMI angeschlossen. Der Ton wird mit übertragen- das würde bei DVI nicht gehen, oder?

Viele Grüße,
Mrmoe
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#7
Ton geht bei Nvidia auch über DVI, hast du vieleicht ein DVI ot HDMI Kabel dran, das geht auch mit Ton.

Falls du nicht sicher bist DVI ist ähnlich wie VGA etwas größer, HDMI ist ähnlich wie USB nur größer
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#8
Eben bin ich noch einmal hinter den vdr gekrabbelt. Er ist definitiv via HDMI angeschlossen.
Nur um Missverständnissen vorzubeugen: Ton mag bei Nvidia über DVI gehen, ich verwende die Intel-Grafik.
Gestern hatte ich dann einmal den Kernel 4.16.3 installiert. Der Output von xrandr sah dann so aus:


Zitat:Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
DP2 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   4096x2160      30.0     25.0     24.0     30.0     24.0  
   3840x2160      30.0     25.0     24.0     30.0     24.0  
   1920x1080     120.0    100.0    119.9     60.0     50.0*    59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080i     60.1     50.0     60.0  
   1280x1024      60.0  
   1360x768       60.0  
   1152x864       60.0  
   1280x720       60.0     50.0     59.9  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        60.0     59.9  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Das sieht ja schon einmal zumindest ein wenig besser aus. Allerdings- aber das ist eine andere Baustelle- meckerte dkms herum, dass der dddvb-Treiber, der installiert werden soll, älter (oder gleich alt) wäre als der im Kernel enthaltene. Insofern wurde das Bauen eingestellt und am Ende waren keine Treiber für meine TV-Karte verfügbar. Vermutlich lässt sich das aber im Setup einstellen. Dazu hatte ich gestern aber keine Muße.

Viele Grüße und ein sonniges Wochenende!
MrMoe
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#9
Hi, 
Ist ja interessant dass bei der höchsten Auflösung die 60 Hz fehlen! 50 fehlen immer noch... 

Wozu dddvb-Treiber? Ist doch alles im Kernel schon drin? 
Warum nimmst du nicht den ersten DP? 

MfG Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#10
Bei der Installation mit dem Standard-Kernel meinte ich für die V7-Karte aktualisierte Treiber zu brauchen. Beim Kernel-Update habe ich das einfach so beibehalten.
Das Mainboard hat nur einen HDMI-Anschluss- und den verwende ich. Die Anzeige wundert mit auch.
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#11
Wir versuchen das mal mit 25 Hz.
Sobald ich Zeit habe Poste ich was du ändern musst (nur eine Zeile)
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#12
Hi Bleifuss2,
eben habe ich mich noch einmal daran gemacht, den neuen Kernel zu installieren. Anschließend hatte ich nach einem einfachen Neustart kein Fernsehbild mehr. Nach einem Shutdown und der Trennung des vdrs vom Strom (keine Ahnung ob das erforderlich war) lief wieder alles wie erwartet. Nur so zum Spaß hatte ich xrandr durchlaufen lassen.


Zitat:Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
DP2 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   3840x2160      60.0 +   50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   4096x2160      60.0     50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080     120.0    100.0*   119.9     60.0     50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080i     60.1     50.0     60.0  
   1280x1024      60.0  
   1360x768       60.0  
   1152x864       60.0  
   1280x720       60.0     50.0     59.9  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        60.0     59.9  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Viele Grüße
MrMoe
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#13
Hi, 
So sollte es aussehen. 
Jetzt ist ja alles dabei! 
MfG Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#14
Auslösung einstellen (du darfst danach kein Monitor-Layout durchführen sonnst wird es überschrieben)
Code:
sudo mcedit /etc/vdr/easyvdr-video-settings.conf



Zitat:VDR_SCREEN_CONNECTOR="HDMI-0"
#Auflösung und Frequenz die eingestellt werden soll

-----> DAS so ändern:
VDR_SCREEN_MODE="--mode 4096x2160 --rate 50.0"

Damit Pchanger passt musst du da das Setup aufrufen.
Mich würde dann interessieren ob es richtig dargestellt wird (sollte gehen).

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#15
Hi,
kann der TV das nativ? Macht wenig Sinn, da 3840 × 2160 gesendet wird lt. Wikipedia.
https://de.wikipedia.org/wiki/4K2K

MfG,
Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#16
Zunächst einmal: vielen Dank für die schnelle Hilfe!

4096x2160 ging praktisch gar nicht. Hin und wieder gab es mal ein verpixeltes Bild auf dem Fernseher- und das war es dann.
3840x2160 lief prinzipiell schon einmal. Hin und wieder gab es Ruckler, die um so öfter auftraten, je höher der Sender aufgelöst war. Am schlimmsten war es bei den UHD-Promo-Kanälen.
Das alles aber nur bei einem ersten schnellen Blick ohne noch ein wenig mit den Einstellungen zu spielen.
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#17
Hi, 
Zum einen was heißt höher aufgelöst? Warcdas eine andere Auflösung? Welche hat dein TV denn ? 
Zum anderen: poste bitte einmal ein easyinfo dabei. Was sagt htop(vorher via apt install htop installieren)  

MfG
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#18
Hi,

Plugin softhddevices-vaapi bietet für UHD auch max. nur "3840x2160" an
Code:
void cMenuSetupSoft::Create(void)
{
   static const char *const osd_size[] = {
"auto", "3840x2160", "1920x1080", "1280x720", "custom",
   };
   static const char *const video_display_formats_4_3[] = {
"pan&scan", "letterbox", "center cut-out",
   };
   static const char *const video_display_formats_16_9[] = {
"pan&scan", "pillarbox", "center cut-out",
   };
   static const char *const audiodrift[] = {
"None", "PCM", "AC-3", "PCM + AC-3"
   };
   static const char *const resolution[RESOLUTIONS] = {
"576i", "720p", "fake 1080i", "1080i", "UHD"
   };
Es wird unter Trusty wohl mesa, libva & xorg zu Alt sein. Leider lassen sich neuere
Versionen nich mehr unter Trusty übersetzen.

Gruss
Wolfgang

Zitieren
#19
Zuerst einmal: sorry, dass es bei mir so lange gedauert hat. Ich bin nicht eher dazu gekommen.

Die Qualitätseinstellungen bei "Skalierung" in Softhddevice sollte man wohl höchstens auf die Stufe "Normal" stellen. Aus HD-Zeiten hatte ich die noch auf "High Quality" stehen- und das lief eher so mittel. Nachfolgend einmal die Prozessorauslastung bei unterschiedlichen Ausgangsauflösungen:


Zitat:576i 2.53 2.05 1.14 max. 12% auf einem der 4 Kerne
720p 2.21 1.91 1.03 max. 18% auf einem der 4 Kerne
1080i 2.36 2.11 1.24 max. 8% auf einen der 4 Kerne
UHD 2.40 2.15 1.36 max. 16% auf einem der 4 Kerne, stärkere Beanspruchung der anderen Kerne

Ich hoffe, dass Experten damit etwas anfangen können. Vermutlich ist hier niemand wild darauf, wenn ich Screenshots vom Terminalfenster hier anhängen würde. Falls andere Infos gefragt sind- einfach nachfragen.

Das OSD auf 4k zu stellen ist keine gute Idee. Farbige Hintergründe werden dabei lediglich transparent dargestellt. Kurzum: skindesigner-Skins laufen eher nicht.

Bei der Wiedergabe von H.265-Aufnahmen, die über DVB-T2 gemacht wurden, haben bei Wiedergabe mit 4k-Auflösung merkwürdige Bildfehler. Am unteren Rand waren Pixelfehler, die in 1080 nicht zu sehen waren. Ferner kam es zu deutlich mehr Artefakten bei der Wiedergabe, die es in 1080 auch nicht gab.

Ein Problem, das sowohl unter 4k als auch 1080 besteht: das OSD ist scheinbar etwas größer als der Bildschirm, so dass das OSD abgeschnitten wird. Gibt es da eine Einstellmöglichkeit?

Viele Grüße
MrMoe


Angehängte Dateien
.zip   easyinfo.zip (Größe: 94,88 KB / Downloads: 1)
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#20
Hallo!

(30.04.2018, 14:08)MrMoe schrieb: Ein Problem, das sowohl unter 4k als auch 1080 besteht: das OSD ist scheinbar etwas größer als der Bildschirm, so dass das OSD abgeschnitten wird. Gibt es da eine Einstellmöglichkeit?
In den VDR-Einstellungen -> OSD kannst du die Höhe/Breite des Skins prozentual verkleinern,
oder im Setup von Plugin softhd selbst die Grösse einstellen.

Gruss
Wolfgang

Zitieren
#21
Cool! Die Option mit dem OSD habe ich immer übersehen. Jetzt passt es.

Korrektur: Die Bildfehler bei der Wiedergabe von H.265-Aufnahmen sind nicht reproduzierbar. Eben habe ich es noch einmal versucht- und genau an der gleichen Stelle derselben Aufnahme ist kein Fehler mehr sichtbar.
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren
#22
@MrMoe

du nutzt doch z.Zt Kernel-4.16.3 ...hast du mir Bitte die Ausgabe von
Code:
modinfo ddbridge
Zeile version: reicht ...möchte wissen ob 0.9.32 oder schon 0.9.33

Merci & Gruss
Wolfgang

Zitieren
#23
Zitat:filename:       /lib/modules/4.16.3-041603-generic/kernel/drivers/media/pci/ddbridge/ddbridge.ko
version:        0.9.32-integrated

Et voila!

Viele Grüße
MrMoe
ASRock J4205-ITX - Cine S2 V7 - Atric IR-WakeupUSB eco - easyVDR 3.5
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste