Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
New Plugin osd2web!
#1
Wink 
Hallo,

kleine Vorschau auf ein neues Plugin für VDR!
Plugin osd2web soll in Zukunft Plugin graphtftng ablösen, dass von horchi nicht mehr
weiterentwickelt wird.
Damit das Plugin unter VDR-2.2.0 läuft, muss der VDR gepatcht und alle Plugins(ca.120)
neu gegen VDR übersetzt werden. ...auch gibt es noch 2 neue Pakete da die Versionen unter Trusty
zu alt sind. Komme vermutlich erst nächstes WE dazu dies im easyVDR PPA zu bauen.
...zuerst will ich noch nee Neu-Installation machen, um alles zu testen.

Pic: osd2web Theme default mit FB
[Bild: vsezqegk.jpg]

Bei start mit "http://<ip-vdr>:4444/skins/default/index.html?theme=default"
wird der eingestellte Skin durch osd2web ersetzt, was zur folge hat, dass kein OSD mehr am
TV erscheint. ...klickt man auf das Symbol rechts Oben, gibt es wieder OSD am VDR.

Pic: osd2web Theme default mit OSD-Menu
[Bild: c3s93wsd.jpg]


Pic: osd2web Theme blue - 800x600
[Bild: hf86lyvt.jpg]

Pic: osd2web Theme plain
[Bild: rplpnsix.jpg]

Pic: easyportal mit osd2web
[Bild: 24sasuqe.jpg]

Wird osd2web so gestartet "http://<ip vdr>:4444/skins/horchiTft/index.html?onlyView=yes&theme=blue
gibt es nur Infos zum Programm & Timer, OSD am VDR ist verfügbar.
Pic: osd2web & live
[Bild: lyae7ps3.jpg]
Bleibt nur zu hoffen das beim bedienen mit FB das OSD-Menu auch auf dem TFT angezeigt wird,
damit man dann auch Mucke über das TFT abspielen kann ohne den TV einzuschalten wie es unter
graphtft(ng) funktioniert.

[Announce] osd2web Plugin
THX an horchi & Rechner für das neue Plugin!

Gruss
Wolfgang

Zitieren
#2
Hallo Wolfgang,

ich habe das Plugin mal auf meinem TestVDR installiert und angeschaut. Aktuell habe ich da aber leider kein Sat Signal verfügbar. Sieht aber doch sehr gut aus.

Gruß
Obelix
Zitieren
#3
Achja, um graphTFTng zu ersetzen, kann man ja einen Browser im Kiosk Modus und Vollbild mit der Option --display=0.1 starten. Ggf. über den Umweg der Variable DISPLAY=:0.1 in einem sep. Script.

Du hattest erwähnt, dass horchi das Plugin nicht mehr maintained. Das bedeutet, es kümmert sich keiner mehr darum?

Gruß
Obelix
Zitieren
#4
EDIT: Was hier stand stimmte nicht. Funktioniert.
Zitieren
#5
Hi,

(13.09.2017, 09:34)obelix schrieb: Aktuell habe ich da aber leider kein Sat Signal verfügbar. Sieht aber doch sehr gut aus.
ja man kann es starten aber es findet keine Kommunikation statt. Da VDR noch einen Patch
benötigt müssen auch alle Plugins neu gegen VDR übersetzt werden.
Zitat:Add AUX data fields to epg entries. This patch is used by some plugins like epg2vdr and osd2web
Wollte ich schon länger mal machen, leider war aber immer was wichtiger.

(13.09.2017, 09:42)obelix schrieb: Das bedeutet, es kümmert sich keiner mehr darum?
so ist es. Ob das nun ein Community maintained VDR project wird weiss ich nicht.
Uli Eckhardt hat zumindest mal einen Patch bereitgestellt, damit Plugin graphtftng gegen VDR-2.3.8
compiled.

Gruss
Wolfgang

Zitieren
#6
Servus,

zum testen habe ich Easyvdr 4 installiert, jedoch habe ich nun Schwierigkeiten das Plugin osd2web zu installieren. Über das EasyPortal - Einstellungen - Addons wird das Pugin nicht gelistet. In der ppa 4-vdr-unstable gibst jedoch dieses Plugin. Gibt es für Easyvdr 4 einen anderen Weg dieses Plugin zu installieren?
Oder kann man bei Easyvdr 4 noch keine Plugins installieren?

Grüsse
Zitieren
#7
Hallo,

Dir ist aber schon klar das dieses Plugin auch  vdr-epg-daemon(Sql-DB) benötigt der die Daten
für das Plugin bereitstellt.Dies ist für VDR-Server gedacht der dann die Daten über
Plugin epg2vdr an den Client weitergibt. ..für VDR der nicht immer läuft,
oder nur ein paar Stunden am Tag, ist "vdr-epg-daemon" nicht zu empfehlen.

(22.11.2018, 20:10)djggy schrieb: Gibt es für Easyvdr 4 einen anderen Weg dieses Plugin zu installieren?
Konsole:
Code:
sudo apt install vdr-plugin-<name>
danach das Plugin über OSD akivieren & VDR neu starten.

(22.11.2018, 20:10)djggy schrieb: Oder kann man bei Easyvdr 4 noch keine Plugins installieren?
du kannst alle Plugins die im "4-vdr-unstable PPA" sind installieren!
Da easyVDR-4.0 noch frühe Alpha ist, funktioniert sehr viel noch nicht wie gewohnt.

Gruss
Wolfgang

Zitieren
#8
Servus Wolfgang,

danke für Deine Hinweise, hilft mir schon erheblich weiter das Ganze zu verstehen.
Jetzt zum Testen wird der VDR nicht den ganzen Tag laufen, zu einen späteren Zeitpunkt dann schon.
Um das Plugin einfach mal testen zu können, habe ich es mit apt install installiert, allerdings ist es dann zum Aktivieren über OSD nicht sichtbar. Wo wird das Plugin eingetragen wenn es aktiviert wird?

Grüsse
Zitieren
#9
Hi,

Habe soeben bei EasyVersion4 erfolgreich osd2web installiert !

Beim ersten Versuch kam eine Meldung mit fehlenden und kollidierenden Abhängigkeiten.
Dann machte ich:
Code:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install vdr-plugin-osd2web

Dann ins OSD /System+Einstellungen/Einstellungen/Plugins-Einstellungen/Aktiviere Plugins/ und ganz unten in der Liste findet sich das Plugin.

Bist du sicher, daß es auch installiert wurde ?

Du findest alle installierten Plugins in /usr/lib/vdr/plugins
Ob es nach Aktivierung dann auch aktiv ist kann in /var/lib/vdr/sysconfig nachgesehen werden, die erste Konfig-Zeile lautet "PLUGINLIST=", dort folgen dann alle aktiven Plugins mit einem P vorangestellt.

Gruss,
gerrry
Zitieren
#10
Hallo,

Konsole:
Code:
apt-cache policy vdr-plugin-osd2web
gibt Auskunft ob installiert oder nicht!

Gruss
Wolfgang

Zitieren
#11
Servus,

ihr seid die Besten. Habe es genauso wie Ihr es beschrieben habt gemacht und schon funktioniert es.
Besten Dank nochmal

Grüsse
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste