Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Python Problem
#76
Hi, 
Ja Spotify läuft bei ihm damit auch jetzt. 

Vielen Dank dafür! 

Dafür hat es meine nächste HDD vorgestern zerlegt... 
Aber OT... 
MfG Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, Mygica t230 Stick als Tuner, nvidia Slim-GT218 512MB PCIe x1     -   v3.5-64
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD Red 4TB, 2x TT3200, ASUS GT730-SL-2GD3-BRK, mod. Digitainergeh.       -   v3.5-64
VDR5: GIGABYTE GA-G31M-S2L, Intel E5200, GT630 passiv, 2GB, 3TB, 6"  t6963c gLCD, mod. Digitainergeh.          -   v3.5-64
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, WD Green 2TB, 6" t6963c gLCD, 2x TT3200    -    v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
Zitieren
#77
(21.01.2018, 23:19)gb schrieb: Sollte widevine fehlen, kannst du dir ein installations Skript laden, am besten mit "nicht" Root rechten, da es mit vdr Rechten auch später ausgeführt werden muß!
Code:
cd /var/lib/vdr
wget http://nmacleod.com/public/libreelec/getwidevine.sh
Dann mit mc das Skript editieren und folgende Zeile anpassen:
Code:
[ -z "${ARCH}" ] && ARCH=$(grep -m1 ARCH= /etc/os-release | sed 's/"//g' | cut -d. -f2)
ändern in
Code:
[ -z "${ARCH}" ] &&  ARCH=x86_64
das Skript für vdr ausführbar machen
Code:
chown vdr:vdr getwidevine.sh
chmod 777 getwidevine.sh
mit  "./getwidevine.sh" auführen und das wars schon.


Gruß Aaron

Hi, ich versuche auch gerade das Skript zum Laufen zu bringen, bekomme aber nur diese Meldung:

Code:
*** THIS SCRIPT IS OBSOLETE ***

Any guide recommending the use of this script is out of date.

The widevine library should now be installed (and updated) by
script.module.inpustreamhelper.

script.module.inputstreamhelper will be installed automatically as a dependency
when installing video addons (Netflix etc.) from a suitable repository.

Contact the video add-on author if the video add-on does not support
script.module.inputstreamhelper.


Hat jemand eine Idee?
Gruß
Michael
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#78
(22.11.2018, 00:11)art.vandellay schrieb: Hi, ich versuche auch gerade das Skript zum Laufen zu bringen, bekomme aber nur diese Meldung:

Code:
*** THIS SCRIPT IS OBSOLETE ***

Any guide recommending the use of this script is out of date.

The widevine library should now be installed (and updated) by
script.module.inpustreamhelper.

script.module.inputstreamhelper will be installed automatically as a dependency
when installing video addons (Netflix etc.) from a suitable repository.

Contact the video add-on author if the video add-on does not support
script.module.inputstreamhelper.


Hat jemand eine Idee?
Hi Michael,

das mit dem Script ist ja schon ein paar Tage her. Unterdessen hat sich in der Richtung schon so einiges geändert.
Zitat:script.module.inputstreamhelper will be installed automatically as a dependency
when installing video addons (Netflix etc.) from a suitable repository.
ZB installierst du das netflix Addon, wird hier widevine durch den Inputstreamhelper automatisch geladen. Es gibt allerdings 2 Probleme, unser Kodi 18 Beta 1 ist zu alt, daher funktioniert der aktuellste Inputstream Adaptive nicht und ohne diesen folglich auch nicht die aktuellste widevine.
Kodi 18 Beta 3 oder andere lassen sich für Ubuntu 14.04. nicht mehr übersetzen, daher wird da für easyVDR3.x auch nichts mehr in der Richtung passieren.

Man kann durch Tricks trotzdem "noch" das netflix Addon wieder ans rennen bekommen, dazu müsste ich mal schauen wo ich was vor ein paar Monaten angepasst hatte. Zusätzlich benötigst du eine ältere widevine, das es mit dem älteren Inputstream Adaptive auch tut.

Gruß Aaron
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#79
Hallo Aaron,
Danke für die Rückmeldung! Wenn du noch etwas findest, super.
Ansonsten warte ich einfach auf easyvdr 4.0.
Ist nicht so dringend....
Gruß Michael
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#80
(22.11.2018, 08:59)art.vandellay schrieb: Wenn du noch etwas findest,  super.
Hallo Michael

Ich versuche es mal am Beispiel Netflix:

Voraussetzung: es ist ein Kodi 18 aus dem PPA von Wolfgang ( mango ) installiert

(21.01.2018, 01:14)mango schrieb: Hi,

in "/etc/apt/preferences.d" eine Datei "mango-kodi-build-1004" erstellen.
Inhalt:
Code:
Package: *
Pin: release o=LP-PPA-mango-vdr-kodi-build
Pin-Priority: 1004

PPA hinzufügen:
Code:
sudo add-apt-repository ppa:mango-vdr/kodi-build

Nun sollte das Verzeichnis "/var/lib/vdr/.kodi" noch umbenannt werden
Code:
sudo mv /var/lib/vdr/.kodi /var/lib/vdr/.kodi.dead

Update & Upgrade
Code:
sudo apt update && sudo apt upgrade

Danach Kodi starten Sprache einrichten und Kodi beenden.
Aus "/var/lib/vdr/.kodi.dead/userdata" die Lircmap.xml ins neue Verzeichnis kopieren.
...gleiches gilt für die "advancedsettings.xml", wenn die von Dir angepasst wurde.
Code:
sudo cp /var/lib/vdr/.kodi.dead/userdata/Lircmap.xml /var/lib/vdr/.kodi/userdata/Lircmap.xml
Rechte setzen:
Code:
sudo chown vdr:vdr /var/lib/vdr/.kodi/userdata/Lircmap.xml

Wird Kodi gestartet, sollte die FB wieder funktionieren und du kannst den Rest konfigurieren.
...kodinerds repo musst du jetz auch nochmals neu installieren.

Gruss
Wolfgang

Wenn wir das hier drüber hinter uns gelassen haben, holen wir uns noch benötigte Pakete ( da Wolfgang schon so nett war und uns diese Pakete vorbereitet hat, ist es ein Kinderspiel )
Code:
sudo apt-get install kodi-inputstream-adaptive
sudo apt-get install python-cryptodome

Nun holen wir uns das Netflix repo
Code:
cd /var/lib/vdr/Downloads
wget https://github.com/kodinerds/repo/raw/master/repository.netflix/repository.netflix-1.0.1.zip

Jetzt müssen wir erstmal Kodi starten, das inputstream-adaptive Addon aktivieren, dann das Netflix repository hinzufügen (aus zip Datei installieren und fremde Paketquellen erlauben aktivieren nicht vergessen )
Netflix Addon installieren, Anmeldung durchspielen und versuchen einen Film, oder Serie zu starten. Nun wird die Meldung kommen, das die widevine automatisch installiert werden soll, nach Abschluss versucht unser Netflix Addon den Stream zu starten, was aber gegen die Wand laufen wird.
Also Kodi wieder beenden und folgendes:

Jetzt holen wir uns die kompatible widevinecdm aus dem Netz, kopieren sie an ihren Platz und setzen die richtigen Rechte:
Code:
su easyvdr
sudo su
cd /var/lib/vdr/Downloads

wget https://dl.google.com/widevine-cdm/1.4.8.1008-linux-x64.zip

unzip 1.4.8.1008-linux-x64.zip

cp /var/lib/vdr/Downloads/libwidevinecdm.so /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm

chmod 777 /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm/libwidevinecdm.so

chown vdr:vdr /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm/libwidevinecdm.so

Das wars.. Big Grin

Gruß Aaron
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#81
Hallo Aaron,
danke für die ausführliche Anleitung!! Kodi 18 hatte ich bereits erfolgreich installiert.
Leider kann ich aber nach Installation von Widevine in Netflix nichts abspielen.

Es kommen folgende Meldungen:
"An update of Widevine CDM is required to play this content"
Danach kommt die Widevine CDM Eula für die aktualisierte Version, die man man akzeptieren muss.
Wählt man dann einen Film aus kommt:
"Mindestens eine Datei konnte nicht abgespielt werden. Für mehr Details Logdatei einsehen"

Unten ein Auszug aus der Logdatei. Ich vermute es bleibt beim Python Problem....

Vielen Dank!
Michael



Code:
22:58:50.826 T:139988687615744   ERROR: /var/lib/vdr/.kodi/addons/script.module.urllib3/lib/urllib3/util/ssl_.py:339: SNIMissingWarning: An HTTPS request has been made, but
the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause va
lidation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-wa
rnings
                                             SNIMissingWarning
22:58:50.826 T:139988687615744   ERROR: /var/lib/vdr/.kodi/addons/script.module.urllib3/lib/urllib3/util/ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is n
ot available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve
this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
                                             InsecurePlatformWarning
22:58:55.527 T:139988712793856   ERROR: GetDirectory - Error getting
22:58:57.857 T:139990005938240   ERROR: Previous line repeats 6 times.
22:58:57.858 T:139990005938240   ERROR: Control 50 in window 10025 has been asked to focus, but it can't
22:58:58.759 T:139988538119936 WARNING: CPythonInvoker(4, /var/lib/vdr/.kodi/addons/plugin.video.netflix/addon.py): the python script "/var/lib/vdr/.kodi/addons/plugin.vide
o.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
22:59:01.783 T:139988538119936 WARNING: CPythonInvoker(5, /var/lib/vdr/.kodi/addons/plugin.video.netflix/addon.py): the python script "/var/lib/vdr/.kodi/addons/plugin.vide
o.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
22:59:11.078 T:139988696008448 WARNING: CPythonInvoker(6, /var/lib/vdr/.kodi/addons/plugin.video.netflix/addon.py): the python script "/var/lib/vdr/.kodi/addons/plugin.vide
o.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
22:59:17.789 T:139990005938240  NOTICE: VideoPlayer: Opening: http://localhost:41743/manifest?id=80111501&dolby=true&hevc=false&hdr=false&dolbyvision=false
22:59:17.797 T:139988538119936  NOTICE: Creating InputStream
22:59:17.902 T:139988696008448 WARNING: CPythonInvoker(7, /var/lib/vdr/.kodi/addons/plugin.video.netflix/addon.py): the python script "/var/lib/vdr/.kodi/addons/plugin.vide
o.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
22:59:19.364 T:139988538119936   ERROR: AddOnLog: InputStream Adaptive: Unable to load widevine shared library (/var/lib/vdr/.kodi/cdm/libwidevinecdm.so)
22:59:19.364 T:139988538119936   ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed
22:59:19.364 T:139988538119936   ERROR: CVideoPlayer::OpenInputStream - error opening [http://localhost:41743/manifest?id=80111501&dolby=true&hevc=false&hdr=false&dolbyvisi
on=false]
22:59:19.364 T:139988538119936  NOTICE: CVideoPlayer::OnExit()
22:59:19.370 T:139990005938240   ERROR: PVRManager - OnPlaybackStopped - unsupported item type
22:59:19.371 T:139990005938240   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.netflix/?action=play_video&infoLabels=%7B%27rating%27%3A+0
%2C+%27season%27%3A+None%2C+%27tvshowtitle%27%3A+%27%27%2C+%27mediatype%27%3A+%27movie%27%2C+%27director%27%3A+u%27David+Yates%27%2C+%27duration%27%3A+8000%2C+%27year%27%3A
+2016%2C+%27genre%27%3A+u%27Preisgekr%5Cxf6nte+Filme%27%2C+%27plot%27%3A+u%27Lang+bevor+Harry+Potter+nach+Hogwarts+ging%2C+stattete+ein+abenteuerlustiger+Magizoologe+New+Yo
rk+einen+Besuch+ab.%27%2C+%27episode%27%3A+%27%27%2C+%27title%27%3A+u%27Phantastische+Tierwesen+und+wo+sie+zu+finden+sind%27%2C+%27mpaa%27%3A+%27NFLX+FSK-12%27%2C+%27writer
%27%3A+%27%27%2C+%27cast%27%3A+%5Bu%27Colin+Farrell%27%2C+u%27Jon+Voight%27%2C+u%27Carmen+Ejogo%27%2C+u%27Ron+Perlman%27%2C+u%27Alison+Sudol%27%2C+u%27Zo%5Cxeb+Kravitz%27%2
C+u%27Katherine+Waterston%27%2C+u%27Eddie+Redmayne%27%2C+u%27Johnny+Depp%27%2C+u%27Dan+Fogler%27%2C+u%27Ezra+Miller%27%2C+u%27Samantha+Morton%27%5D%7D&video_id=80111501&pin
=True]
22:59:19.391 T:139990005938240  NOTICE: CVideoPlayer::CloseFile()
22:59:19.391 T:139990005938240  NOTICE: VideoPlayer: waiting for threads to exit
22:59:19.391 T:139990005938240  NOTICE: VideoPlayer: finished waiting
22:59:19.413 T:139990005938240  NOTICE: CVideoPlayer::CloseFile()
22:59:19.413 T:139990005938240  NOTICE: VideoPlayer: waiting for threads to exit
22:59:19.413 T:139990005938240  NOTICE: VideoPlayer: finished waiting
22:59:24.417 T:139988538119936 WARNING: CPythonInvoker(8, /var/lib/vdr/.kodi/addons/plugin.video.netflix/addon.py): the python script "/var/lib/vdr/.kodi/addons/plugin.vide
o.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
22:59:27.466 T:139988538119936 WARNING: CPythonInvoker(9, /var/lib/vdr/.kodi/addons/plugin.video.netflix/addon.py): the python script "/var/lib/vdr/.kodi/addons/plugin.vide
o.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
22:59:29.997 T:139990005938240  NOTICE: VideoPlayer: Opening: http://localhost:41743/manifest?id=70264857&dolby=true&hevc=false&hdr=false&dolbyvision=false
22:59:30.001 T:139988529727232  NOTICE: Creating InputStream
22:59:30.086 T:139988538119936 WARNING: CPythonInvoker(10, /var/lib/vdr/.kodi/addons/plugin.video.netflix/addon.py): the python script "/var/lib/vdr/.kodi/addons/plugin.vid
eo.netflix/addon.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE
22:59:30.400 T:139988529727232   ERROR: AddOnLog: InputStream Adaptive: Unable to load widevine shared library (/var/lib/vdr/.kodi/cdm/libwidevinecdm.so)
22:59:30.400 T:139988529727232   ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed
22:59:30.400 T:139988529727232   ERROR: CVideoPlayer::OpenInputStream - error opening [http://localhost:41743/manifest?id=70264857&dolby=true&hevc=false&hdr=false&dolbyvisi
on=false]
22:59:30.400 T:139988529727232  NOTICE: CVideoPlayer::OnExit()
22:59:30.400 T:139990005938240   ERROR: PVRManager - OnPlaybackStopped - unsupported item type
22:59:30.400 T:139990005938240   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.netflix/?action=play_video&infoLabels=%7B%27rating%27%3A+0
%2C+%27writer%27%3A+%27%27%2C+%27episode%27%3A+1%2C+%27plot%27%3A+u%27Premierminister+Michael+Callow+hat+mit+einem+schockierenden+Dilemma+zu+k%5Cxe4mpfen%2C+als+Prinzessin+
Susannah%2C+ein+geliebtes+Mitglied+der+K%5Cxf6nigsfamilie%2C+entf%5Cxfchrt+wird.%27%2C+%27season%27%3A+1%2C+%27tvshowtitle%27%3A+u%27Black+Mirror%27%2C+%27title%27%3A+u%27D
er+Wille+des+Volkes%27%2C+%27mediatype%27%3A+u%27episode%27%2C+%27mpaa%27%3A+u%27-%27%2C+%27director%27%3A+%27%27%2C+%27genre%27%3A+u%27Preisgekr%5Cxf6nte+Serien%27%2C+%27y
ear%27%3A+2011%2C+%27duration%27%3A+2648%7D&video_id=70264857&pin=False&start_offset=-1]
22:59:30.405 T:139990005938240  NOTICE: CVideoPlayer::CloseFile()
22:59:30.405 T:139990005938240  NOTICE: VideoPlayer: waiting for threads to exit
22:59:30.405 T:139990005938240  NOTICE: VideoPlayer: finished waiting
22:59:30.426 T:139990005938240  NOTICE: CVideoPlayer::CloseFile()
22:59:30.426 T:139990005938240  NOTICE: VideoPlayer: waiting for threads to exit
22:59:30.426 T:139990005938240  NOTICE: VideoPlayer: finished waiting
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#82
Hast du nach der Meldung "Mindestens eine Datei konnte nicht abgespielt werden. Für mehr Details Logdatei einsehen" mal kodi beendet und das hier drunter durchgespielt?
(23.11.2018, 02:38)gb schrieb: Jetzt holen wir uns die kompatible widevinecdm aus dem Netz, kopieren sie an ihren Platz und setzen die richtigen Rechte:
Code:
su easyvdr
sudo su
cd /var/lib/vdr/Downloads

wget https://dl.google.com/widevine-cdm/1.4.8.1008-linux-x64.zip

unzip 1.4.8.1008-linux-x64.zip

cp /var/lib/vdr/Downloads/libwidevinecdm.so /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm

chmod 777 /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm/libwidevinecdm.so

chown vdr:vdr /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm/libwidevinecdm.so

Gruß Aaron
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#83
Habe es gerade nochmal durchgespielt, incl. reboot. Hat aber am Ergebnis nichts geändert.

Gruß
Michael
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#84
Ok, ich hab's eben in der vm wie oben #80 beschrieben mal mit einem neu installierten easyVDR3.5 probiert und konnte erfolgreich einen Film starten. :/
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#85
Kannst du mal schauen, welche version dein Inputstream Adaptive hat und welche dein netflix Addon?
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#86
Hallo,
ich habe folgende installiert:
Inputstream Adaptive 2.0.12 von peak3d
Netflix 0.12.18

Gruß
Michael
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#87
(24.11.2018, 00:46)gb schrieb: Ok, ich hab's eben in der vm wie oben #80 beschrieben mal mit einem neu installierten easyVDR3.5 probiert und konnte erfolgreich einen Film starten. :/

Das teste ich gleich auch mal.....
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#88
(24.11.2018, 13:30)art.vandellay schrieb: ich habe folgende installiert:
Inputstream Adaptive 2.0.12 von peak3d
Netflix 0.12.18
Hallo Michael, das stimmt alles soweit.

Anhand deines Logs sehe ich das er die widevine nicht laden kann, wenn es jedoch die richtige Version und auch mit lese Rechte auf VDR gesetzt ist, ist es mir unverständlich. Dann könnte es echt nur noch am Python liegen.
Ich hatte auch schon einen ähnlichen Fall, da musste ich neu aufsetzen, da Python vermurkst war.

Gruß Aaron
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#89
Hallo,
ich habe gerade neu installiert. Leider hat auch das nicht zum Ziel geführt. Vielleicht versuche ich es nachher nochmal am anderen Rechner.
Trotzdem Danke für Deine Mühe.
Ansonsten bleibt ja noch der Browser zum schauen....

Gruß
Michael
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#90
Was sagt denn ein:
Code:
ls -l /var/lib/vdr/.kodi/userdata/addon_data/script.mo
dule.inputstreamhelper/cdm
und ein
Code:
ls -l /var/lib/vdr/.kodi/cdm

Gruß Aaron
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#91
Code:
ls -l /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm

bringt:

Code:
insgesamt 6768
-rwxrwxrwx 1 vdr vdr 6920724 Nov 24 16:16 libwidevinecdm.so
-rw-rw-r-- 1 vdr vdr     479 Nov 24 16:16 LICENSE.txt
-rw-rw-r-- 1 vdr vdr     368 Nov 24 16:16 widevine_config.json

und
Code:
ls -l /var/lib/vdr/.kodi/cdm

Code:
lrwxrwxrwx 1 vdr vdr 92 Nov 24 16:16 libwidevinecdm.so -> /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm/libwidevinecdm.so

Gruß
Michael
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#92
Zitat:-rwxrwxrwx 1 vdr vdr 6920724 Nov 24 16:16 libwidevinecdm.so
Das ist die falsche libwidevinecdm, die ist zu neu, das erkenne ich an der Datei Größe. Du musst mal kontrollieren ob das kopieren der entzipten richtig funktioniert, gegebenfalls einfach mal mit mc machen.

So sollte sie eigentlich groß sein
Zitat:-rwxr--r-- 1 vdr vdr 5765212 Aug 3 2017 libwidevinecdm.so
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#93
ich habe auch die in der gleichen Größe (Version 1.4.8.1008) entpackt und verschoben.
In Kodi macht er dann ein Update und überschreibt sie mit der Version 1.4.9.1088.
Kann man das irgendwie verhindern?
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#94
Solange du nur die eine Datei libwidevinecdm.so unter /var/lib/vdr/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm/ überschreibst und andere nicht anfasst sollte er eigentlich nicht ständig ein neues Update mache wollen. Klappt bei mir immer ohne Probleme :/
Natürlich nicht vergessen, das diese die vdr Rechte vor kodi Start bekommen hat, sollte ja bekannt sein.
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#95
Beim Start Update verneinen !!
Vllt auch mal den Pfad kontrollieren
Zu widevine hin der Konfiguration des Plugins / Export /-Pfad / spezial:/....
und des InputStream Adaptive
Konfigurieren / Einstellungen - Inputstream Adaptive /General / Decrypter path /spezial://....cdm
Test-VDR : Digitainer I Gehäuse - MSI G41M-P25 Board - Intel P4 E6700 / 775 CPU - 2x1GB DDR3 RAM - MSI GT 720 PCI-e HDMI Grafik - Mystique SaTiX S2 SAT - 120GB SSD + 1TB Hitachi HDD - LG GH24 DL DVD - USB-STM32 V2 mit SMK RC6 MCE 50GB Fernbedienung - EasyVDR 3.5.02-64 Stable  - Softhddevice mit Pulseaudio und estuary4vdr OSD - Kodi 17.6 Final mit Confluence Skin
VDR-Client,s : Media MVP Scart, VIP BOX 1903, 1910 , EasyStream 0.6-18 für WIN 10, Raspberry PI 3 mit OpenElec 7.01 und TotalControl FB Code 0104 Lirc an Tsop 31238
Zitieren
#96
(27.11.2018, 15:05)Oberlooser schrieb: Beim Start Update verneinen !!
Vllt auch mal den Pfad kontrollieren
Zu widevine hin der Konfiguration des Plugins / Export /-Pfad / spezial:/....
und des InputStream Adaptive
Konfigurieren / Einstellungen - Inputstream Adaptive /General / Decrypter path /spezial://....cdm
Hallo Helmut 
Der Pfad, beide Versionen der Addons also peak 2.0.12 und netflix 0.13.18 sind korrekt. Allein das die widevine bei ihm immer erneuert wird ist der Fehler .
Im Home/cdm ist bei ihm ein Symlink vorhanden, der auf den Pfad zum helper verweist.

Edit: im Moment geht jedoch überhaupt nix, da netflix gerade alles umstellt und die Jungs vom netflix Addon alles neu anpassen müssen. Ich bin gespannt ob da ein Lichtblick bei raus kommt..

Gruß Aaron
Mediacenter
easyVDR3.5(4.x.x 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste