Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Easy VDR 0.8 und VGA2SCART
#1
Hallo,

ich bekomme leider auf verschiedenen RGB TVs keine VGA2SCART Ausgabe mit easyVDR 0.8 hin  :'(

Kann es sein, dass mein AT3ION-I Deluxe (ATOM mit ION) nicht mit VGA2SCART funktioniert  ??? Das Kabel stammt aus der Schmiede von Dr. Jones.

Hätte ich bei der Installation noch etwas besonderes beachten müssen :-\

Danke für jeden Tipp, 
Marco
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#2
Hallo erstmal: Nicht falsch verstehen:

Bei der Neuinstallation hast du die Frage VGA2Scart verwenden mit Ja beantwortet?

Wenn ja, dann bitte easyInfo posten (siehe meine Signatur)

Andy
VDR 1: ASRock mit Atom J1200, NVIDIA GT610, Lüfterlos, DD Cine DVB-C/T mit easyVDR 3.0
Zitieren
#3
Hallo,

bei der Installation habe ich VGA2SCART als Option ausgewählt.

Auch habe ich jetzt einen weiteren Rechner mit easyVDR 0.8 installiert.

Inzwischen erhalte ich auch eine Ausgabe auf dem RGB SCART - hier hatte mich die Schaltung Grafikkarte etwas überrascht. Wenn bei einem Systemstart der Digitale Anschluß gewählt ist dann kommt auch beim nachträglichen Stecken per VGA kein Signal - egal ob Digital noch angeschlossen ist oder nicht  ???

Jetzt ist lediglich das Bild doppelt, nicht vollständig und daher verschoben dargestellt. Liegt das an noch nicht ganz passenden Parametern?

Gibt es dafür Standardwerte oder müsste ich das ausprobieren (was mit dem Bildschirm etwas schwierig zu bewerkstelligen ist)?

Wenn ich richtig vermute, müsste dass evtl.in der xorg.conf einstellbar sein - oder doch über das nvidia tool?

Werden die Informationen aus easyInfo noch benötigt?

Danke,
Marco
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#4
Moin moin marco_weinkauf,

ja bitte den Indianer ;-]

MfG.
          MFG.
Sorry, das war mal dir Hardware, nu wechselt die zu oft ;-]
P4/1.8 1024 mit VGA, 100Mbit, USB 2.0 onBoard VGA misc HDDs CDRW2100E - DXR3 EM8300 original Hollywood+ V1 - DVB-C PCI Twinhan 2021 - DVB-T USB2.0 MSI DIGIVOX II V2+3
easyVDR 0.6.08 Kernel 2.6.28.9 - testing 0.7v5, vga2scart,... ;-]


Du Brauchen Hilfe? Wir brauchen Daten! <-> Indianer
Zitieren
#5
okok  :-X, hier die EasyInfo
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#6
Moin moin marco_weinkauf,

ok, klar die xorg.conf ist falsch,
kopiere mal aus /usr/local/src/patches/vga2scart/xorg_nvidia.conf nach /etc/X11/xorg.conf

MfG.
          MFG.
Sorry, das war mal dir Hardware, nu wechselt die zu oft ;-]
P4/1.8 1024 mit VGA, 100Mbit, USB 2.0 onBoard VGA misc HDDs CDRW2100E - DXR3 EM8300 original Hollywood+ V1 - DVB-C PCI Twinhan 2021 - DVB-T USB2.0 MSI DIGIVOX II V2+3
easyVDR 0.6.08 Kernel 2.6.28.9 - testing 0.7v5, vga2scart,... ;-]


Du Brauchen Hilfe? Wir brauchen Daten! <-> Indianer
Zitieren
#7
Hallo,

leider funktioniert nach dem kopieren die Grafikausgabe nach dem Systemstart gar nicht mehr, d.h. das bisher verschobene und doppelte Bild ist nach dem Start des X-Servers schwarz  ???

Ich habe die aktuelle EasyInfo angehängt. Was habe ich hier falsch gemacht?

Der cp Befehl war übrigens für mich nur so zu bewerkstelligen, dass ich wieder mit dem Digitalen Ausgang gebootet habe und dann per Shell den cp abgesetzt habe. Gibt es da keinen anderen, eleganteren Weg?  :-[

Danke,
Marco
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#8
Moin moin marco_weinkauf,

probiere mal meine xorg.conf,
wenn die auch nicht funkt, werde ich versuchen aus Deinem alten Log eine angepaste zu erstellen.

MfG.
          MFG.
Sorry, das war mal dir Hardware, nu wechselt die zu oft ;-]
P4/1.8 1024 mit VGA, 100Mbit, USB 2.0 onBoard VGA misc HDDs CDRW2100E - DXR3 EM8300 original Hollywood+ V1 - DVB-C PCI Twinhan 2021 - DVB-T USB2.0 MSI DIGIVOX II V2+3
easyVDR 0.6.08 Kernel 2.6.28.9 - testing 0.7v5, vga2scart,... ;-]


Du Brauchen Hilfe? Wir brauchen Daten! <-> Indianer
Zitieren
#9
Hallo Mfg,

Deine xorg.conf hat leider keine Besserung gebracht.

Ohne wirklich zu wissen was ich tue habe ich mir meine xorg.conf angeschaut und dort in der Section Default den Screen Wert von alt "Screen0" auf neu "Default Screen" geändert - war das richtig?

Danach bekomme ich zumindestens eine scheinbare SCART Ausgabe - allerdings wollte ich gerne den Desktop auf 1680x1050 per DVI ausgegeben haben. Ist das möglich? Wenn ja wie?

Danke,
Marco
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#10
Moin moin marco_weinkauf,

ehmja, was ich jetzt immer voraussetze war vga2scart, da ist es auch wichtig, dass vor dem Einschalten nur der vga2scartVGA-Stecker am Board steckt.

Wenn Du nun via DVI ausgeben möchtest nimm die rudimentäre xorg.conf aus Deinem ersten Log, die Automatik die beim Einschalten schaut was angeschlossen ist sollte via DVI die EDID auslesen und ein brauchbares Bild liefern, ließe sich dann mittels benutzerdefinierte edid.bin optimieren. Oder mittel etsprechender Modeline.

Welcher "Monitor"namen/typ ist es denn jetzt?

Imho ist meine xorg.conf[sub]vga2scart[sub]vdpau[/sub][/sub] mit Screen1(DVI) für graphTFT konfiguriert.

MfG.
        MFG.
Sorry, das war mal dir Hardware, nu wechselt die zu oft ;-]
P4/1.8 1024 mit VGA, 100Mbit, USB 2.0 onBoard VGA misc HDDs CDRW2100E - DXR3 EM8300 original Hollywood+ V1 - DVB-C PCI Twinhan 2021 - DVB-T USB2.0 MSI DIGIVOX II V2+3
easyVDR 0.6.08 Kernel 2.6.28.9 - testing 0.7v5, vga2scart,... ;-]


Du Brauchen Hilfe? Wir brauchen Daten! <-> Indianer
Zitieren
#11
Hallo MFG,

dank Deiner Hilfe habe ich das Ursprüngliche Problem lösen können, ich kann die VGA2SCART auf dem ION Board nutzen. Vielen Dank  Smile



Hier meine Lösung

Was ich nicht wusste, war dass nach der Installation manuell die /usr/local/src/patches/vga2scart/xorg_nvidia.conf nach /etc/X11/xorg.conf kopiert werden muß. Allerdings ist diese xorg.conf nach meiner Sichtweise noch nicht funktionsfähig, da die Screen Bezeichnungen nicht zueinander passend sind.

/usr/local/src/patches/vga2scart/xorg_nvidia.conf:
Code:
Section "ServerLayout"
   Screen      0  "Screen0" 0 0
   ...
EndSection

Section "Screen"
    Identifier     "Default Screen"
    ...
EndSection

Angepasst habe ich
Code:
Section "ServerLayout"
    Screen      0  "Default Screen" 0 0
    ...
EndSection

Section "Screen"
    Identifier     "Default Screen"
    ...
EndSection

Damit funktioniert es für mich und ich bin zufrieden  Big Grin

Gruß,
Marco
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#12
Nochmal Nachfrage: Mit Screen 0 in Server Layout geht es nicht, mit Default Screen hast du ein Bild per VGA2Scart?

Achja - und ein K+ für die Eigeninitiative, das recherchieren und die Rückmeldung!

Andy
VDR 1: ASRock mit Atom J1200, NVIDIA GT610, Lüfterlos, DD Cine DVB-C/T mit easyVDR 3.0
Zitieren
#13
Moin moin sinai,

denke primär ist es wichtig, dass in der Definition und im Aufruf das gleiche steht ;-]

@marco_weinkauf
magst mal mit 2x Screen0 testen?

MfG.
        MFG.
Sorry, das war mal dir Hardware, nu wechselt die zu oft ;-]
P4/1.8 1024 mit VGA, 100Mbit, USB 2.0 onBoard VGA misc HDDs CDRW2100E - DXR3 EM8300 original Hollywood+ V1 - DVB-C PCI Twinhan 2021 - DVB-T USB2.0 MSI DIGIVOX II V2+3
easyVDR 0.6.08 Kernel 2.6.28.9 - testing 0.7v5, vga2scart,... ;-]


Du Brauchen Hilfe? Wir brauchen Daten! <-> Indianer
Zitieren
#14
Hallo

@sinai
Danke. Ja nach Abänderung in der Section "Serverlayout" den "Screen" auf "Default Screen" habe ich nach dem Starten des X-Servers ein Bild per RGB am TV. Beim Booten und in den Konsolen habe ich weiterhin ein verzerrtes Bild, aber das wüsste ich nicht wie abzuändern.

@MFG
Wenn ich Dich richtig verstanden habe, meinst Du ich sollte mal ausprobieren in der Section "Screen" den "Indentifier" analog zur initialen "/usr/local/src/patches/vga2scart/xorg_nvidia.conf" auch auf "Screen0" setze, so dass Section "Serverlayout" und Section "Screen" zueinander passen.

Kann ich heute im Laufe des Tages testen, bin mir aber sehr sicher, dass es bei gleicher Bezeichnung funktionieren wird.

Gruß,
Marco
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#15
Ja auch bei gleicher Bezeichnung mit Screen0 funktioniert die VGA2SCART Ausgabe.

Zitat:@MFG
Wenn ich Dich richtig verstanden habe, meinst Du ich sollte mal ausprobieren in der Section "Screen" den "Indentifier" analog zur initialen "/usr/local/src/patches/vga2scart/xorg_nvidia.conf" auch auf "Screen0" setze, so dass Section "Serverlayout" und Section "Screen" zueinander passen.

Kann ich heute im Laufe des Tages testen, bin mir aber sehr sicher, dass es bei gleicher Bezeichnung funktionieren wird.

Gruß,
Marco
HTPC: AT3ION-I Deluxe, 4 GB
Testsystem: ASUS P5K, GeForce 9400 Silent, 2 GB
Zitieren
#16
Hallo,
Ich teste gerade Easyvdr 0.8.06 mit xineliboutput, vdr-sxfe und xbmc welcher über VGA2SCART an eine 16:9 Röhre angeschlossen werden soll.
Der VDR läuft einwandfrei über VGA2SCART, versuche ich allerdings XBMC zu starten, beendet sich der VDR und man sieht nur die X-Oberfläche. Anbei ein Auszug aus dem user.log.
Zum Test habe ich dann einen Montior angeschlossen. Mit der standardmäßig installierten xorg.conf startet XBMC an dem Monitor ohne Probleme. Benutze ich am Monitor die xorg.conf für VGA2SCART beendet sich wieder nur der VDR, ansonsten passiert nichts. Ich vermute dass es an der xorg.conf liegen könnte.
Hat jemand eine Idee was das Problem sein könnte?
Gruß
Michael


Angehängte Dateien
.log   user.log (Größe: 3,49 KB / Downloads: 3)
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren
#17
Hallo,
Problem ist gelöst.
In der xorg.conf fehlte der Eintrag
Load          "glx"

Michael
Easyvdr 3.5.02-stable - VDR 2.2.0 - 4.4.0-96-generic- Gigabyte GA-H97M-HD3 - Zotac GeForce GT 730 - Pentium G3240 - 8GB Ram - 500GB SATA WD - cineS2 DVB-S2 6.5
[Testrechner: ASUS M3N78-VM - AMD Sempron 140 - 2GB Ram - cineS2 DVB-S2 Twin Tuner (v5)]


Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste