Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[vertagt auf EasyVDR v4] Moonlight zum PChanger hinzufügen
#51
Hallo Aaron,

Der Inhalt der /etc/vdr/pulseaudio.conf lautet:


Code:
CARD_PULSEAUDIO_NAME="alsa_card.pci-0000_01_00.1"
CARD_PULSEAUDIO_NAME_NOT_USED="alsa_card.pci-0000_00_1b.0"
CARD_OUTPUT_PROFILE="output:hdmi-stereo-extra1"
SINK_COMBINED="no"
CARD_PROFILE_OPTIONS="pcm"
GAMING_CARD_PULSEAUDIO_NAME="none"
GAMING_CARD_PULSEAUDIO_NAME_NOT_USED="none"
GAMING_CARD_OUTPUT_PROFILE="none"
GAMING_CARD_PROFILE_OPTIONS="none"

pactl info ergab


Code:
easyvdr@easyVDR:~$ pactl info
Server-Zeichenkette: /run/user/1000/pulse/native
Bibliotheks-Protokollversion: 32
Server-Protokollversion: 32
ist lokal: ja
Client-Index: 10
Tile-Größe: 65472
Name des Benutzers: easyvdr
Rechnername: easyVDR
Name des Servers: pulseaudio
Version des Servers: 11.1
Standard-Abtastwert-Angabe: s16le 2ch 44100Hz
Standard-Kanal-Zuordnung: front-left,front-right
Standard-Ziel: alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1
Standard-Quelle: alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor
Cookie: 061b:59b9


Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#52
Hi Sven
Hier ist das Problem:
Zitat:Server-Zeichenkette: /run/user/1000/pulse/native
Name des Benutzers: easyvdr
Pulseaudio User ist easyvdr, sollte jedoch vdr sein.

Hier müsste mal Bleifuss2 ran, er steht da tiefer in der Materie und wüsste vielleicht wo welcher Hebel zu setzen wäre.

Der Rest sieht gut aus.

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#53
Guten Morgen

mach mal Volgendes:

Pchanger-> 0 (Desktop) rechte Taste Terminal öffnen.
Dann pactl info

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#54
Hallo nochmal, 

Nachdem ich nun gefühlte dutzende Male das System neu installiert habe, kommt jetzt meine Antwort. 
Zum einen fuhr das System gar nicht erst hoch, zum anderen kam mehrere Mal ein Sperrbildschirm, den ich nicht mit Benutzername und Passwort entsperren konnte.
Aktuell geht es bis auf den Ton mit dem Standardskin. Mit Skindesigner hab ich Farb- und Texturverläufe. Aber das nur nebenbei.

Außerdem habe ich mich bei dieser Installation mal für Passthrough-Audio entschieden. Übertragen wird im PCM-Format. Auch hier ist das Testrauschen auf dem TV super zu hören, aber der VDR-Ton eben nicht.
Die Ausgabe von pactl info im LxTerminal war wie folgt:

Zitat:easyvdr@easyVDR:~$ pactl info
Server-Zeichenkette: unix:/run/user/1000/pulse/native
Bibliotheks-Protokollversion: 32
Server-Protokollversion: 32
ist lokal: ja
Client-Index: 9
Tile-Größe: 65472
Name des Benutzers: easyvdr
Rechnername: easyVDR
Name des Servers: pulseaudio
Version des Servers: 11.1
Standard-Abtastwert-Angabe: s16le 2ch 44100Hz
Standard-Kanal-Zuordnung: front-left,front-right
Standard-Ziel: alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1
Standard-Quelle: alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor
Cookie: 3499:7511
Ich hoffe, ihr könnt damit etwas anfangen. Dies übersteigt (noch) meine Linux-Kenntnisse.

Gru
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#55
Startet bei dir alles automatisch oder musst du dich anmelden?

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#56
Ich hab bei der Installation "Automatisch anmelden" aktiviert.
Könnte das durch ein Update wieder zurückgesetzt worden sein?

Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#57
Nabend

Zitat:Ich hab bei der Installation "Automatisch anmelden" aktiviert.

Das ist das Problem, dadurch hast du die Standardanmeldung gekillt.
Wo und wann hast du das eingestellt?

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#58
Bei der Installation von Lubuntu:
"Benutzer", "Computername" etc.
Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#59
Hallo Sven

Genau und da bitte das Häkchen für automatisches Anmelden weglassen. So langsam erklärt es auch warum dieses Problem bei einigen weiteren Usern beim Testen passiert ist.

Ich habe das Häkchen noch nie gesetzt, da wir das automatische anmelden durch unserere install Routine umsetzen. 
Habe ja auch schon gut 50x installiert und nie dieses User Problem gehabt.
Ich bin gespannt auf dein Feedback..

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#60
Ich kümmere mich drum. Heute wird's aber bestimmt leider nichts mehr.
Melde mich...

Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#61
Hallo, da bin ich, 

Häkchen nicht gesetzt, aber bei jedem Erststart nach der Easyvdr-Installation bleibt der PC beim Startbild (blaues Easyvdr-Bild mit sich drehendem Drittelkreis) stehen und geht auch nach 30min nicht weiter. Laut syslog kann das System X nicht starten und gibt dann irgendwann auf.
Dennoch habe ich es durch Ausführen des Setups über SSH geschafft, die Ersteinrichtung auszuführen. Danach fuhr der PC auch normal hoch und startete den VDR.


Einen Ton hab ich aber immernoch nicht.  Big Grin
Als nächstes probiere ich dann xpadneo.

Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#62
Cool da passieren ja seltsame Dinge auf deinem PC 

Du kennst ja das Spiel, 1x bitte den Inhalt von der pulseaudio.conf und die Ausgabe von pactl info. 
Ich werde mal parallel easyVDR4 installieren und schauen ob sich etwas geändert hat. 


Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#63
Ich habe jetzt 2x in der VM installiert und jedes mal lief PulseAudio mit dem User vdr unter X, also soweit alles korrekt.

Was mir aufgefallen ist, ist das mein virtuelles Ausgabe Device nach einem Reboot nicht mehr da war und ich damit überhaupt kein Sounddevice mehr hatte. Das kann jetzt aber auch an meiner Oracle VM liegen. Vielleicht installiere ich die Tage nochmal auf meinem Testrechner unter realen Bedingungen.

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#64
Hallo Aaron,

Zitat:Du kennst ja das Spiel, 1x bitte den Inhalt von der pulseaudio.conf und die Ausgabe von pactl info.

Wie du wünschst:

pulseaudio.conf
Zitat:CARD_PULSEAUDIO_NAME="alsa_card.pci-0000_01_00.1"
CARD_PULSEAUDIO_NAME_NOT_USED="alsa_card.pci-0000_00_1b.0"
CARD_OUTPUT_PROFILE="output:hdmi-stereo"
SINK_COMBINED="no"
CARD_PROFILE_OPTIONS="pcm"
GAMING_CARD_PULSEAUDIO_NAME="none"
GAMING_CARD_PULSEAUDIO_NAME_NOT_USED="none"
GAMING_CARD_OUTPUT_PROFILE="none"
GAMING_CARD_PROFILE_OPTIONS="none"

pactl info

Zitat:easyvdr@easyVDR:/$ pactl info
Server-Zeichenkette: /run/user/1000/pulse/native
Bibliotheks-Protokollversion: 32
Server-Protokollversion: 32
ist lokal: ja
Client-Index: 3
Tile-Größe: 65472
Name des Benutzers: easyvdr
Rechnername: easyVDR
Name des Servers: pulseaudio
Version des Servers: 11.1
Standard-Abtastwert-Angabe: s16le 2ch 44100Hz
Standard-Kanal-Zuordnung: front-left,front-right
Standard-Ziel: auto_null
Standard-Quelle: auto_null.monitor
Cookie: 865c:59df

Ich habe keine Ahnung, warum das bei mir so ist, wenn es bei euch doch funktioniert. Huh
Hab ich vielleicht was vergessen? Ich habe nur die easy_inst.zip runtergeladen, entpackt, ausführbar gemacht und gestartet.
Der Rest geht doch dadurch allein, oder? Laut Beschreibung sollte ich doch den Rest darunter vergessen. Undecided 

Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#65
Startest du das Skript in einer alt+ctrl+f2 Konsole oder unter der x Konsole? 

Ich installiere gerade auf meinem NVIDIA Testsystem, mal schauen was dabei raus kommt. 

Gruss Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#66
Ich starte es in der Strg+Alt+F2 - Konsole.

Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#67
Ich bekomme einfach nicht raus, was bei dir anders läuft Big Grin
Hier meine Ausgabe vom NVidia Test PC:
Zitat:vdr@easyVDR:~$ pactl info
Server-Zeichenkette: unix:/run/user/2000/pulse/native
Bibliotheks-Protokollversion: 32
Server-Protokollversion: 32
ist lokal: ja
Client-Index: 37
Tile-Größe: 65472
Name des Benutzers: vdr
Rechnername: easyVDR
Name des Servers: pulseaudio
Version des Servers: 11.1
Standard-Abtastwert-Angabe: s16le 2ch 44100Hz
Standard-Kanal-Zuordnung: front-left,front-right
Standard-Ziel: alsa_output.pci-0000_05_00.1.hdmi-stereo-extra1
Standard-Quelle: alsa_output.pci-0000_05_00.1.hdmi-stereo-extra1.monitor
Cookie: ae9c:7a61

An deiner pactl Ausgabe gefallen mir einige Sachen überhaupt nicht:
Zitat:Server-Zeichenkette: /run/user/1000/pulse/native
Name des Benutzers: easyvdr
Sagt mir User easyvdr ist am Drücker

Und das sieht auch nicht gut aus:
Zitat:Standard-Ziel: auto_null
Standard-Quelle: auto_null.monitor
auto_null ist ein Dummydevice und hier wird der Sound ins Nirvana gejagt.

Nun zu deinen Einstellungen:
Zitat:CARD_OUTPUT_PROFILE="output:hdmi-stereo"
Hast du hier bei der Auswahl den TV Namen hinter dem Ausgang zu stehen gehabt? Es ist sehr selten, das hdmi-stereo tatsächlich der HDMI Ausgang ist, aber natürlich möglich. Im Regelfall ist es meisten hdmi-stereo-extra1
Im Endefekt, muss nach deinen Einstellung der Soundtest funktionieren, wenn der geht stimmt auch der Ausgang.

hmmm... schwieriger Fall mit dem X User Desaster

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#68
Hallöle,
ich habe im Setup bei der Auswahl der Audioausgabe immer "LG TV" (mein Fernseher) als erkannte Hardware hinter "hdmi-stereo-extra1" gehabt.
Etwas anderes habe ich nie ausgewählt.
Ich probiere morgen mal spaßeshalber was anderes. Mehr als 'nicht funktionieren' kann's ja nicht.

Gruß
Sven
VDR1: easyVDR 3.5 Stable 64bit, Intel i3, Nvidia GeForce GT710, 4GB DDR3, LG BluRay-Brenner als Client
Amazon FireTVStick mit KODI und VNSI-Client
NAS: Readynas Ultra2 Plus mit Ubuntu Server 14.04 und (yaVDR-)-minisatip-/Streamdev-/Aufnahme-Server
Gaming-Server: u. A. AMD 1920x, 32GB DDR5, 3x GTX1050Ti, 1TB NVMe
Zitieren
#69
Hallo Sven 

Ok hdmi-stereo-extra1 wäre ja auch ok, aber bei deiner Auswahl ( pulseaudio.conf ) stand dann hdmi-stereo.
Würde vorschlagen einfach nochmal das pulseaudio Setup zu durchlaufen und das auswählen wo lgtv hinter steht. Dann die pulseaudio.conf bitte posten.
Ps:
Bleibt trotzdem noch das Rechteprobleme mit easyvdr und vdr. 

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste