Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Installation – GraphTFT + Touch + eGalax
#1
Hallo Zusammen,

Ich habe eine PCIe nVidia Grafikkarte. Über HDMI gehe ich auf den TV, über VGA ans Display.

Wenn ich das Display berühre, erhalte ich einen Mauszeiger (Kreuz) auf dem Display und auf dem TV. Die Kalibrierung funktioniert nicht, da versucht wird den TV zu kalibrieren. Ein „erfolgreiches Touch-Event“ funktioniert somit auch nicht.

Den Thread von Florian.Reinartz https://www.easy-vdr.de/showthread.php?t...ght=egalax

für EasyVDR 1.0 habe ich durchgearbeitet, ohne Erfolg. Läuft die Einrichtung der Touch-Funktion in V3.5 heute anders ab oder habe ich in dem Thread was übersehen?

Muss ich den Original Display Treiber von OrigenAE (Kernel 4.x) installieren oder ist der Treiber schon an Bord?

Bin für alle Hinweise dankbar.

Gruß Oli

VDR im Aufbau: Asrock 880GMH/USB3 Board - AMD Athlon II X2 240e 2,8 GHz CPU - 2x2GB DDR3 RAM - Digital Device DVBS2-V6.2 Dual SAT PCIe - ASUS GeForce GT430 Grafik -passiv gekühlt- OrigenAE X15e Gehäuse + 7" Touchscreen eGalax - EasyVDR 3.5
VDR in Rente: Fujitsu Siemens D1183 Board - Intel Pentium III 800 MHz - Technotrend DVB-S Premium Rev. 1.6 PCI - 500 MB RAM - OrigenAE X15e Gehäuse + 7" Touchscreen eGalax- EasyVDR 0.8
Zitieren
#2
Thumbs Up 
Hallo zusammen,

bin mittlerweile ein wenig schlauer ;-)

Original-Treiber für eGalax-Display wird nicht benötigt - sind in V3.5 enthalten! Confused

Die Touchfunktion reagiert nun im entsprechenden Theme (hier DeepPurple). Ich hatte vorher ein falsches Theme ausgewählt (anthraize), bei dem die Touch-Funktion nicht integriert ist.

In den Einstellungen von graphtft, bekomme ich beim Ausführen der "Test"-Funktion, Koordinaten zurück. Allerdings stimmen "berührte" Punkte und angezeigte Koordinaten nicht überein - ich habe einen Versatz von 10-20 Pixel in x und y-Richtung! Da ich die Objekte in der "Calibrate"-Funktion nicht sauber treffe, läuft diese auch nicht durch. Angry

Dann habe ich versucht mit

Code:
$ xinput_calibrator
die Kalibrierung in einem Terminal auszuführen.

Ergebnis:
Code:
Unable to connect to X server

Kann ja auch nicht funktionieren. Sobald das Toolmenü aufgerufen wird (um ein Terminal zu öffnen), beendet sich das Display (und auch der X-Server).

Wie kann ich xinput-calibrator zusammen mit einem aktiven X-Server ausführen?

Hilfeeeeeeeeee.
Zitieren
#3
Hi 

setz mal den Befehl DISPLAY=:0 vor deinem Befehl, also..

Code:
DISPLAY=:0 xinput_calibrator
Dann wird das Programm von der Konsole auf x umgelenkt. 
Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#4
Hallo Aaron,

danke für Dein Hilfestellung!

Über den PChanger und eine Konsole konnte ich mittels

Code:
DISPLAY=:0 xinput_calibrator

auf X umlenken und die Kalibrierung des 7" TFT durchführen.

Die erhaltenen Koordinaten und Einstellungen habe ich dann in /etc/X11/xorg.conf.d/99-calibration.conf eingetragen:

Inhalt der Datei:

Code:
Section "InputClass"
        Identifier "calibration"
        MatchProduct "eGalax Inc."
        Option "Calibration" "103 1829 1878 100"
        Option "SwapAxes" "1"
EndSection


Blöderweise habe ich nach wie vor das Problem:

- Mauszeiger nach Neustart auf TV
- Mauszeiger muss via Maus auf vom TV auf den 7" TFT geführt werden, nun funktioniert die Touch-Funktion ABER am Rand versetzt (ca. 1cm)
- Kalibrieren hilft nicht - Umlaufend außen (ca. 1cm) die ich via touch nicht erreiche
- Als würde die Touchfolie mit 7" Größe nur 5" oder 6" bedienen während das Bild auf dem TFT volle 7" hat

Jemand eine Idee?

Gruß Oli


VDR im Aufbau: Asrock 880GMH/USB3 Board - AMD Athlon II X2 240e 2,8 GHz CPU - 2x2GB DDR3 RAM - Digital Device DVBS2-V6.2 Dual SAT PCIe - ASUS GeForce GT430 Grafik -passiv gekühlt- OrigenAE X15e Gehäuse + 7" Touchscreen eGalax - EasyVDR 3.5

VDR in Rente: Fujitsu Siemens D1183 Board - Intel Pentium III 800 MHz - Technotrend DVB-S Premium Rev. 1.6 PCI - 500 MB RAM - OrigenAE X15e Gehäuse + 7" Touchscreen eGalax- EasyVDR 0.8
Zitieren
#5
Hi, wenn ich mir den anderen Beitrag anschaue, gab es ja identische Probleme mit Mauszeiger und dem nicht zu bedienenden Rand.
Ich interpretiere aus dem anderen Beitrag, das Florian das Display mit 800x600 und den calibrierten Werten zumindest bis an den Rand zum Rennen gebracht hat. 

Mit was für eine Auflösung fährst du das Display? 

Ps: Ich hab kein touch Display und daher auch Null Ahnung davon. Aber wenn ich das so lese sollte es sicher mit viel Geduld umsetzbar sein... 

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren
#6
Hi,

@gb: danke für die Tipps. Ich fahre die Auflösung 800x600. Ich habe jetzt Tage lang alle möglichen Einstellungen probiert. Erfolglos. Die Berührung auf dem Touch wird immer als Mouse-Event auf dem TV interpretiert...

Ich muss aber noch erwähnen, dass ich KEIN externes eGalax-Display habe, sondern ein fest verbautes in meinem OrigenAE-Gehäuse. Dazu gibt es aktuelle Treiber auf http://www.eeti.com.tw/drivers_Linux.html

Bis jetzt hatte ich nicht versucht die Treiber zu installieren. Zum einen wird hier


https://wiki.ubuntuusers.de/Archiv/Touchscreen/
extra darauf hingewiesen, dass "...von einer nachträglichen Installation von Herstellersoftware jedoch abzuraten,..." ist, wenn der "... Screen mit Bordmitteln funktioniert...". Er funktioniert - aber nur zu 80%.

Allerdings ist fraglich, ob das Display von 2007 noch mit den aktuellen Treibern unterstützt wird. Mit alten Treiber geht es wg. der aktuellen Kernelversion nicht.

Also, ich die Herstellertreiber-Installation gestartet:

-> Meldung: Kein Device gefunden - Installation braucht laufendes X - somit kann ich nur bei laufendem VDR installieren

Weiter - Mit PChanger+Terminal die Installation versucht

-> Meldung: Keine Berechtigung - Ich muss root sein zum Installieren - es gibt aber keinen Root mehr
https://wiki.easy-vdr.de/index.php?title=Root

Das Passwort für vdr kenne ich nicht und habe ich auch nicht gefunden - sudo su geht auch nicht.

Wie installiere ich unter einem laufen VDR mit Root-Rechten die Treiber?

Hilfeeeeeeeeeeeeeee.

Gruß Oli


VDR im Aufbau: Asrock 880GMH/USB3 Board - AMD Athlon II X2 240e 2,8 GHz CPU - 2x2GB DDR3 RAM - Digital Device DVBS2-V6.2 Dual SAT PCIe - ASUS GeForce GT430 Grafik -passiv gekühlt- OrigenAE X15e Gehäuse + 7" Touchscreen eGalax - EasyVDR 3.5

VDR in Rente: Fujitsu Siemens D1183 Board - Intel Pentium III 800 MHz - Technotrend DVB-S Premium Rev. 1.6 PCI - 500 MB RAM - OrigenAE X15e Gehäuse + 7" Touchscreen eGalax- EasyVDR 0.8
Zitieren
#7
Hi Oli

Xterminal auf:

Code:
su easyvdr
sudo su

Manchmal sind es die Kleinigkeiten, die einen aufhalten Big Grin

Gruß Aaron
Mediacenter
easyVDR4.Alpha(Lubuntu18.04 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste