Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Wlan-Einrichtung in Version 2.5 - Info
#1
Wlanstick einstecken und Installation ohne Netzwerkkabel starten (Wlan-Stick Logilink WL0145)


Wlan bei Installation auf DHCP stellen: SSID und Wlan-Schlüssel eingeben, sonst keine Einstellungen machen.
(Keine Einstellungen im Toolmenü zu Wlan oder Lan machen, das ist alles von Anfang an in anderen Dateien ([/etc/NetworkManager/system-connections/] zum bearbeiten die Rechte auf 600 setzen zum schreibschützen wieder auf 400  stellen, siehe auch https://wiki.ubuntuusers.de/NetworkManag..._ohne_GUI/))


Beim Installieren „kein weiteres Update“ anwählen
Bei Netzwerkanwahl „chancel“ wählen
Nach Installation Neustart ohne irgendwelche Einstellungen
Bei Setup-Einrichtung Netzwerk als Wlan erkennen lassen, kann sein das nichts erkannt wird.
Neustart. Danach in /etc/network/interfaces alles löschen bis auf:


# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback


Statische IP-Adresse


Um eine statische IP-Adresse zu bekommen folgendes in der Konsole machen:
sudo -s
mcedit /etc/NetworkManager/system-connections/Wi-Fi connection 1
Den folgenden Eintrag ersetzen:

[ipv4]
method=auto

durch

[ipv4]
#method=auto
method=manual
dns=192.168.178.1;
addresses1=192.168.178.25;24;192.168.178.1


192.168.178.1 sollte die Adresse des eigenen Routers sein
192.168.178.25 sollte die gewünschte statische Adresse sein
192.16.178.1 sollte die Gateway-Adresse bzw. die Router-Adresse sein

So funktioniert bei mir nach 50000 maligen einrichten das Wlan mit dem Stick nun einwandfrei. Ich habe eine statische IP-Adresse eingestellt.
Ich vermeide es im Setup des OSD Einstellungen zum Wlan zu verändern


Da ich für einen Bekannten einen HD-VDR aufziehe und er keine LAN-Leitung im Wohnzimmer hat, soll das ganze über WLAN laufen.

Bei Einrichtung eines Netzwerkes mit Netzwerkkabel und Wlan-Stick gibt es anscheinend einige Schwierigkeiten. Da Lan + Wlan hier bei mir nicht gleichzeitig richtig kompatibel lief habe ich zuerst über Netzwerkkabel installiert und danach die Wlan-Einstellungen angepasst.

Das Problem:
Die Installation über den PCChanger (Netzwerk-Setup) endete mit der Fehlermeldung: network-manager-gnome kann nicht installiert werden.
Solange das Netzwerkkabel angesteckt ist funktioniert der Wlan-Stick nicht. Wenn dann das Netzwerkkabel abgesteckt ist wird der Wlan-Stick zwar erkannt (lsusb), ist aber ohne Funktion. Dieses Problem kann nur durch das erstellen einer wpa_supplicant.conf im Ordner etc geändert werden, da diese standartmässig nicht vorhanden ist und ein Verweis auf diese in den VDR-Einstellungen gesetzt ist (System & Einstellungen – Einstellungen – System-Einstellungen – Netzwerk – Wlan-Einstellungen – WPA-Einstellungen). Beim nächsten Problem findet der Wlan-Stick dann keine IP-Adresse bzw. es wird beim Hochfahren eine durch DHCP zugewiesen, aber diese wird nach ca. 5 Sekunden wieder deaktiviert oder ähnliches. Deshalb wird hier von mir der Wlanstick mit einer Statischen IP-Adresse „bestückt“.

Natürlich sollte man vorher wissen

a welcher IP-Adress-Bereich beim eigenen Netzwerk verwendet wird

b die Wlan-Daten (Name und Schlüssel) bekannt sein

a kann z.B. anhand der Netzwerkkabel-Adresse ermittelt werden. Einfach im VDR-Menü in die Systemeinstellungen-Systeminformationen navigieren und dort sollte dann bei angeschlossenen Netzwerkkabel die IP-Adresse der aktiven Netzwerkkarte angezeigt werden. Die Wlan-IP-Adresse könnte dann z.B. um eine Ziffer erhöht werden. Netzwerk-Adresse Kabel ist z.B.: 192.168.178.12,
dann könnte die Wlan-IP-Adresse 192.1687.178.13 verwendet werden. Wenn noch kein anderes Netzwerkgerät (Tablet, Smartphone etc.) diese verwendet oder statisch eingestellt ist.

b sollte in den Router-Unterlagen bzw. im Router selbst nachgeschaut werden können


Mein Wlan-Stick ist der LogLlink WL0145 (Chipsatz Ralink RT5370 ID 148f:5370)

Vor der Standartinstallation den Stick (und das Netzwerkkabel) schon einstecken und eingesteckt lassen. Während der Installation (zum Schluss hin) kommt irgendwann eine Abfrage ob die Konfigurationsdatei für Lan, Wlan oder benutzerdefinierte Datei verwendet wird. Ich habe die benutzerdefinierte Datei gewählt.

Nach dem automatischen Neustart zuerst im VDR-Menü nach „System & Einstellungen – Einstellungen – System-Einstellungen – Netzwerk“ navigieren und den Modus von LAN oder LAN&WLAN auf WLAN umstellen, danach nochmals neu starten.
Mit der Windowstaste an der Tastatur in den PCChanger-Modus wechseln. F3 für System Programme und danach mit 1 Terminal anwählen.
Oder mit Alt+Ctrl+F2 in das Terminal wechseln.

Im Ordner etc die Datei wpa_supplicant.conf erstellen:

sudo mcedit /etc/wpa_supplicant.conf

in dieser Datei dann folgende Werte eintragen:

ctrl_interface=/var/run/wpa_supplicant
ap_scan=2
update_config=1

network={
ssid=Der-Wlan-Name
scan_ssid=1
psk=Der-Wlan-Schlüssel
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

danach abspeichern. Der Datei noch Rechte geben:

sudo chmod 755 wpa_supplicant.conf

Jetzt A oder B:

A:
Im Order etc/network die Datei interfaces bearbeiten und eine feste IP-Adresse für das Wlan zuweisen:

sudo mcedit /etc/network/interfaces

auto lo
iface lo inet loopback

auto wlan0
iface wland0 inet static
address 192.168.178.13(eine aus dem bekannten Adressbereich, die noch nicht statisch benutzt wird)
netmask 255.255.255.0
gateway 192.168.178.1 (sollte die Router-IP sein)
wireless yes
wireless-channel 7 (an den eigenen Kanal anpassen)
wpa-driver wext         (an den eigenen Treiber anpassen)
wpa-conf /etc/wpa_supplicant.conf

danach abspeichern.

B:
Im VDR-Menü: „System & Einstellungen – Einstellungen – System-Einstellungen – Netzwerk – Wlan-Einstellungen“ hier die Einstellungen für die IP-Adressen eingeben (Wichtig - WLAN DHCP auf „nein“ setzen)

Nach einem
sudo reboot
sollte der VDR neu starten, das Netzwerk bzw. der Wlanstick aktiv sein und eine statische IP-Adresse besitzen. Überprüfen kann man dies, indem man ins VDR-Menü navigiert „System & Einstellungen – Befehle – Netzwerk – Netzwerkeinstellungen ansehen“
Dort sollte dann, wenn man mit der Pfeiltaste nach unten „scrollt“ bei wlan0 die eingetragene IP-Adresse vorhanden sein.

Hinweis: Lustigerweise wird bei mir nicht die eingetragene IP-Adresse verwendet sondern eine andere. Ich hatte 192.168.178.35 eingetragen und es wird 192.168.178.31 verwendet. Wenn ich 192.168.178.39 eintrage wird 192.168.178.40 verwendet und das obwohl im VDR-Menü die gleichen Werte eingetragen sind - kurios.

Die Daten zur Wlan-Verschlüsselung können ermittelt werden über:

sudo iwlist scanning

siehe auch:

https://wiki.ubuntuusers.de/WLAN/wpa_supplicant/
Testgeräd: Asrock J4105M: 8GB Ram: Festplatte: Adapter PCIe-PCI: TT S2-1600: später noch DD V6.5: PicoPSU 90W: ScalarNetzteil 96W: Atric Rev.5
Software: Lubuntu 18.04 & Unstable4-Pakete

Aktuell: EasyVDR 2.5: Silverstone SG02F: Athlon X2 245e: MSI 890GXM-G65: DDR3 -  4x 2GB-Kit Corsair: LG-Brenner: DigitalDevice Cine S2 V6.5: MSI - Geforce GT720: Atric Rev.5:
Phillips SBC RU 7060: Logilink WL0145 für Mediathek:
System-Platte: SSD Samsung irgendwas
Video0-Platte:  WD10JPVT

Ausser Betrieb:

VDR-HD 2: EasyVDR 1.0:Silverstone SG02F:Athlon 3700+:ASRock 939A790GMH:2 GB DDR-Ram:LG-Brenner:1x TT S2 4100:1x TT S2 1600:Nvidia G210:WD10JPVT:Atric Rev.5:
Phillips SBC RU 7060

VDR-HD 3: EasyVDR 0.8:FSC E5600:Samsung HD204UI 2TB:1x TT-S2-1600:Club3D8400GS

VDR-SD: EasyVDR 0.606:FSC Siemens E5600:Sempron 3000+
D2264:TTS-2300:HD322HJ:512MB:GDR8164b
Neue Rückwand + RiserCard
Zitieren
#2
Hallo

Ich habe jetzt nicht alles gelesen.

Wlan einrichten:

1. Netzwerk im Setup einrichten (wegen IP Adressen / Freigaben usw)
2.
Code:
/etc/network

Genau so anpassen:
Code:
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Neu booten Pchanger Netzwerksetup, das Netzwerk mit der gleichen IP wie vorher im Setup einrichten. Das war es dann.

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#3
Hallo Bleifuss2,

Ich hatte jetzt extra nocheinmal auf eine andere Festplatte installiert..

zu 1. genauso hab ich das gemacht ( Ich hatte aber DHCP beide male drin)
zu 2. das stand ja von Anfang an drin.

Zitat:Das Problem:
Die Installation über den PCChanger (Netzwerk-Setup) endete mit der Fehlermeldung: network-manager-gnome kann nicht installiert werden.

Gruß
Testgeräd: Asrock J4105M: 8GB Ram: Festplatte: Adapter PCIe-PCI: TT S2-1600: später noch DD V6.5: PicoPSU 90W: ScalarNetzteil 96W: Atric Rev.5
Software: Lubuntu 18.04 & Unstable4-Pakete

Aktuell: EasyVDR 2.5: Silverstone SG02F: Athlon X2 245e: MSI 890GXM-G65: DDR3 -  4x 2GB-Kit Corsair: LG-Brenner: DigitalDevice Cine S2 V6.5: MSI - Geforce GT720: Atric Rev.5:
Phillips SBC RU 7060: Logilink WL0145 für Mediathek:
System-Platte: SSD Samsung irgendwas
Video0-Platte:  WD10JPVT

Ausser Betrieb:

VDR-HD 2: EasyVDR 1.0:Silverstone SG02F:Athlon 3700+:ASRock 939A790GMH:2 GB DDR-Ram:LG-Brenner:1x TT S2 4100:1x TT S2 1600:Nvidia G210:WD10JPVT:Atric Rev.5:
Phillips SBC RU 7060

VDR-HD 3: EasyVDR 0.8:FSC E5600:Samsung HD204UI 2TB:1x TT-S2-1600:Club3D8400GS

VDR-SD: EasyVDR 0.606:FSC Siemens E5600:Sempron 3000+
D2264:TTS-2300:HD322HJ:512MB:GDR8164b
Neue Rückwand + RiserCard
Zitieren
#4
Hallo

Zitat:zu 2. das stand ja von Anfang an drin.

Bei dir müsste mehr in der Datei stehen, alles löschen so das sie wie oben aussieht.
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
Zitieren
#5
Ich habe meine alte Anleitung überarbeitet und einen leichteren Weg gefunden (siehe ersten Beitrag)
Testgeräd: Asrock J4105M: 8GB Ram: Festplatte: Adapter PCIe-PCI: TT S2-1600: später noch DD V6.5: PicoPSU 90W: ScalarNetzteil 96W: Atric Rev.5
Software: Lubuntu 18.04 & Unstable4-Pakete

Aktuell: EasyVDR 2.5: Silverstone SG02F: Athlon X2 245e: MSI 890GXM-G65: DDR3 -  4x 2GB-Kit Corsair: LG-Brenner: DigitalDevice Cine S2 V6.5: MSI - Geforce GT720: Atric Rev.5:
Phillips SBC RU 7060: Logilink WL0145 für Mediathek:
System-Platte: SSD Samsung irgendwas
Video0-Platte:  WD10JPVT

Ausser Betrieb:

VDR-HD 2: EasyVDR 1.0:Silverstone SG02F:Athlon 3700+:ASRock 939A790GMH:2 GB DDR-Ram:LG-Brenner:1x TT S2 4100:1x TT S2 1600:Nvidia G210:WD10JPVT:Atric Rev.5:
Phillips SBC RU 7060

VDR-HD 3: EasyVDR 0.8:FSC E5600:Samsung HD204UI 2TB:1x TT-S2-1600:Club3D8400GS

VDR-SD: EasyVDR 0.606:FSC Siemens E5600:Sempron 3000+
D2264:TTS-2300:HD322HJ:512MB:GDR8164b
Neue Rückwand + RiserCard
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste