Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
gelöst: DFAtmo 0.4.0: XBMC und Postplugin
#1
Hallöichen mal wieder...

in diesem fred: http://www.easy-vdr.de/forum/index.php?t...#msg123187

wurde für den aufruf von postplugins der ort /var/lib/vdr/easyvdr-frontend-sxfe.conf genannt.

die conf unter easyvdr2.0 sieht etwas anders aus:

Code:
FULLSCREEN="--fullscreen"
GEOMETRY=""
ACCELERATION=""
VIDEO_DEVICE="--video=vdpau"
VIDEO_MISCELLANEOUS_1="--post tvtime:method=use_vo_driver"
VIDEO_MISCELLANEOUS_2=""
FRONTEND_DISPLAY=":0"
AUDIO_DEVICE="--audio=alsa"
AUDIO_DEVICE_PASSTHROUGH=""
AUDIO_MIXER_CHANNEL=""
AUDIO_MISCELLANEOUS=""
MISCELLANEOUS="--syslog --reconnect --tcp"
CONFIG_FILE="--config /var/lib/vdr/plugins/xineliboutput/config "
CONNECTSTRING="xvdr://127.0.0.1:37890"

die conf unter easyvdr 1.0:

Code:
PARAMETER="--post dfatmo:driver=serial,driver_param=/dev/ttyUSB0,top=1,bottom=1,left=1,right=1,center=1,gamma=10,brightness=180 --syslog --fullscreen --config /var/lib/vdr/plugins/xineliboutput/config --audio=alsa --post tvtime:method=use_vo_driver --reconnect --tcp"
CONNECTSTRING="xvdr://127.0.0.1:37890"

bin etwas verwirrt....

kann mir einer da einen entscheidenden tip geben

mfg
Max
VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren
#2
hi
hab in der zwischenzeit mir das original gekauft, und hab nen philips TV.
hab so lange atmo gehabt, das die home-regierung ihre zustimmung gab son
überteuerten tv zu kaufen Smile

aber, den einzigen --post aufruf, den ich jetzt sehe ist inder
zeile:
[size=1.35em]VIDEO_MISCELLANEOUS_1[/size]
eventuell müssen jetzt aber alle --post aufrufe einzeln gemacht werden, darum der "hinweis" mit
der "leerzeile"
[size=0.7em]VIDEO_MISCELLANEOUS_2=""[/size][size=0.7em]und so weiter...

ein vrsuch ist es wert.

Gruss goaman


[/size][size=1em]edit: Im prinzip sind alle parameter aufrufe von "früher" ja noch vorhanden, man hat nur die datei ein
bisschen aufgeräumt, und die parameter sortiert, fast schon kommentiert, um übersicht zu schaffen.

[/size]
vdr1 hw: DD Cine S2 (DVB-S2) V6.5 via Unicable, DD Cine C2T2 V7 (C/C2/T/T2), NV GT630 rev2, Q9300 Gigabyte GA-EP45-DS3, Samsung SSD 830 128, sata WD20EFRX-68E, Atric5 seriel, SilverStone SST-GD09B, Harmony 300,650
sw: Easyvdr 3.5.02-64 kernel 4.4.0-96

vdr2 hw: Intel NUC 5i3RYH, 8gb ram, SSD 850 EVO,TT-TVStick CT2-4400 usb, Harmony 300,650 -- sw: Easyvdr 3.5.02-64 kernel 4.4.0-96

vdr3: hw: Intel NUC DN2820FYK, 4gb ram, SSD 850 EVO, Edision Optimuss DVB-C/T/T2 USB Stick, One4All 7960. oder Harmony 300,650 -- sw: Easyvdr2.5.0-64 - kernel 3.19.0-64


Zitieren
#3
Hallo an alle... Wink

irgendwie will das board nicht unter easy2.0... >Sad

beim aufruf unter xbmc kriege ich meldung:

DFAtmo: output driver error: could not open serial port device '/dev/ttyUSB0': Permission denied

jetzt frage ich micht: vonwem.... oder warum  Wink

hat eine idee wie ich das rausfinden kann?

mfg
Max
VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren
#4
und da bin ich wieder...

so hab dem user noch zur gruppe "dialout" zugewiesen:

Code:
adduser easyvdr dialout

jetzt ist unter xbmc alles hell... Big Grin

jetzt noch postplugin...

VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren
#5
Hi,

(11.01.2015, 22:46)MaxPayne_2007 link schrieb: irgendwie will das board nicht unter easy2.0... >Sad

beim aufruf unter xbmc kriege ich meldung:

DFAtmo: output driver error: could not open serial port device '/dev/ttyUSB0': Permission denied

jetzt frage ich micht: vonwem.... oder warum  Wink

hat eine idee wie ich das rausfinden kann?
liegt an
a.) falscher Pfad
b.) Addon für Frodo
Code:
    # copy xbmc plugin to the addon dir if it exists
    if [ -d /var/lib/vdr/.xbmc/addons/packages ]; then
    cp /usr/lib/dfatmo/dfatmo-xbmc-addon.zip /var/lib/vdr/.xbmc/addons/packages
    cp /usr/lib/dfatmo/dfatmo-xbmc-frodo-addon.zip /var/lib/vdr/.xbmc/addons/packages
    fi
werde "dfatmo" neu bauen wenn passendes Addon.

Gruss
Wolfgang

Zitieren
#6
Hi,

(11.01.2015, 22:56)MaxPayne_2007 link schrieb: und da bin ich wieder...

so hab dem user noch zur gruppe "dialout" zugewiesen:

Code:
adduser easyvdr dialout

jetzt ist unter xbmc alles hell... Big Grin
Ok ..dann bau ich es trotzdem neu da bis jetzt nur vdr der Gruppe zugeordnet wird.
Code:
    # add user vdr to group dialout
    adduser vdr dialout

P.S
..was soll noch geändert werden?

Gruss
Wolfgang

Zitieren
#7
und da bin ich schon wieder....

jetzt mache ich eine kleine zusammenfassung:

Ich habe hier http://karatelight.de/index.php/atmo-main.html am laufen... das gute stücke hatte ich bereits unter 0.8, 1.0 und jetzt auch unter easyvdr2.0 am laufen

Für die Ansteuerung hat sich bei mir dfatmo gut bewehrt, daher nutze ich das hier auch.

1.DFAtmo 0.4.0 von https://github.com/durchflieger/DFAtmo geladen und mittels
Code:
dpkg-buildpackage -b -D -tc -sd -us -uc

die deb-packete gebildet und anschließend über dpkg -i packet installiert

2. XBMC:
für xbmc wird beim bauen der deb packete auch gleich das winaddon als zip erstellt. dies kann man dann bequem installieren.
die settings.xml von dfatmo sieht nach der richtigen einstellung folgendermaßen aus:

Code:
<settings>
    <setting id="analyze_rate" value="35" />
    <setting id="analyze_size" value="0" />
    <setting id="bottom" value="1" />
    <setting id="bottom_left" value="true" />
    <setting id="bottom_right" value="true" />
    <setting id="brightness" value="300" />
    <setting id="center" value="true" />
    <setting id="custom_driver" value="" />
    <setting id="darkness_limit" value="1" />
    <setting id="driver" value="serial" />
    <setting id="driver_param" value="/dev/ttyUSB0&amp;proto:classic" />
    <setting id="edge_weighting" value="60" />
    <setting id="enabled" value="true" />
    <setting id="filter" value="2" />
    <setting id="filter_delay" value="0" />
    <setting id="filter_length" value="500" />
    <setting id="filter_smoothness" value="50" />
    <setting id="filter_threshold" value="40" />
    <setting id="gamma" value="10" />
    <setting id="hue_threshold" value="99" />
    <setting id="hue_win_size" value="3" />
    <setting id="left" value="1" />
    <setting id="log_level" value="1" />
    <setting id="output_rate" value="20" />
    <setting id="overscan" value="0" />
    <setting id="right" value="1" />
    <setting id="sat_win_size" value="3" />
    <setting id="top" value="1" />
    <setting id="top_left" value="true" />
    <setting id="top_right" value="true" />
    <setting id="uniform_brightness" value="1" />
    <setting id="wc_blue" value="255" />
    <setting id="wc_green" value="255" />
    <setting id="wc_red" value="255" />
    <setting id="weight_limit" value="12" />
</settings>

danach xbmc neustarten addon aktiv schalten und alles wieder schön hell

3. vdr:
beim vdr habe ich in der leeren zeile (VIDEO_MISCELLANEOUS_2) von easyvdr-frontend-sxfe.conf:
Code:
FULLSCREEN="--fullscreen"
GEOMETRY=""
ACCELERATION=""
VIDEO_DEVICE="--video=vdpau"
VIDEO_MISCELLANEOUS_1="--post tvtime:method=use_vo_driver"
VIDEO_MISCELLANEOUS_2="--post dfatmo:driver=serial,driver_param=/dev/ttyUSB0,top=1,bottom=1,left=1,right=1,center=1,gamma=10,brightness=180"
FRONTEND_DISPLAY=":0"
AUDIO_DEVICE="--audio=alsa"
AUDIO_DEVICE_PASSTHROUGH=""
AUDIO_MIXER_CHANNEL=""
AUDIO_MISCELLANEOUS=""
MISCELLANEOUS="--syslog --reconnect --tcp"
CONFIG_FILE="--config /var/lib/vdr/plugins/xineliboutput/config "
CONNECTSTRING="xvdr://127.0.0.1:37890"
PARAMETER="--post dfatmo:driver=serial,driver_param=/dev/ttyUSB0,top=1,bottom=1,left=1,right=1,center=1,gamma=10,brightness=180"

den zweiten postaufruf eingetragen...

vdr neustart und auch hier alles schön hell.... Big Grin


mfg
Max
VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren
#8
Hi,

(11.01.2015, 23:18)MaxPayne_2007 link schrieb: 1.DFAtmo 0.4.0 von https://github.com/durchflieger/DFAtmo geladen und mittels

2. XBMC:
für xbmc wird beim bauen der deb packete auch gleich das winaddon als zip erstellt. dies kann man dann bequem installieren.
die settings.xml von dfatmo sieht nach der richtigen einstellung folgendermaßen aus:

3. vdr:
beim vdr habe ich in der leeren zeile (VIDEO_MISCELLANEOUS_2) von easyvdr-frontend-sxfe.conf:
Code:
FULLSCREEN="--fullscreen"
GEOMETRY=""
ACCELERATION=""
VIDEO_DEVICE="--video=vdpau"
VIDEO_MISCELLANEOUS_1="--post tvtime:method=use_vo_driver"
VIDEO_MISCELLANEOUS_2="--post dfatmo:driver=serial,driver_param=/dev/ttyUSB0,top=1,bottom=1,left=1,right=1,center=1,gamma=10,brightness=180"
FRONTEND_DISPLAY=":0"
AUDIO_DEVICE="--audio=alsa"
AUDIO_DEVICE_PASSTHROUGH=""
AUDIO_MIXER_CHANNEL=""
AUDIO_MISCELLANEOUS=""
MISCELLANEOUS="--syslog --reconnect --tcp"
CONFIG_FILE="--config /var/lib/vdr/plugins/xineliboutput/config "
CONNECTSTRING="xvdr://127.0.0.1:37890"
PARAMETER="--post dfatmo:driver=serial,driver_param=/dev/ttyUSB0,top=1,bottom=1,left=1,right=1,center=1,gamma=10,brightness=180"
wir haben ja die gleichen Quellen, die "easyvdr-frontend-sxfe.conf" kann ich anpassen.
Kannst du die Orginal "https://github.com/durchflieger/DFAtmo/blob/master/settings.xml" auf Deine Werte anpassen?

Gruss
Wolfgang

Zitieren
#9
Hallo Wolfgang,

diese setting ist doch eine vorlage...

wenn dann hier....

Code:
    <category label="General">
        <setting id="enabled" label="Launch on startup" type="bool" default="false"/>
        <setting id="driver" label="Output driver" type="labelenum" values="null|file|serial|df10ch|custom" default="null"/>
        <setting id="custom_driver" label="Output driver name" value="" type="text" enable="eq(-1,4)"/>
        <setting id="driver_param" label="Driver parameters" value="" type="text" enable="!eq(-2,0)+!eq(-2,3)"/>
        <setting id="log_level" label="Log level" type="enum" values="NONE|ERROR|INFO|DEBUG" default="1"/>
    </category>

siehe bild meine einstellungen

mfg
Max


Angehängte Dateien Thumbnail(s)
   
VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren
#10
super ..

du hast in deiner easyvdr-frontend-sxfe.conf moch zweimal den
--post aufruf. Der ist doch bestimmt aus den "ersten" Versuchen. Ichnehme mal an
man braucht ihn nur einmal. Nur falls es zur verwirrung dienen soll, nimm es
doch noch mal raus, um alles "sauber" zu machen. Smile

Gruss Goaman
vdr1 hw: DD Cine S2 (DVB-S2) V6.5 via Unicable, DD Cine C2T2 V7 (C/C2/T/T2), NV GT630 rev2, Q9300 Gigabyte GA-EP45-DS3, Samsung SSD 830 128, sata WD20EFRX-68E, Atric5 seriel, SilverStone SST-GD09B, Harmony 300,650
sw: Easyvdr 3.5.02-64 kernel 4.4.0-96

vdr2 hw: Intel NUC 5i3RYH, 8gb ram, SSD 850 EVO,TT-TVStick CT2-4400 usb, Harmony 300,650 -- sw: Easyvdr 3.5.02-64 kernel 4.4.0-96

vdr3: hw: Intel NUC DN2820FYK, 4gb ram, SSD 850 EVO, Edision Optimuss DVB-C/T/T2 USB Stick, One4All 7960. oder Harmony 300,650 -- sw: Easyvdr2.5.0-64 - kernel 3.19.0-64


Zitieren
#11
Hallöichen Goa,

ich wollte vollständigkeitshalber das ganze abrunden....

hab nach dem ersten post noch mein post dran gehängt => vdr fährt nicht hoch
hab nach dem ersten post noch ein post aufruf dran geschrieben und dann mein dfatmo etc... => vdr fährt nicht hoch

nur die letzte lösung: in jeder zeile ein postaufruf geht!

mfg
Max
VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren
#12
Hallo zusammen,

wollte an dieser Stelle noch mal erwähnen, dass dfatmo 0.4.0 auch unter easyvdr 2.1 auch einwandfrei läuft...

Aber es fehlt immer noch: adduser easyvdr dialout

fügt das bitte in das nächste update hinzu...  Wink

mfg
Max
VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren
#13
Hallöichen an dieser Stelle..

musste mal heute nach festplattenkrasch 2.5 neu installieren...

dabei ist aufgefallen, dass beim paket dfatmo der user easyvdr nicht zu dealout gehört und zusätzlich notwendiges paket libxine-dfatmo-plugin nicht integriert ist. Rolleyes

ansonsten läufts...

mfg
Max
VDR 1: easyVDR 3.5 64Bit: Gigabyte B250M-D3H+ GT1030 + 2 x NOVA-HD-S2 + VDPAU (Wohnzimmer). DFAtmo in XBMC und als POST-plugin
VDR 2: easyVDR 3.0 32Bit: ASUS N4L-VM DH + T2400 + 1GB DDR2 + NOVA-HD-S2 + Server (Kelller)
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste