Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Frage zu Installation easyVDR 1.0.0 der per WLAN ins Netz verbunden werden soll
#1
Hallo zusammen,

ich möchte einen easyVDR v1.0.0 neu aufsetzen der per WLAN ins Netzwerk verbunden werden soll.

Bisher habe ich immer easyVDR auf Rechnern installiert, die per Kabel im Netzwerk verbunden waren.

Wie läuft die Installation bei einer WLAN-Verbindung ab?

Die WLAN-Karte ist übrigens diese hier:

http://www.reichelt.de/index.html?ACTION...253bWN951N

Danke vorab für Eure Hilfe.

Gruß Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#2
Treiber sollten im Kernel dabei sein

Dann per Setup, OSD oder Editor konfigurieren

Anleitung: http://wiki.ubuntuusers.de/WLAN

Andy
VDR 1: ASRock mit Atom J1200, NVIDIA GT610, Lüfterlos, DD Cine DVB-C/T mit easyVDR 3.0
Zitieren
#3
Hallo Andy,

danke für die Info.

Da bin ich ja mal gespannt;-)

Gruß Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#4
Hallo zusammen,

ich benötige Unterstützung bei der Einrichtung des WLAN-Zugriffs für den easyVDR.

Über das Setup kann ich nicht gehen, weil ich per Putty übers LAN auf den easyVDR zugreife,
und ich mir sonst den Ast absägen würde auf dem ich sitze;-)

Über die direkte Konsole des easyVDR kann ich nicht arbeiten, weil ich dort nichts erkennen kann.
Dort werden nur "komische" Zeichen angezeigt.
Das ist von Anfang an bei der v1.0.0 so gewesen.
Deshalb habe ich die Installation übers Netz per Putty-Zugriff durchlaufen lassen.

Im OSD des easyVDR habe ich unter "Einstellungen\Systemeinstellungen\Netzwerk\WLAN-Einstellungen" folgendes eingestellt:

- DHCP = JA
- SSID = <SSID meines WLANs>
- Mode = Managed
- Verschlüsselung = WPA

WPA-Einstellungen

- Configfile = /etc/wpa_supplicant.conf
- Treiber = wext
- Eapol-Version = 1
- AP-Scan = 1
- WPA-Protokoll = RSN
- Pairwise = CCMP
- Group = CCMP
- Passphrase-Art = HEX

Ich weiß nicht was ich bei Kanal angeben soll.
Der WLAN-Accesspoint hat da "Auto" stehen.
Also habe ich die Einstellung so gelassen:

- CHANNEL = 7

-------------------------------------------------------------------------------
Nachtrag:

Über "sudo iwlist scanning" habe ich herausgefunden, dass ich Kanal 6 einstellen muss
-------------------------------------------------------------------------------

Ich habe mir mit wpa_passphrase eine Datei wpa_supplicant.conf generiert und in /etc abgelegt:

Code:
network={
    ssid="<SSID meines WLANs>"
    psk=.....
}


iwconfig liefert

Code:
wlan0     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lspci -nn | grep -i net liefert

Code:
01:0d.0 Network controller [0280]: Atheros Communications Inc. AR922X Wireless Network Adapter [168c:0029] (rev 01)

So, und jetzt bin ich mit meinem Latein am Ende;-)

Wer kann mir weiterhelfen?

Vielen Dank vorab für jede Unterstützung!

Gruß Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#5
Hallo,

so, jetzt habe ich im Setup mal "LAN & WLAN" ausgewählt.

Jetzt ergibt "iwconfig" folgende Ausgabe:

Code:
wlan0     IEEE 802.11bgn  ESSID:"LinksysE2000"
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC-Adresse>
          Bit Rate=5.5 Mb/s   Tx-Power=20 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=23/70  Signal level=-87 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:5  Invalid misc:0   Missed beacon:0

Und "ifconfig" gibt folgende Ausgabe

Code:
wlan0     Link encap:Ethernet  Hardware Adresse <MAC-Adresse>
          inet6-Adresse: ..../64 Gültigkeitsbereich:Verbindung
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX packets:662 errors:0 dropped:0 overruns:0 frame:0
          TX packets:689 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:89370 (89.3 KB)  TX bytes:111072 (111.0 KB)

Wenn ich das hier richtig interpretiere dann wird die Hardware schonmal erkannt (sowohl die WLAN-Karte als auch der Accesspoint),
und es wird auch versucht, per WLAN eine Verbindung aufzubauen (jedenfalls sehe ich die MAC-Adresse der WLAN-Karte im Accesspoint als "verbunden").

Aber im DHCP-Server wird keine IP-Adresse an die WLAN-Karte vergeben.

Hm?

Wer kann Licht ins Dunkel bringen?

Danke vorab für jede Unterstützung.

Gruß Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#6
Hallo,

wie kann ich die "linux-backports-modules" installieren?

Dort ist der Treiber "ath9k" enthalten, den ich sehr wahrscheinlich benötige.

Vielen Dank für jeden Tipp!

Gruß Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#7
Spontan würde ich sagen backports in sources aufnehmen und dann apt-get install ...

Andy
VDR 1: ASRock mit Atom J1200, NVIDIA GT610, Lüfterlos, DD Cine DVB-C/T mit easyVDR 3.0
Zitieren
#8
Hallo Andy,

kannst Du mir

Zitat:backports in sources aufnehmen und dann apt-get install ...

bitte etwas detaillierter beschreiben.

Sorry, ich bin da nicht so bewandert.

Danke und Gruß

Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#9
Hallo,

hier nochmal zusammengasst der aktuelle Stand.

"/etc/network/interfaces":

Code:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
     wireless yes
     wireless-channel 6
     wpa-driver wext
     wpa-conf /etc/wpa_supplicant.conf

"/etc/wpa_supplicant.conf":

Code:
ctrl_interface=/var/run/wpa_supplicant

eapol_version=1

ap_scan=1

network={
        ssid="LinksysE2000"
        scan_ssid=1
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
        psk=d49fcf692a8eca6eb5...
}

Das Problem ist jetzt noch der falsche Treiber. "wext" ist für meine WLAN-Karte (s.o.) wohl nicht der richtige.
Kann mir jemand sagen, welchen Treiber ich benötige und wo ich den herbekommen kann?

Wenn ich richtig liege, dann brauche ich den Treiber "ath9k" der in dem Metapaket "linux-backports-modules" enthalten ist.
Kann mir das jemand bestätigen?

Gruß Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#10
Hallo,

der Befehl

Code:
sudo apt-get install linux-backports-modules-wireless

liefert die Ausgabe

Code:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
E: Paket linux-backports-modules-wireless kann nicht gefunden werden

Wer kann mir denn bitte mal weiterhelfen?

Danke und Gruß

Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#11
Auf eigenes Risiko!!!

http://www.ubuntuupdates.org/ppa/canonic...st=oneiric

Andy
VDR 1: ASRock mit Atom J1200, NVIDIA GT610, Lüfterlos, DD Cine DVB-C/T mit easyVDR 3.0
Zitieren
#12
Hallo Hartmut,

probier es doch zuerst mit Madwifi!
"Madwifi ist das Treiberprojekt für Atheros Chip-basierende WLAN-Karten"
http://wiki.ubuntuusers.de/WLAN/MadWifi#Manuell

Gruss
Wolfgang

Zitieren
#13
Hallo zusammen,

bevor ich mich mit dem Thema Madwifi und/oder linux-backports-modules  näher beschäftige habe ich nochmal alles überprüft und folgenden Eintrag im Log gefunden:

Code:
Oct 20 20:32:17 easyVDR2 wpa_supplicant[1011]: WPA: 4-Way Handshake failed - pre-shared key may be incorrect

Kurzum:

Ich habe mit pass_phrase auf dem easyVDR-Rechner einen neuen PSK generiert und dieser funktioniert!
(Den bisherigen PSK habe ich auf einem anderen Linuxrechner generiert.)

D.h. es funktioniert jetzt mit dem Treiber wext.

Was ich jetzt noch prüfen muss, ist die Geschwindigkeit der WLAN-Verbindung.

Ich werde mich dazu später nochmal melden.

Vielen Dank für Eure Unterstützung!

Gruß Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#14
Schön. Mit posten von easyInfo wäre das sicher früher aufgefallen. Ich greppe easyInfo immer nach failed, error und not found..

Andy
VDR 1: ASRock mit Atom J1200, NVIDIA GT610, Lüfterlos, DD Cine DVB-C/T mit easyVDR 3.0
Zitieren
#15
Hallo zusammen,

ich habe den Rechner jetzt an seinem "Bestimmungsort" stehen und jetzt sagt iwconfig:

Code:
wlan0     IEEE 802.11bgn  ESSID:"LinksysE2000"
          Mode:Managed  Frequency:2.412 GHz  Access Point: <MAC-Adresse>
          Bit Rate=243 Mb/s   Tx-Power=20 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:403  Invalid misc:174   Missed beacon:0

D.h. die Geschwindigkeit ist in Ordnung.

ABER:

Wenn ich den easyVDR2 (Client) einschalte wird der easyVDR (Server) nicht mehr per WOL gestartet.
D.h. die Datei "/usr/share/vdr/after-vdr-hooks/30_wakeup_mount" wird zwar ausgeführt, aber "zu früh".
Wahrscheinlich geht der "ping" auf den Server nicht.

Hier ein Auszug aus dem Log

Code:
Oct 21 10:45:51 easyVDR2 wpa_supplicant[892]: Trying to associate with c0:c1:c0:21:19:f3 (SSID='LinksysE2000' freq=2412 MHz)
Oct 21 10:45:51 easyVDR2 dhclient: can't create /var/lib/dhcp3/dhclient.wlan0.leases: No such file or directory
Oct 21 10:45:51 easyVDR2 wpa_supplicant[892]: Associated with c0:c1:c0:21:19:f3
Oct 21 10:45:51 easyVDR2 after-vdr-hooks: executing /usr/share/vdr/after-vdr-hooks/30_wakeup_mount
Oct 21 10:45:52 easyVDR2 dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
Oct 21 10:45:52 easyVDR2 wpa_supplicant[892]: WPA: Key negotiation completed with c0:c1:c0:21:19:f3 [PTK=CCMP GTK=CCMP]
Oct 21 10:45:53 easyVDR2 wpa_supplicant[892]: CTRL-EVENT-CONNECTED - Connection to c0:c1:c0:21:19:f3 completed (auth) [id=0 id_str=]
...
Oct 21 10:45:53 easyVDR2 kernel: [   26.076291] ADDRCONF(NETDEV_UP): wlan0: link is not ready
...
Oct 21 10:45:53 easyVDR2 kernel: [   27.958608] wlan0: authenticate with c0:c1:c0:21:19:f3 (try 1)
Oct 21 10:45:53 easyVDR2 kernel: [   28.029864] wlan0: authenticated
Oct 21 10:45:53 easyVDR2 kernel: [   28.029973] wlan0: associate with c0:c1:c0:21:19:f3 (try 1)
Oct 21 10:45:53 easyVDR2 kernel: [   28.034280] wlan0: RX AssocResp from c0:c1:c0:21:19:f3 (capab=0x411 status=0 aid=1)
Oct 21 10:45:53 easyVDR2 kernel: [   28.034298] wlan0: associated
Oct 21 10:45:53 easyVDR2 kernel: [   28.068435] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
...
Oct 21 10:45:54 easyVDR2 dhclient: DHCPOFFER of 192.168.179.20 from 192.168.179.1
Oct 21 10:45:54 easyVDR2 dhclient: DHCPREQUEST of 192.168.179.20 on wlan0 to 255.255.255.255 port 67
Oct 21 10:45:54 easyVDR2 dhclient: DHCPACK of 192.168.179.20 from 192.168.179.1
Oct 21 10:45:55 easyVDR2 dhclient: can't create /var/lib/dhcp3/dhclient.wlan0.leases: No such file or directory
Oct 21 10:45:55 easyVDR2 dhclient: bound to 192.168.179.20 -- renewal in 398225 seconds.

Wie kann man erreichen, dass die Datei "/usr/share/vdr/after-vdr-hooks/30_wakeup_mount" erst ausgeführt wird, nachdem die WLAN-Verbindung komplett fertig aufgebaut wurde?

Danke vorab für Eure Unterstützung.

Gruß Hartmut

easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren
#16
Hallo Hartmut,

(21.10.2012, 11:49)hrueger link schrieb: Wie kann man erreichen, dass die Datei "/usr/share/vdr/after-vdr-hooks/30_wakeup_mount" erst ausgeführt wird, nachdem die WLAN-Verbindung komplett fertig aufgebaut wurde?
setzt doch ein sleep 20 ..wenn es nicht reicht dann mehr, am Anfang vom Script.

Gruss
Wolfgang

Zitieren
#17
Hallo Wolfgang,

hab ich gemacht. Super!

Jetzt funktioniert es.

Danke und Gruß

Hartmut
easyVDR 3.0.0, VDR 2.2.0
Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
serieller IR-Empfänger mit LIRC und FB OneForAll Simple 3 (URC 11-6430 R01)
PC: Celeron 847 1.10GHz, 4 GB RAM, 2 TB HDD, Board: MSI C847MS-E33, Grafik: GeForce GT 610
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste