Hallo, Gast!


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Bild/Ton asynchron bei 4K UHD Fernseher bei bestimmten Sendern
#1
Ich habe mir einen 4K-Fernseher geholt und seitdem hat meine (zugegeben nicht mehr wirklich aktuelle) Easyvdr 3.0 Alpha-Version Probleme bei mehreren Sendern, dass Bild und Ton nicht synchron sind.
Nach dem ich den neuen Fernseher angeschlossen hatte, hatte ich das setup nochmals aufgerufen und den Fernseher neu erkennen lassen.

Als Auflösung habe ich 1920x1080/100Hz_p eingestellt (habs auch mit 50hz auch mal getestet, konnte aber keinen Unterschied feststellen).

Konkret ists mir bei ARD (HD) und BR (HD) aufgefallen. Beim ARD (SD) oder anderen Privatsendern trat kein Fehler auf, da wars immer synchron.
Daraufhin habe ich mal die aktuelle Easyvdr 3.5er Version installiert (mit ner anderen Festplatte) - leider wars da genauso.
Nun läuft erstmal wieder die 3.0 Alpha.

Im syslog konnte ich folgendes beobachten:

Code:
Dec  3 18:47:32 easyvdr vdr: [2740] connect from 127.0.0.1, port 55954 - accepted
Dec  3 18:47:33 easyvdr vdr: [2740] closing SVDRP connection
Dec  3 18:47:54 easyvdr vdr: [2748] channel 1 (Das Erste HD) event So. 03.12.2017 18:49-18:50 (VPS: 03.12. 18:49) 'Gewinnzahlen Deutsche Fernsehlotterie' status 4
Dec  3 18:48:02 easyvdr vdr: video: slow down video, duping frame
Dec  3 18:48:02 easyvdr vdr: video: 25:07:28.226  +63 7155   0/\ms 182+5 v-buf
Dec  3 18:48:15 easyvdr vdr: [2748] channel 15 (NDR FS HH HD) event So. 03.12.2017 18:45-19:30 (VPS: 03.12. 18:45) 'DAS!' status 4
Dec  3 18:48:15 easyvdr vdr: [2748] channel 3 (BR Fernsehen Süd HD) event So. 03.12.2017 18:45-19:15 (VPS: 03.12. 18:45) 'freizeit' status 4
Dec  3 18:48:32 easyvdr vdr: video: slow down video, duping frame
Dec  3 18:48:32 easyvdr vdr: video: 25:07:58.226  +63 7203   0/\ms 182+5 v-buf
Dec  3 18:49:02 easyvdr vdr: video: slow down video, duping frame
Dec  3 18:49:02 easyvdr vdr: video: 25:08:28.226  +63 7411   0/\ms 182+5 v-buf
Dec  3 18:49:32 easyvdr vdr: video: slow down video, duping frame
Dec  3 18:49:32 easyvdr vdr: video: 25:08:58.226  +63 7203   0/\ms 182+5 v-buf
Dec  3 18:49:54 easyvdr vdr: video: slow down video, duping frame
Dec  3 18:49:54 easyvdr vdr: video: audio/video difference too big
Dec  3 18:49:54 easyvdr vdr: video: 25:09:27.546+6744 7827   0/\ms  40+5 v-buf
Dec  3 18:49:56 easyvdr vdr: video: audio/video difference too big
Dec  3 18:49:56 easyvdr vdr: video: decoder buffer empty, duping frame (246083/45062) 0 v-buf
Dec  3 18:49:56 easyvdr vdr: video: 25:09:30.706+8334 7825   0/\ms   0+1 v-buf
Dec  3 18:49:56 easyvdr vdr: video: audio/video difference too big
Dec  3 18:49:56 easyvdr vdr: video: decoder buffer empty, duping frame (246084/45062) 0 v-buf
Dec  3 18:49:56 easyvdr vdr: video: 25:09:30.706+8314 7806   0/\ms   0+1 v-buf
Dec  3 18:49:56 easyvdr vdr: video: audio/video difference too big
Dec  3 18:49:56 easyvdr vdr: video: 25:09:30.666+8259 7822   0/\ms   0+3 v-buf
Dec  3 18:49:56 easyvdr vdr: video: audio/video difference too big
Dec  3 18:49:56 easyvdr vdr: video: decoder buffer empty, duping frame (246085/45068) 0 v-buf
Dec  3 18:49:56 easyvdr vdr: video: 25:09:30.826+8352 7819   0/\ms   0+1 v-buf
Dec  3 18:49:56 easyvdr vdr: video: audio/video difference too big
Dec  3 18:49:56 easyvdr vdr: video: decoder buffer empty, duping frame (246086/45068) 2 v-buf
Dec  3 18:49:56 easyvdr vdr: video: 25:09:30.826+8332 7831   0/\ms   2+1 v-buf
Dec  3 18:49:56 easyvdr vdr: video: audio/video difference too big
Dec  3 18:49:56 easyvdr vdr: video: 25:09:30.786+8287 7826   0/\ms   1+3 v-buf

Wie man sieht, geht's auf einmal los mit "audio/video difference too big", danach war das Bild/Ton nicht mehr synchron.

Der TV ist direkt per HDMI mit dem VDR verbunden, Details zu meiner Hardware findet ihr in meiner Signatur (Intelgrafik, VAAPI).
Als Ausgabe wird das Softdevice verwendet.

Hat vielleicht jemand anders an 4k UHD-Fernsehern sowas schon mal beobachten können oder hängts mit der Kombination VAAPI/4K zusammen?
Gibts hier irgendwelche Einstellungsmöglichkeiten, die helfen können?

Ich kann bei Bedarf zur Fehlereingrenzung auch gerne wieder auf die Easyvdr 3.5 wechseln, hauptsache, dieser Tonversatz tritt nicht mehr auf bei dem 4k-TV.
Hardware: ASRock H170M Pro4S + Intel® Core™ i3-6100 CPU @ 3.70GHz mit 4 GB RAM, HDD 256 GB SanDisk SD8SBAT2, sowie integrierte Grafik Intel Sky Lake Integrated Graphics (rev 06) mit VAAPI. DVB: Digital Devices CineS2 - Karte (V6). Alles  in einem ANTEC Fusion Gehäuse (inkl. IR-Empfänger + LCD-Display)   mit Easyvdr 3.0 Alpha.
 Zitieren
#2
Hallo

Beim ruckeln kann ich auch nichts sagen, aber nimm 50Hz, das ist auf jeden Fall besser,

Kannst du mal die Ausgabe von diesem Terminal Befehl posten?


Code:
DISPLAY=:0 xrandr


Dann könnte ich 4 K als Auflösung einbauen, wobei man testen müsste ob der VDR das kann.

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
 Zitieren
#3
Danke für die Antwort.

Hab mal auf 50 Hz umgeschaltet, wurde aber nicht besser.

Hier die Ausgabe:
Code:
easyvdr@easyvdr:~$ DISPLAY=:0 xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
  4096x2160      24.0     24.0
  3840x2160      30.0     25.0     24.0     30.0     24.0
  1920x1080     120.0    100.0    119.9     60.0     50.0*    59.9     30.0     25.0     24.0     30.0     24.0
  1920x1080i     60.1     50.0     60.0
  1280x1024      60.0
  1360x768       60.0
  1152x864       60.0
  1280x720       60.0     50.0     59.9
  1024x768       60.0
  800x600        60.3
  720x576        50.0
  720x576i       50.1
  720x480        60.0     59.9
  640x480        60.0     59.9
  720x400        70.1
HDMI3 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Hardware: ASRock H170M Pro4S + Intel® Core™ i3-6100 CPU @ 3.70GHz mit 4 GB RAM, HDD 256 GB SanDisk SD8SBAT2, sowie integrierte Grafik Intel Sky Lake Integrated Graphics (rev 06) mit VAAPI. DVB: Digital Devices CineS2 - Karte (V6). Alles  in einem ANTEC Fusion Gehäuse (inkl. IR-Empfänger + LCD-Display)   mit Easyvdr 3.0 Alpha.
 Zitieren
#4
Hallo

Danke für die Info, hilft mir aber nicht weiter. Wenn das ein Normaler TV sein sollte dann kann man bei höheren Auflösungen ja nicht mal 50p darstellen, das ist ja ein Rückschritt. Zum Computerspielen wäre der ja auch nicht zu gebrauchen.

Aber die Auslösung + Freq ist passend eingestellt, nur habe ich gerade gesehen das du noch einen Skylarke Prozessor hast, reicht da die Grafikleistung für VAAPI? Wie ist das wenn du eine Aufnahme in Kodi anschaust? In Kodi natürlich VAAPI aktivieren.

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
 Zitieren
#5
(04.12.2017, 15:13)Bleifuss2 schrieb: Wenn das ein Normaler TV sein sollte dann kann man bei höheren Auflösungen ja nicht mal 50p darstellen, das ist ja ein Rückschritt. Zum Computerspielen wäre der ja auch nicht zu gebrauchen.

Supports HDMI with max. resolution up to 4K x 2K (4096x2160) @ 24Hz / (3840x2160) @ 30Hz
Supports DVI-D with max. resolution up to 1920x1200 @ 60Hz
Mit dem Mainboard keine 50Hz in 4k drin. Anscheinend ist der pixelclock bei rund 260MHz im Limit und
der DVI Port ist die preiswerte Ausführung mit nur einem TDMS Kanal anstelle der zwei möglichen.

 

Andererseits wird softhddevice nur mit exakt 50Hz gut laufen und der Monitor kann ja auch 1920x1080@50.
Für TV ist das ok, der TV rechnet das dann hoch; wie sinnvoll 4k sind ist ne andre Frage.
Du brauchst Hilfe? Wir brauchen Daten!
while (! asleep()) sheep++;
 Zitieren
#6
Hi

Zitat:Andererseits wird softhddevice nur mit exakt 50Hz gut laufen und der Monitor kann ja auch 1920x1080@50.

Für TV ist das ok, der TV rechnet das dann hoch; wie sinnvoll 4k sind ist ne andre Frage.

Schon klar, ich hätte die neuen Auflösungen aber in das Setup übernommen, wäre interessant welche Software damit klar kommt.

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
 Zitieren
#7
Interessantes Hintergrundwissen - d.h. mit meiner jetzigen Computerhardware wird 4k also nicht drin sein.

Andererseits...mir war und ist bewußt, dass easyVDR derzeit "nur" eine Full-HD-Auflösung hat.
Ich habe mir den Fernseher geholt, weil durch ein vergrößertes Wohnzimmer der jetzige TV zu klein wurde - und da ich nicht alle 5 Jahre 'nen neuen TV kaufen will, hab ich gleich einen mit 4k geholt (LG49UJ635V).
Wie Wirbel schon schreibt, wird Full-HD ja korrekt hochgerechnet vom Fernseher, aber der Sound passt halt nicht.

Ich habe auch mal den empfohlenen Test mit KODI (VAAPI aktiv) und einer auffälligen Aufnahme gemacht.
Unter VDR:  asynchron
Unter Kodi:  synchron

Insofern vermute ( SPEKULATION! Big Grin  ) ich das Problem mit der Unsynchronität eher bei den Audioeinstellungen beim Softhddevice...

Hab' mal ein bisschen reingeschaut in die Plugineinstellungen im Frontend, da gibts z.B.
Audio Drift Korrektur und irgendwelches Pass-Through-Zeugs, mit dem ich nicht wirklich was anfangen kann, ausser sinnlos rumzuprobieren...

Hat damit irgendwer Erfahrung mit Bild/Tonversatz oder gibts 'ne Seite über diese ganzen Parameter, dann würd' ich mich mal ans Werk machen.
Mit Google konnte ich keine wirklichen Treffer finden, könnte aber auch daran liegen, dass es nur bei easyVDR z.B. Audio Drift Korrektur heißt...

Auf http://vdr-wiki.de/wiki/index.php/Softhddevice-plugin hab ich was gefunden, da steht aber zur dieser Drift Korrektur auch nicht wirklich was drin..
Hardware: ASRock H170M Pro4S + Intel® Core™ i3-6100 CPU @ 3.70GHz mit 4 GB RAM, HDD 256 GB SanDisk SD8SBAT2, sowie integrierte Grafik Intel Sky Lake Integrated Graphics (rev 06) mit VAAPI. DVB: Digital Devices CineS2 - Karte (V6). Alles  in einem ANTEC Fusion Gehäuse (inkl. IR-Empfänger + LCD-Display)   mit Easyvdr 3.0 Alpha.
 Zitieren
#8
Hi

Nun ich hatte die Probleme bei VAAPI auch deshalb habe ich wieder eine Nvidia ...
Bei VAAPI hat gb am meisten Erfahrung, ich denke das die 3.5 auch besser geeignet wäre da es neuere Treiber gibt (glaube ich).
Das Problem ist das Deinterleacing, wenn du da experimentierst kann sein das es geht, aber mit schlechterem Bild.

Gruß
Bleifuss
Produktiv-VDR:
Board GA H77-DS3H, Intel Intel® Core™ i5-3470, Cine S2 DVB, WD 3TB Green, WDC WD20EARS-00J  2TB, Geforce 750Ti oder Intel HD
Easyvdr 3.0
 Zitieren
#9
Ja, bei easyVDR3.5 ist die intelgrafik Unterstützung weit aus besser. Solltest du Probleme beim Ton haben, auch mal mit alsa anstelle pulseaudio testen. Es kann schon sein das Bild und Ton asynchron laufen, liegt glaube ich weniger am Intel Prozess was du ja mit htop nachschauen kannst.

Dein Test mit kodi bestätigt ja auch meine Vermutung zwecks Leistung.

Ich tippe da eher auf softhddevice und pulseaudio Problem.

Muss man sich halt leider durchtesten.
Hab leider kein uhd daher kann ich das Problem nicht nachstellen.


Gruß Aaron

Gesendet von meinem S7Edge mit Tapatalk
Mediacenter
easyVDR3.0(4.2.0 64-Bit) Gigabyte, Ltd. H97-HD3 mit Intel® G3260 @ 3.30GHz 4GB DDRx,Intelgrafik,MATSHITA BD-MLT UJ265 Bluray LW, 2TB Festplatte,LCD+IRTrans-Empfänger,2x SkystarS2 PCI

 Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste