Hallo, Gast!


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Gelöst: Cine S2 V7a: System hängt sich auf
#1
Hallo,
nachdem meine alte Cine S2 V5 kein Signal mehr geliefert hat, baute ich die neue Cine S2 V7a ein.
In diesem Zusammenhang habe ich auch gleich ein Update auf easyVDR 3.5 gemacht.
Als Treiber habe ich den dddvb-Driver-only ausgewählt.
Ich habe die gleichen Symptome wie hier beschrieben: http://www.easy-vdr.de/thread-18199-post...#pid178045
(Signalqualität wird als sehr niedrig angezeigt, Bild und Ton sind aber nicht zu beanstanden)

Doch bei mir bricht vermutlich immer mal wieder das Signal komplett weg. Es dauert zwischen ca. 10 Minuten und einer Stunde. Im Liveview friert dann das Bild ein, bei der Wiedergabe einer Aufnahme erscheint der Desktophintergrund (mit Maus).



In der angehängten syslog heisst es u.a. ERROR: video data stream broken.
Hat evtl die Satellitenanlage einen Schuss?
Oder hat das irgendwas mit dem irq 129 zu tun oder mit dem Segfault?



.txt   syslog.txt (Größe: 26,62 KB / Downloads: 2)
Produktiv-VDR:
Board: Gigabyte GA-B250-HD3P, 4GB RAM | CPU: Intel Pen
tium G4400 2x 3.30GHz | Disk: 2000GB WD Black WDBSLA0020HNC-ERSN | Grafik: MSI GeForce GT 1030 2GH LP OC 2GB Nvidia GDDR5 | DVB: CineS2 (V7a) | FB: X10_20029725 | Easyvdr 3.5

 Zitieren
#2
Hi,
die v7a ist nicht für gute Treiber berühmt! Ich glaube am ehesten wirst du noch Erfolg haben mit dem Kernel 4.14 oder sogar RC von 4.15.

Ich glaube der dddvb supportet die nur rudimentär in der bei uns verfügbaren Variante (die die meines Wissens neueste verfügbare ist, im media-build bei uns ist ne ältere drin)

Wende dich mal an den guten Support von DD bzgl. Reparatur der alten, da sind die wohl sehr gut!

Femon Daten sind glaub ich immer bei der sinnfreie Werte...

Hast du Fehler im Log? nst ist da am Suchen nach i2c Fehlern oder so.

Eine weitere Idee wäre der neue dkms Treiber von jasminj im VDR-Portal...

Aber erst mal Kernelupdate!

MfG,
Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, als Tuner FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 v3.-64 stable
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD 2TB+3TB, 2x TT3200 + ASUS GT730-SL-2GD3-BRK + mod. Digitainergeh. v3-64
VDR5: GIGABYTE GA-G31M-S2L + Intel E5200 + GT220 + Zalman ZNF 100 Passivkühler + 2GB + t6963c gLCD + Satelco DVB-C+CI + Sundtek DVB-C/T v2010+mod. Digitainergeh. v1
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, 750GB, t6963c gLCD, 2x TT3200 v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
 Zitieren
#3
Zitat:Nov  9 23:52:04 easyVDR kernel: [ 1292.738912] irq 129: nobody cared (try booting with the "irqpoll" option)
Nov  9 23:52:04 easyVDR kernel: [ 1292.738925] CPU: 0 PID: 0 Comm: swapper/0 Tainted: P        W  OE   4.4.0-98-generic #121~14.04.1-Ubuntu
Nov  9 23:52:04 easyVDR kernel: [ 1292.738930] Hardware name: Gigabyte Technology Co., Ltd. B250-HD3P/B250-HD3P-CF, BIOS F6 04/07/2017
Nov  9 23:52:04 easyVDR kernel: [ 1292.738933]  0000000000000000 ffff88012ec03e60 ffffffff813df94c ffff88012798f600
Nov  9 23:52:04 easyVDR kernel: [ 1292.738941]  ffff88012798f6d4 ffff88012ec03e88 ffffffff810d8f25 ffff88012798f600
Nov  9 23:52:04 easyVDR kernel: [ 1292.738947]  0000000000000000 0000000000000081 ffff88012ec03ec0 ffffffff810d928f
Nov  9 23:52:04 easyVDR kernel: [ 1292.738952] Call Trace:
Nov  9 23:52:04 easyVDR kernel: [ 1292.738955]    [] dump_stack+0x63/0x87
Nov  9 23:52:04 easyVDR kernel: [ 1292.738973]  [] __report_bad_irq+0x35/0xd0
Nov  9 23:52:04 easyVDR kernel: [ 1292.738978]  [] note_interrupt+0x21f/0x280
Nov  9 23:52:04 easyVDR kernel: [ 1292.738984]  [] handle_irq_event_percpu+0xbc/0x1d0
Nov  9 23:52:04 easyVDR kernel: [ 1292.738989]  [] handle_irq_event+0x3e/0x60
Nov  9 23:52:04 easyVDR kernel: [ 1292.738995]  [] handle_edge_irq+0x9c/0x150
Nov  9 23:52:04 easyVDR kernel: [ 1292.739002]  [] handle_irq+0x20/0x30
Nov  9 23:52:04 easyVDR kernel: [ 1292.739009]  [] do_IRQ+0x4d/0xd0
Nov  9 23:52:04 easyVDR kernel: [ 1292.739014]  [] common_interrupt+0x82/0x82
Nov  9 23:52:04 easyVDR kernel: [ 1292.739016]    [] ? cpuidle_enter_state+0xd8/0x250
Nov  9 23:52:04 easyVDR kernel: [ 1292.739027]  [] cpuidle_enter+0x17/0x20
Nov  9 23:52:04 easyVDR kernel: [ 1292.739034]  [] call_cpuidle+0x32/0x60
Nov  9 23:52:04 easyVDR kernel: [ 1292.739038]  [] ? cpuidle_select+0x13/0x20
Nov  9 23:52:04 easyVDR kernel: [ 1292.739045]  [] cpu_startup_entry+0x289/0x350
Nov  9 23:52:04 easyVDR kernel: [ 1292.739051]  [] rest_init+0x7c/0x80
Nov  9 23:52:04 easyVDR kernel: [ 1292.739057]  [] start_kernel+0x4a9/0x4b6
Nov  9 23:52:04 easyVDR kernel: [ 1292.739062]  [] ? set_init_arg+0x55/0x55
Nov  9 23:52:04 easyVDR kernel: [ 1292.739067]  [] ? early_idt_handler_array+0x120/0x120
Nov  9 23:52:04 easyVDR kernel: [ 1292.739072]  [] x86_64_start_reservations+0x2a/0x2c
Nov  9 23:52:04 easyVDR kernel: [ 1292.739076]  [] x86_64_start_kernel+0x13d/0x14c
Nov  9 23:52:04 easyVDR kernel: [ 1292.739079] handlers:
Nov  9 23:52:04 easyVDR kernel: [ 1292.739093] [] ddb_irq_handler0 [ddbridge]
Nov  9 23:52:04 easyVDR kernel: [ 1292.739096] Disabling IRQ #129
Nov  9 23:52:05 easyVDR vdr: video: decoder buffer empty, duping frame (4/62975) 0 v-buf
Nov  9 23:52:34 easyVDR vdr: [3192] ERROR: video data stream broken
Nov  9 23:52:34 easyVDR vdr: [3192] initiating emergency exit

Das ist glaub ich das Preoblem...

Poste direkt, wenn mit neuestem Kernel (ohne extra-Treiber!!!) im Portal im Thread von nst dazu...

MfG,
Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, als Tuner FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 v3.-64 stable
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD 2TB+3TB, 2x TT3200 + ASUS GT730-SL-2GD3-BRK + mod. Digitainergeh. v3-64
VDR5: GIGABYTE GA-G31M-S2L + Intel E5200 + GT220 + Zalman ZNF 100 Passivkühler + 2GB + t6963c gLCD + Satelco DVB-C+CI + Sundtek DVB-C/T v2010+mod. Digitainergeh. v1
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, 750GB, t6963c gLCD, 2x TT3200 v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
 Zitieren
#4
Hi Vdrfreak1,

werde Heute oder Morgen ein neues dddvb-dkms bauen.
Seit erscheinen von Version-0.9.32 gab es Änderungen am Treiber.
Sollte der Treiber dann immer noch nicht wie gewünscht funktionieren,
gibt es noch die von SurfaceCleanerZ(Stefan) aufgezeigten Möglichkeiten.
...die aber bei wechsel vom Kernel weitere Änderungen nach sich ziehen(gcc dkms etc.)

Gruss
Wolfgang

 Zitieren
#5
Das mit dem neuen Treiber hört sich gut an. Werde ihn dann installieren und nach Testphase wieder posten.
Danke!

Reiner
Produktiv-VDR:
Board: Gigabyte GA-B250-HD3P, 4GB RAM | CPU: Intel Pen
tium G4400 2x 3.30GHz | Disk: 2000GB WD Black WDBSLA0020HNC-ERSN | Grafik: MSI GeForce GT 1030 2GH LP OC 2GB Nvidia GDDR5 | DVB: CineS2 (V7a) | FB: X10_20029725 | Easyvdr 3.5

 Zitieren
#6
Hallo Reiner,

neues Paket wurde in "3-base-unstable PPA" gebaut.
Paket mit wget holen ist besser, als das PPA einzubinden.

Konsole:
Code:
cd /tmp
wget https://launchpad.net/~easyvdr-team/+archive/ubuntu/3-base-unstable/+files/dddvb-dkms_0.9.32.1easyVDR0-trusty_all.deb
sudo dpkg -i dddvb-dkms_0.9.32.1*.deb

P.S
Module werden gebaut, Funktionstest musst du machen!

Gruss
Wolfgang

 Zitieren
#7
Hatte ähnliches Verhalten:
DD Octopus LE Bridge 2x DuoFlex v2, easyVDR frisch installiert, DVB Karte wurde während der Installation nicht erkannt also dddvb-kms nachinstalliert.
Nach ca 15 Minuten:

Nov 11 16:51:31 easyVDR-1 kernel: [  644.854358] irq 31: nobody cared (try booting with the "irqpoll" option)
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854376] CPU: 2 PID: 0 Comm: swapper/2 Tainted: P           OE   4.4.0-96-generic #119~14.04.1-Ubuntu
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854382] Hardware name: To be filled by O.E.M. To be filled by O.E.M./KTQM77/mITX, BIOS 4.6.5 12/19/2013
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854388]  0000000000000000 ffff88011dd03e60 ffffffff813df4ac ffff880035b37e00
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854397]  ffff880035b37ed4 ffff88011dd03e88 ffffffff810d8f55 ffff880035b37e00
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854404]  0000000000000000 000000000000001f ffff88011dd03ec0 ffffffff810d92bf
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854412] Call Trace:
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854417]  <IRQ>  [<ffffffff813df4ac>] dump_stack+0x63/0x87
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854447]  [<ffffffff810d8f55>] __report_bad_irq+0x35/0xd0
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854454]  [<ffffffff810d92bf>] note_interrupt+0x21f/0x280
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854461]  [<ffffffff810d655c>] handle_irq_event_percpu+0xbc/0x1d0
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854469]  [<ffffffff810d66ae>] handle_irq_event+0x3e/0x60
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854480]  [<ffffffff810d9acc>] handle_edge_irq+0x9c/0x150
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854492]  [<ffffffff810300c0>] handle_irq+0x20/0x30
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854504]  [<ffffffff8181195d>] do_IRQ+0x4d/0xd0
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854510]  [<ffffffff8180fa42>] common_interrupt+0x82/0x82
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854514]  <EOI>  [<ffffffff816a8fb8>] ? cpuidle_enter_state+0xd8/0x250
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854538]  [<ffffffff816a8f94>] ? cpuidle_enter_state+0xb4/0x250
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854546]  [<ffffffff816a9167>] cpuidle_enter+0x17/0x20
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854558]  [<ffffffff810bfaf2>] call_cpuidle+0x32/0x60
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854568]  [<ffffffff816a9143>] ? cpuidle_select+0x13/0x20
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854579]  [<ffffffff810bfda9>] cpu_startup_entry+0x289/0x350
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854588]  [<ffffffff8104f409>] start_secondary+0x149/0x170
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854593] handlers:
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854613] [<ffffffffc0370bd0>] ddb_irq_handler0 [ddbridge]
Nov 11 16:51:31 easyVDR-1 kernel: [  644.854629] Disabling IRQ #31

Danach mit Mango's  deb aktualisiert, leider keine Besserung, nach einiger Zeit wieder ähnliches im syslog.

Nov 11 17:05:46 easyVDR-1 kernel: [  664.652874] irq 31: nobody cared (try booting with the "irqpoll" option)
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652880] CPU: 0 PID: 0 Comm: swapper/0 Tainted: P           OE   4.4.0-96-generic #119~14.04.1-Ubuntu
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652882] Hardware name: To be filled by O.E.M. To be filled by O.E.M./KTQM77/mITX, BIOS 4.6.5 12/19/2013
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652884]  0000000000000000 ffff88011dc03e60 ffffffff813df4ac ffff8800dd8bd400
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652887]  ffff8800dd8bd4d4 ffff88011dc03e88 ffffffff810d8f55 ffff8800dd8bd400
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652889]  0000000000000000 000000000000001f ffff88011dc03ec0 ffffffff810d92bf
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652891] Call Trace:
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652893]  <IRQ>  [<ffffffff813df4ac>] dump_stack+0x63/0x87
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652900]  [<ffffffff810d8f55>] __report_bad_irq+0x35/0xd0
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652902]  [<ffffffff810d92bf>] note_interrupt+0x21f/0x280
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652904]  [<ffffffff810d655c>] handle_irq_event_percpu+0xbc/0x1d0
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652905]  [<ffffffff810d66ae>] handle_irq_event+0x3e/0x60
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652907]  [<ffffffff810d9acc>] handle_edge_irq+0x9c/0x150
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652910]  [<ffffffff810300c0>] handle_irq+0x20/0x30
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652913]  [<ffffffff8181195d>] do_IRQ+0x4d/0xd0
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652914]  [<ffffffff8180fa42>] common_interrupt+0x82/0x82
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652915]  <EOI>  [<ffffffff816a8fb8>] ? cpuidle_enter_state+0xd8/0x250
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652918]  [<ffffffff816a9167>] cpuidle_enter+0x17/0x20
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652921]  [<ffffffff810bfaf2>] call_cpuidle+0x32/0x60
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652922]  [<ffffffff816a9143>] ? cpuidle_select+0x13/0x20
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652924]  [<ffffffff810bfda9>] cpu_startup_entry+0x289/0x350
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652927]  [<ffffffff8180325c>] rest_init+0x7c/0x80
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652931]  [<ffffffff81f62108>] start_kernel+0x4a9/0x4b6
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652933]  [<ffffffff81f61a4a>] ? set_init_arg+0x55/0x55
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652935]  [<ffffffff81f61120>] ? early_idt_handler_array+0x120/0x120
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652937]  [<ffffffff81f615ee>] x86_64_start_reservations+0x2a/0x2c
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652940]  [<ffffffff81f6172d>] x86_64_start_kernel+0x13d/0x14c
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652941] handlers:
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652948] [<ffffffffc03cfe30>] ddb_irq_handler0 [ddbridge]
Nov 11 17:05:46 easyVDR-1 kernel: [  664.652949] Disabling IRQ #31
Nov 11 17:05:47 easyVDR-1 kernel: [  665.328442] st: Version 20101219, fixed bufsize 32768, s/g segs 256

Seit einem:  
echo 'options ddbridge msi=0' | sudo tee /etc/modprobe.d/ddbridge.conf
scheint es besser zu funktionieren bzw läuft noch.
 Zitieren
#8
Hallo,

also bei mir hat sich durch den neuen Treiber ebenfalls nichts verändert. Allerdings habe ich jetzt festgestellt, dass der vorige dkms-Treiber ebenfalls irgendeine Version 0.9.32 war. Trotz gleicher Version, scheint es aber ein anderer zu sein,
denn wenn ich nach dem update im setup von easyvdr den dkms-Treiber neu installiere, erscheint eine Fehlermeldung und im Log (apt-get.log) der Hinweis auf ein Downgrade:

Code:
===> ########################################################################################
===> So 12. Nov 12:32:25 CET 2017: Installation von DVB-Treiberpack dddvb-dkms ...
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Die folgenden Pakete werden durch eine ÄLTERE VERSION ERSETZT (Downgrade):
 dddvb-dkms
0 aktualisiert, 0 neu installiert, 1 durch eine ältere Version ersetzt, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0 B von 393 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 80,9 kB Plattenplatz freigegeben.
E: Es gab Probleme und -y wurde ohne --force-yes verwendet.
#############################################################################################


@SurfaceCleanerZ
Digitaldevices weist darauf hin, dass im Kernel 4.x bisher leider nur die Treiber bis V6.5 enthalten sind:
https://www.digital-devices.eu/shop/de/c...sCustom/80
Daher scheint ein experimentieren mit anderen Kerneln wenig erfolgsversprechend zu sein.
Eine Reparatur habe ich angefragt.

Trotzdem sollte das Problem natürlich irgendwie gelöst werden.
Da test.it so ziemlich das gleiche Problem hat, gehe ich nun davon aus, dass es nicht an meiner Hardware liegt, ausser evtl. an der neuen Karte.

Ich füge mal die aktuelle easyinfo an.

Gruß

Reiner


Angehängte Dateien
.zip   easyinfo.zip (Größe: 128,02 KB / Downloads: 0)
Produktiv-VDR:
Board: Gigabyte GA-B250-HD3P, 4GB RAM | CPU: Intel Pen
tium G4400 2x 3.30GHz | Disk: 2000GB WD Black WDBSLA0020HNC-ERSN | Grafik: MSI GeForce GT 1030 2GH LP OC 2GB Nvidia GDDR5 | DVB: CineS2 (V7a) | FB: X10_20029725 | Easyvdr 3.5

 Zitieren
#9
Hast du es mal mit 'options ddbridge msi=0' in der /etc/modprobe.d/ddbridge.conf probiert?
 Zitieren
#10
Hi,

(12.11.2017, 13:59)Vdrfreak1 schrieb: Allerdings habe ich jetzt festgestellt, dass der vorige dkms-Treiber ebenfalls irgendeine Version 0.9.32 war. Trotz gleicher Version, scheint es aber ein anderer zu sein,
denn wenn ich nach dem update im setup von easyvdr den dkms-Treiber neu installiere, erscheint eine Fehlermeldung und im Log (apt-get.log) der Hinweis auf ein Downgrade:
der Treiber hat immer noch die gleiche Version.
Es wurde nur der aktuelle Git-Stand cloned und daraus ein neues Paket gebaut.
..alt > dddvb-dkms-1:0.9.32.0easyVDR0-trusty - neu > dddvb-dkms-1:0.9.32.1easyVDR0-trusty
Wird ein neueres Paket local mit dpkg -i *.deb installiert, woher soll das System den Wissen das es das
neue Paket behalten soll? ...es ist ja kein PPA aktiviert in dem sich das Paket befindet.
Für diesen Fall kann man aber mit z.B "apt-mark hold dddvb-dkms" das Paket halten
und es wird bei upgrade kein downgrade geben.

@test.it
Läuft der Treiber jetzt mit "options ddbridge msi=0" stabil, oder kommt es wieder zum "Disabling IRQ #31"?
>> Nov 11 16:51:31 easyVDR-1 kernel: [  644.854358] irq 31: nobody cared (try booting with the "irqpoll" option)
...häng mal Bitte die Ausgabe von
Code:
cat /proc/interrupts
an,nachdem das System gestartet ist.

P.S
"irqpoll" ist ja nichts anderes als ein Verfahren zur Steuerung des Zugriffs auf Peripheriegeräte,
bei dem der Rechner in festgelegten zeitlichen Abständen die Schnittstelle(n) abfragt.
wird dies jedoch Synchron an einem IRQ mehrmals gemacht, kann es passieren das sich die Hardware dazu aufhängt.

Gruss
Wolfgang

 Zitieren
#11
Mit "options ddbridge msi=0" läuft es stabil, zumindest bei mir.

Ein "cat /proc/Interrupts" ergibt folgendes:

Code:
# cat /proc/interrupts
          CPU0       CPU1       CPU2       CPU3
 0:         17          0          0          0  IR-IO-APIC   2-edge      timer
 1:          1          4          3          1  IR-IO-APIC   1-edge      i8042
 3:          1          0          1          0  IR-IO-APIC   3-edge
 4:          0          1          1          0  IR-IO-APIC   4-edge
 5:       3312       3146      10613       5548  IR-IO-APIC   5-edge      parport0
 8:          0          0          1          0  IR-IO-APIC   8-edge      rtc0
 9:          0          0          0          0  IR-IO-APIC   9-fasteoi   acpi
12:          1          0          2          0  IR-IO-APIC  12-edge      i8042
16:         26        199         92       2391  IR-IO-APIC  16-fasteoi   ehci_hcd:usb1
17:        112         38        508         58  IR-IO-APIC  17-fasteoi   snd_hda_intel
18:        804       4273       1161      57955  IR-IO-APIC  18-fasteoi   ddbridge
23:          6          8         53          4  IR-IO-APIC  23-fasteoi   ehci_hcd:usb2
24:          0          0          0          0  DMAR-MSI   0-edge      dmar0
26:          0          0          1          0  IR-PCI-MSI 327680-edge      xhci_hcd
27:          1          0          0          0  IR-PCI-MSI 1572864-edge      firewire_ohci
28:      32954         26        476         37  IR-PCI-MSI 409600-edge      eth0
29:       5684       2482       4036       3555  IR-PCI-MSI 512000-edge      0000:00:1f.2
30:         21          0          1          4  IR-PCI-MSI 360448-edge      mei_me
31:       2044       1990      37281       1588  IR-PCI-MSI 524288-edge      nvidia
NMI:          1          1          1          1   Non-maskable interrupts
LOC:      40228      69815      37637      19299   Local timer interrupts
SPU:          0          0          0          0   Spurious interrupts
PMI:          1          1          1          1   Performance monitoring interrupts
IWI:          0          0          0          0   IRQ work interrupts
RTR:          0          0          0          0   APIC ICR read retries
RES:       3047       2986       3397       1708   Rescheduling interrupts
CAL:        932        972        833        732   Function call interrupts
TLB:       1603       1608        264       1582   TLB shootdowns
TRM:          0          0          0          0   Thermal event interrupts
THR:          0          0          0          0   Threshold APIC interrupts
DFR:          0          0          0          0   Deferred Error APIC interrupts
MCE:          0          0          0          0   Machine check exceptions
MCP:          3          3          3          3   Machine check polls
ERR:          0
MIS:          0
PIN:          0          0          0          0   Posted-interrupt notification event
PIW:          0          0          0          0   Posted-interrupt wakeup event
 Zitieren
#12
Hi,

(12.11.2017, 18:41)test.it schrieb: Mit "options ddbridge msi=0" läuft es stabil, zumindest bei mir.
...lief das auch mit dem alten Treiber stabil, oder kam es da trotz "options" zum Fehler?

Gruss
Wolfgang

 Zitieren
#13
Hallo,

sorry, test.it, habe deinen Zusatz übersehen.
Habe es vorher eingefügt:

Code:
sudo echo 'options ddbridge msi=0' > /etc/modprobe.d/ddbridge.conf
sudo reboot


Seit über fünf Stunden läuft es auch bei mir stabil.

@Mango:
Ist es möglich, dass Du diesen Eintrag durch das Installationsskript erstellen lässt?



Danke euch Beiden.
Reiner
Produktiv-VDR:
Board: Gigabyte GA-B250-HD3P, 4GB RAM | CPU: Intel Pen
tium G4400 2x 3.30GHz | Disk: 2000GB WD Black WDBSLA0020HNC-ERSN | Grafik: MSI GeForce GT 1030 2GH LP OC 2GB Nvidia GDDR5 | DVB: CineS2 (V7a) | FB: X10_20029725 | Easyvdr 3.5

 Zitieren
#14
Hi,

(12.11.2017, 20:42)Vdrfreak1 schrieb: Seit über fünf Stunden läuft es auch bei mir stabil.
wenn der Treiber keine weitern Fehler verursacht, schiebe ich den nach 3-base-stable PPA
..dann gibt es auch keinen Stress mehr bei upgrade und das Paket muss nicht auf hold gesetzt werden.
Ist das Paket auf hold gesetzt, kann man den Hold mit
Code:
sudo apt-mark unhold dddvb-dkms
wieder lösen.

(12.11.2017, 20:42)Vdrfreak1 schrieb: Ist es möglich, dass Du diesen Eintrag durch das Installationsskript erstellen lässt?
kann man, passt aber nicht für alle Karten. Es gibt da auch noch Parameter msi=1(je nach MoBo)
da müsste man Karten-Typ/MoBo abfragen, erst dann kann der Parameter gesetzt werden.
Mal ehrlich
Code:
echo 'options ddbridge msi=0' | sudo tee /etc/modprobe.d/ddbridge.conf
oder
Code:
echo 'options ddbridge msi=1' | sudo tee /etc/modprobe.d/ddbridge.conf
dass macht man 1x ...fertig!

Gruss
Wolfgang

 Zitieren
#15
(12.11.2017, 20:29)mango schrieb:
(12.11.2017, 18:41)test.it schrieb: Mit "options ddbridge msi=0" läuft es stabil, zumindest bei mir.
...lief das auch mit dem alten Treiber stabil, oder kam es da trotz "options" zum Fehler?

Gruss
Wolfgang

Hi,

bei mir war es wie schon geschrieben eine "frische" Neuinstallation von Mitte letzter Woche da ich von yaVDR zu easyVDR gewechselt bin.
Da ich mit dem dddvb-kms Paket auch schon unter yaVDR so meine Probleme hatte habe ich auf dem neuinstallierten easyVDR gleich mal das aktualisierte dddvb-kms von dir installiert ohne das mit der ddbrigde.conf mit dem stable dddvb-kms zu testen.
Das fiel mir leider erst wieder ein als es mit dem aktualisierte dddvb-kms nicht besser wurde, da war doch was ... mit msi= ...
Sorry!
Leicht möglich das es mit dem stable dddvb-kms und der ddbridge.conf auch schon gepasst hätte...
 Zitieren
#16
Zitat:dass macht man 1x ...fertig!

ja, da hast du natürlich recht.
Doch ich dachte an diejenigen, die künftig eine V7a installieren. Woher wissen die, dass dies gemacht werden muss?
Sie müssen dann erst diesen Thread suchen. Das war eigentlich der Sinn meiner Frage.

Aber okay; ist natürlich schwierig, wenn es nicht für alle Karten passt.

Morgen werde ich nochmal den alten Treiber mit den options testen und rückmelden.

Gruß
Reiner
Produktiv-VDR:
Board: Gigabyte GA-B250-HD3P, 4GB RAM | CPU: Intel Pen
tium G4400 2x 3.30GHz | Disk: 2000GB WD Black WDBSLA0020HNC-ERSN | Grafik: MSI GeForce GT 1030 2GH LP OC 2GB Nvidia GDDR5 | DVB: CineS2 (V7a) | FB: X10_20029725 | Easyvdr 3.5

 Zitieren
#17
Hallo Reiner,

(12.11.2017, 21:33)Vdrfreak1 schrieb: Sie müssen dann erst diesen Thread suchen. Das war eigentlich der Sinn meiner Frage.
...das kann man auch im EasyVDR-Wiki publizieren.

(12.11.2017, 21:33)Vdrfreak1 schrieb: Morgen werde ich nochmal den alten Treiber mit den options testen und rückmelden.
...nee brauchst du nicht extra machen, dass Paket soll durch das neue Paket ersetzt werden!

Gruss
Wolfgang

 Zitieren
#18
Okay,
alles scheint stabil zu laufen.

Zitat:...das kann man auch im EasyVDR-Wiki publizieren.
Wie wäre es, wenn man auch einen Hinweis in dem Hilfe-Menü der Treiberauswahl einfügt?


Ein "Problem" gibt es noch:
Nach der Treiberinstallation übers Setup erscheint die Meldung:
Code:
-> Fehler bei Install von dddvb-dkms siehe /var/log/easyvdr/apt-get.log
apt-get.log:
Code:
E: Es gab Probleme und -y wurde ohne --force-yes verwendet.

Es scheint ja trotzdem zu funktionieren, aber die Fehlermeldung ist für den User doch sehr irritierend.

Gruß

Reiner
Produktiv-VDR:
Board: Gigabyte GA-B250-HD3P, 4GB RAM | CPU: Intel Pen
tium G4400 2x 3.30GHz | Disk: 2000GB WD Black WDBSLA0020HNC-ERSN | Grafik: MSI GeForce GT 1030 2GH LP OC 2GB Nvidia GDDR5 | DVB: CineS2 (V7a) | FB: X10_20029725 | Easyvdr 3.5

 Zitieren
#19
Hi,

Paket "dddvb-dkms 1:0.9.32.1easyVDR0-trusty" wurde nach 3-base-stable PPA verschoben!

Install-Log:
Code:
root@easy4:/tmp# dpkg -i *.deb
Vormals nicht ausgewähltes Paket dddvb-dkms wird gewählt.
(Lese Datenbank ... 241018 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von dddvb-dkms_0.9.32.1easyVDR0-trusty_all.deb ...
Entpacken von dddvb-dkms (1:0.9.32.1easyVDR0-trusty) ...
dddvb-dkms (1:0.9.32.1easyVDR0-trusty) wird eingerichtet ...
Loading new dddvb-0.9.32.1easyVDR0 DKMS files...
First Installation: checking all kernels...
Building only for 4.4.0-98-generic
Building for architecture x86_64
Building initial module for 4.4.0-98-generic
Done.

ddbridge:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

octonet.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

dvb-core.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

cxd2099.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

cxd2843.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

drxk.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

lnbh25.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

lnbp21.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

mxl5xx.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

stv0367dd.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

stv090x.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

stv0910.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

stv6110x.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

stv6111.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

tda18212dd.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

tda18271c2dd.ko:
Running module version sanity check.
- Original module
- Installation
  - Installing to /lib/modules/4.4.0-98-generic/updates/dkms/

depmod..........

DKMS: install completed.

@Vdrfreak1
-> Fehler bei Install von dddvb-dkms siehe /var/log/easyvdr/apt-get.log
Bitte den Treiber zuerst deinstallieren
Code:
sudo apt-get remove --purge dddvb-dkms
sudo apt update
sudo apt-get install dddvb-dkms

Gruss
Wolfgang

 Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste