Hallo, Gast!


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst] Hauppauge WinTV-Starburst funktioniert nicht
#1
Hallo zusammen,

aufgrund des Eintrags "supported in mainline kernel since 3.9" auf https://www.linuxtv.org/wiki/index.php/H...-Starburst habe ich mir eine Hauppauge WinTV-Starburst geholt. Leider funktioniert die nicht mit easyVDR 3.0 Sad

/var/log/syslog sagt dazu:
Apr 19 22:41:55 easyVDR vdr: [2690] loading /var/lib/vdr/svdrphosts.conf
Apr 19 22:41:55 easyVDR vdr: [2690] loading /var/lib/vdr/remote.conf
Apr 19 22:41:55 easyVDR vdr: [2690] loading /var/lib/vdr/keymacros.conf
Apr 19 22:41:55 easyVDR kernel: [   20.755368] i2c i2c-4: tda10071: found a 'NXP TDA10071' in cold state, will try to load a firmware
Apr 19 22:41:55 easyVDR kernel: [   20.755370] i2c i2c-4: tda10071: downloading firmware from file 'dvb-fe-tda10071.fw'
Apr 19 22:41:55 easyVDR NetworkManager[1234]: <info> WiFi hardware radio set enabled
Apr 19 22:41:56 easyVDR after-vdr-hooks: executing /usr/share/vdr/after-vdr-hooks/30_test_setupplugin_running
Apr 19 22:41:56 easyVDR after-vdr-hooks: executing /usr/share/vdr/after-vdr-hooks/40_skinflatplus_refresh_weather
Apr 19 22:41:57 easyVDR lircd-0.9.0[2244]: accepted new client on /var/run/lirc/lircd
Apr 19 22:41:57 easyVDR kernel: [   23.029552] snd_hda_intel 0000:00:1f.3: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
Apr 19 22:41:58 easyVDR after-vdr-hooks: executing /usr/share/vdr/after-vdr-hooks/99_disable-power-switch-rules
Apr 19 22:41:58 easyVDR kernel: [   23.123691] init: easyvdr-vdr post-start process (2262) terminated with status 1
Apr 19 22:41:58 easyVDR kernel: [   23.137906] init: easyvdr-create-ramdisk main process (2746) killed by TERM signal
Apr 19 22:41:59 easyVDR easyvdr-systemstart: wait for vdr
Apr 19 22:42:00 easyVDR easyvdr-systemstart: wait for vdr
Apr 19 22:42:00 easyVDR kernel: [   25.302467] i2c i2c-4: tda10071: firmware version 1.21.31.2
Apr 19 22:42:00 easyVDR kernel: [   25.302470] i2c i2c-4: tda10071: found a 'NXP TDA10071' in warm state
Apr 19 22:42:00 easyVDR vdr: [2690] DVB API version is 0x050A (VDR was built with 0x050A)
Apr 19 22:42:00 easyVDR vdr: [2690] frontend 0/0 provides DVB-S,DVB-S2 with QPSK ("NXP TDA10071")
Apr 19 22:42:00 easyVDR vdr: [2690] found 1 DVB device
Apr 19 22:42:00 easyVDR vdr: [2690] initializing plugin: burn (0.2.2): Universelles Umwandlungs- und Brennplugin
Apr 19 22:42:00 easyVDR vdr: [2690] initializing plugin: devstatus (0.4.1): DVB-Gerätestatus
Apr 19 22:42:00 easyVDR vdr: [2690] initializing plugin: dvdswitch (0.2.2): Erlaubt das Abspielen von DVD-Abbildern
Apr 19 22:42:00 easyVDR vdr: [2690] dvdswitch: use DVD Device: /dev/dvd
Apr 19 22:42:00 easyVDR vdr: [2690] dvdswitch: create link /var/lib/vdr/plugins/dvdswitch/dvdlink to /dev/dvd
Apr 19 22:42:00 easyVDR kernel: [   25.343658] i2c i2c-4: tda10071: i2c rd failed=-5 reg=1f len=1
Apr 19 22:42:00 easyVDR vdr: [2690] initializing plugin: epgsearch (1.0.1.beta5): Suche im EPG nach Wiederholungen und anderem
[...]
Apr 19 22:42:00 easyVDR vdr: [2690] parsing /var/lib/vdr/plugins/text2skin/anthra_1920_FSt2/anthra_1920_FSt2.skin
Apr 19 22:42:00 easyVDR vdr: [2690] text2skin: loading /var/lib/vdr/plugins/text2skin/anthra_1920_OS9/anthra_1920_OS9.colors
Apr 19 22:42:00 easyVDR vdr: [2690] parsing /var/lib/vdr/plugins/text2skin/anthra_1920_OS9/anthra_1920_OS9.skin
Apr 19 22:42:00 easyVDR vdr: [2690] starting plugin: softhddevice
Apr 19 22:42:01 easyVDR easyvdr-systemstart: wait for vdr
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 0 is not supported by HW
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 1 is not supported by HW
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 2 is not supported by HW
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 3 is not supported by HW
Apr 19 22:42:01 easyVDR vdr: [2690] starting plugin: setup
Apr 19 22:42:01 easyVDR vdr: [2690] setting current skin to "flatPlus"
Apr 19 22:42:01 easyVDR vdr: [2690] loading /var/lib/vdr/themes/flatPlus-default.theme
Apr 19 22:42:01 easyVDR vdr: [2690] switching to channel 1 (Das Erste HD)
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 0 is not supported by HW
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 1 is not supported by HW
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 2 is not supported by HW
Apr 19 22:42:01 easyVDR vdr: Selected deinterlacer for resolution 3 is not supported by HW
Apr 19 22:42:01 easyVDR kernel: [   26.205315] i2c i2c-4: tda10071: i2c rd failed=-5 reg=39 len=1
Apr 19 22:42:01 easyVDR vdr: [2841] ERROR (dvbdevice.c,893): Ein-/Ausgabefehler der Gegenstelle (remote)
Apr 19 22:42:01 easyVDR kernel: [   26.207392] i2c i2c-4: a8293: i2c failed=-5 rd=0
Apr 19 22:42:01 easyVDR kernel: [   26.209609] i2c i2c-4: tda10071: i2c wr failed=-5 reg=00 len=5
Apr 19 22:42:01 easyVDR vdr: [2841] ERROR (dvbdevice.c,894): Ein-/Ausgabefehler der Gegenstelle (remote)
Apr 19 22:42:01 easyVDR kernel: [   26.211773] i2c i2c-4: tda10071: i2c wr failed=-5 reg=81 len=1
Apr 19 22:42:01 easyVDR vdr: video: display buffer empty, duping frame (1/0) 0
Apr 19 22:42:01 easyVDR vdr: video: display buffer empty, duping frame (2/0) 0
Apr 19 22:42:01 easyVDR vdr: video: display buffer empty, duping frame (3/0) 0
Apr 19 22:42:01 easyVDR vdr: video: display buffer empty, duping frame (4/0) 0

Das Laden der Firmware scheint also erst mal zu klappen, kurz darauf streikt aber der Zugriff auf dem i2c-Bus. Die Firmware 1.21.31.2 ist bei Linux Media Experimental dabei, ich habe es aber auch schon mit der neueren Firmware 1.27.43.0 versucht. Die Karte hat einfach keinen Empfang (Signalstärke ist null, es kommt auch kein EPG), ist aber z.B. auf /dev/dvb/adapter0/frontend0 zu sehen. Das SAT-Kabel tut, wenn ich es in eine andere Karte stecke.

Habt Ihr eine Idee, was da schief geht? Die Karte ist frisch gekauft und ich habe sie noch nicht mit Windows getestet (kann ich aber machen, wenn Ihr auf einen Hardware-Defekt tippt).

Vielen Dank im Voraus!

Roland


P.S.: die Karte steckt in einem Asrock B150M-HDV mit Pentium G4560, Ausgabe über HDMI und mit einem alten DVB-T-Stick (Stick im syslog oben nicht gesteckt) bekomme ich sogar ein Bild von ein paar alten DVB-T (nicht -T2) Sendern. Die Ausgabe scheint also zu funktionieren.
 Zitieren
#2
Hi,

(19.04.2017, 22:41)Roland schrieb: Habt Ihr eine Idee, was da schief geht?
Bitte easyInfo & dmesg anhängen!

P.S
Du schreibst "Linux Media Experimental" ..wurde "media-build-experimental-dkms" installiert??

Gruss
Wolfgang

 Zitieren
#3
Möglicherweise ist die Firmware Datei zu alt. dvb-fe-tda10071.fw

linuxtv: firmware version 1.27.43.0
bei dir: firmware version 1.21.31.2
Du brauchst Hilfe? Wir brauchen Daten!
while (! asleep()) sheep++;
 Zitieren
#4
Hi, 
Bin kein Experte, aber waren nicht i2c Fehler auch durch grub Einträge zu bekämpfen bei UEFI Boards? Also hpet deaktivieren und oder msi deaktivieren? 
@wirbel: hat er doch beide versucht wie oben steht. 
MfG Stefan
Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, als Tuner FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 v3.-64 stable
VDR2 in Rente
VDR3 in Rente
VDR4: MSI G31M2 v2, Intel E5200, 6" t6963c gLCD, 2GB, WD 2TB+3TB, 2x TT3200 + ASUS GT730-SL-2GD3-BRK + mod. Digitainergeh. v3-64
VDR5: GIGABYTE GA-G31M-S2L + Intel E5200 + GT220 + Zalman ZNF 100 Passivkühler + 2GB + t6963c gLCD + Satelco DVB-C+CI + Sundtek DVB-C/T v2010+mod. Digitainergeh. v1
VDR6: MSI MS-7236, Intel E2140, GT630 passiv, 2GB, 750GB, t6963c gLCD, 2x TT3200 v2.5-64
Hilfe gefällig? Dann brauchen wir ein easyInfo aus easyPortal!
 Zitieren
#5
@Stefan, danke hab ich übersehen.

I2C muss funktionieren, zumindest zeitweise, sonst würde die Karte nicht detektiert.
Du brauchst Hilfe? Wir brauchen Daten!
while (! asleep()) sheep++;
 Zitieren
#6
Hallo Mango,
Hallo Wirbel,
Hallo SurfaceCleanerZ,

vielen Dank schon mal für Euren Einsatz! Und danke für's Verschieben ins richtige Unterforum - der easyVDR tut bei mir einfach seit Jahren so stressfrei, dass ich etwas die Forenübersicht verloren habe.

Im Anhang die Ausgabe von "dmesg > dmesg.txt" und die easyInfo. Im Vergleich zum initialen syslog habe ich jetzt die neuste Firmware und habe den Floppy-Power-Stecker an der Sat-Karte eingesteckt (ist angeblich optional aber sicher ist sicher). Leider habe ich immer noch null Empfang.

Der im dmesg genannte a8293, mit dem nicht geredet werden kann, ist übrigens ein "Single LNB Supply and Control Voltage Regulator" - sicher auch keine ganz unwichtige Funktion. Allerdings zickt zuerst der TDA10071:
-----------------------------------------------------------------------------------
[   20.971837] i2c i2c-4: tda10071: found a 'NXP TDA10071' in cold state, will try to load a firmware
[   20.971840] i2c i2c-4: tda10071: downloading firmware from file 'dvb-fe-tda10071.fw'
[   23.029887] snd_hda_intel 0000:00:1f.3: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[   23.282063] init: easyvdr-vdr post-start process (2314) terminated with status 1
[   23.298290] init: easyvdr-create-ramdisk main process (2796) killed by TERM signal
[   25.845262] i2c i2c-4: tda10071: firmware version 1.27.43.0
[   25.845271] i2c i2c-4: tda10071: found a 'NXP TDA10071' in warm state
[   25.887088] i2c i2c-4: tda10071: i2c rd failed=-5 reg=1f len=1
[   25.899499] i2c i2c-4: tda10071: i2c rd failed=-5 reg=39 len=1
[   26.705520] i2c i2c-4: tda10071: i2c rd failed=-5 reg=39 len=1
[   26.707598] i2c i2c-4: a8293: i2c failed=-5 rd=0
[   26.709809] i2c i2c-4: tda10071: i2c wr failed=-5 reg=00 len=5
-----------------------------------------------------------------------------------

Habt Ihr eine Idee, was das mit dem "IRG timing workaround" soll? Klingt für mich jetzt nicht vertrauenserweckend.

Als nächstes werde ich mal auf eine extra Festplatte ein Windows 7 aufspielen und die Karte im Rechner damit testen.

Danke und Gruß

Roland


Angehängte Dateien
.txt   dmesg.txt (Größe: 77,48 KB / Downloads: 3)
.zip   easyinfo.zip (Größe: 84,45 KB / Downloads: 2)
easyVDR 0.9.77, TT S2-6400 (1x Sat), TechniSat Airstar 2 DVB-T PCI, Board Intel DH67BLB, Pentium G630T (35W, SandyBridge), 4GB RAM Kingston KVR1333D3N9/4G, 2TB ST2000DL003, BQT L7-300W
 Zitieren
#7
Hi,

(20.04.2017, 20:25)Roland schrieb: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
die Meldung bezieht sich auf den Sound-Chip ...vllt. passt nee Einstellung nicht!

P.S
Da die Karte ab Kernel-3.9 bereits unterstützt wird, Bitte "media-build-experimental-dkms"
deinstallieren.
Code:
sudo apt-get remove --purge media-build-experimental-dkms

Gruss
Wolfgang

 Zitieren
#8
(20.04.2017, 20:40)mango schrieb: Hi,

(20.04.2017, 20:25)Roland schrieb: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
die Meldung bezieht sich auf den Sound-Chip ...vllt. passt nee Einstellung nicht!

P.S
Da die Karte ab Kernel-3.9 bereits unterstützt wird, Bitte "media-build-experimental-dkms"
deinstallieren.
Code:
sudo apt-get remove --purge media-build-experimental-dkms

Gruss
Wolfgang

Hallo Wolfgang,

das war glaube ich schon mal eine sehr gute Idee - die I2C-Fehler sind weg! Allerdings immer noch kein Bild und kein Empfang oder EPG (ich hatte das am Anfang auch schon mal versucht, bin dann aber in meiner Verzweiflung auf experimental-dkms, ohne vorher mal dmesg anzuschauen).

Im Anhang noch die aktualisierte easyinfo und dmesg-Ausgabe.

Gruß

Roland



P.S.: ein "w_scan -f s -s S19E2" meint übrigens auch, dass da kein Signal anliegt - habe langsam den Verdacht, dass da irgendwas an der Karte faul ist. Oder kann das irgendwie an meinem Sat-Multiswitch liegen? Mein alter VDR mit TT s2-6400 tut an dem Kabel aber problemlos:

easyvdr@easyVDR:~$ w_scan -f s -s S19E2
w_scan -f s -s S19E2
w_scan version 20170107 (compiled for DVB API 5.10)
using settings for 19.2 east Astra 1KR/1L/1N/1M
scan type SATELLITE, channellist 68
output format vdr-2.0
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
        /dev/dvb/adapter0/frontend0 -> SATELLITE "NXP TDA10071": very good :-))

Using SATELLITE frontend (adapter /dev/dvb/adapter0/frontend0)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.10
frontend 'NXP TDA10071' supports
INVERSION_AUTO
DVB-S
DVB-S2
FREQ (0.95GHz ... 2.15GHz)
SRATE (1.000MSym/s ... 45.000MSym/s)
using LNB "UNIVERSAL"
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
trying 'S2 f = 10729 kHz V SR = 22000  2/3 0,35  8PSK  (0:0:0)'
(time: 00:00.008) diseqc_send_msg: SEC_TONE_OFF failed.

initial_tune:2813: Setting frontend failed S2 f = 10729 kHz V SR = 22000  2/3 0,                       35  8PSK  (0:0:0)
trying 'S  f = 10744 kHz H SR = 22000  5/6 0,35  QPSK  (0:0:0)'
(time: 00:00.008) diseqc_send_msg: SEC_TONE_OFF failed.

[...]
initial_tune:2813: Setting frontend failed S2 f = 12725 kHz H SR = 30000 AUTO 0,                       AUTO  8PSK  (0:0:0)
trying 'S  f = 12729 kHz V SR = 22000  5/6 0,35  QPSK  (0:0:0)'
(time: 00:00.240) diseqc_send_msg: SEC_TONE_OFF failed.

initial_tune:2813: Setting frontend failed S  f = 12729 kHz V SR = 22000  5/6 0,                       35  QPSK  (0:0:0)

ERROR: Sorry - i couldn't get any working frequency/transponder
 Nothing to scan!!


Angehängte Dateien
.txt   dmesg_ohne_dkms.txt (Größe: 57,04 KB / Downloads: 2)
.zip   easyinfo_ohne_dkms.zip (Größe: 61,38 KB / Downloads: 3)
easyVDR 0.9.77, TT S2-6400 (1x Sat), TechniSat Airstar 2 DVB-T PCI, Board Intel DH67BLB, Pentium G630T (35W, SandyBridge), 4GB RAM Kingston KVR1333D3N9/4G, 2TB ST2000DL003, BQT L7-300W
 Zitieren
#9
Hallo,

ja dmesg sieht schon viel besser aus!
Code:
[    8.394034] cx23885 driver version 0.0.4 loaded
[    8.394164] CORE cx23885[0]: subsystem: 0070:c12a, board: Hauppauge WinTV Starburst [card=53,autodetected]
[    8.551032] FAT-fs (sdb1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[    8.719248] tveeprom 4-0050: Hauppauge model 121100, rev B2C3, serial# 4035687283
[    8.719250] tveeprom 4-0050: MAC address is 00:0d:fe:8b:b3:73
[    8.719252] tveeprom 4-0050: tuner model is Conexant CX24118A (idx 123, type 4)
[    8.719253] tveeprom 4-0050: TV standards ATSC/DVB Digital (eeprom 0x80)
[    8.719253] tveeprom 4-0050: audio processor is CX23888 (idx 40)
[    8.719254] tveeprom 4-0050: decoder processor is CX23888 (idx 34)
[    8.719255] tveeprom 4-0050: has no radio, has IR receiver, has no IR transmitter
[    8.719256] cx23885[0]: warning: unknown hauppauge model #121100
[    8.719256] cx23885[0]: hauppauge eeprom: model=121100
[    8.719258] cx23885_dvb_register() allocating 1 frontend(s)
[    8.719259] cx23885[0]: cx23885 based dvb card
[    8.734174] tda10071 4-0005: NXP TDA10071 successfully identified
[    8.747245] a8293 4-000b: Allegro A8293 SEC successfully attached
[    8.747252] DVB: registering new adapter (cx23885[0])
[    8.747255] cx23885 0000:01:00.0: DVB: registering adapter 0 frontend 0 (NXP TDA10071)...
[    8.747428] cx23885_dev_checkrevision() Hardware revision = 0xd0
[    8.747432] cx23885[0]/0: found at 0000:01:00.0, rev: 4, irq: 16, latency: 0, mmio: 0xdf000000

Hängt da noch ein USB-Stick am VDR??

Jetzt gibt es nur noch diese Fehler
Code:
Apr 20 22:07:14 easyVDR vdr: [2750] ERROR (dvbdevice.c,893): Eingabe-/Ausgabefehler
Apr 20 22:07:14 easyVDR vdr: [2750] ERROR (dvbdevice.c,894): Eingabe-/Ausgabefehler
&
Code:
Apr 20 22:07:26 easyVDR vdr: video: display buffer empty, duping frame (3761/0) 0
Apr 20 22:07:26 easyVDR vdr: video: display buffer empty, duping frame (3762/0) 0
leider ist nur diese Meldung im syslog zu sehen, aber kein VDR start!

Signal liegt auch nicht an!
Code:
#####################################################
##### femon -H -c5 -a0  
#####################################################

FE: NXP TDA10071 (DVBS)
status       | signal   0% | snr   0% | ber 0 | unc 0 |
status       | signal   0% | snr   0% | ber 0 | unc 0 |
status       | signal   0% | snr   0% | ber 0 | unc 0 |
status       | signal   0% | snr   0% | ber 0 | unc 0 |
status       | signal   0% | snr   0% | ber 0 | unc 0 |

(20.04.2017, 21:29)Roland schrieb: Oder kann das irgendwie an meinem Sat-Multiswitch liegen? Mein alter VDR mit TT s2-6400 tut an dem Kabel aber problemlos:
Ist am alten VDR -> DiSEqC benutzen aktiviert?

Gruss
Wolfgang

 Zitieren
#10
>> Oder kann das irgendwie an meinem Sat-Multiswitch liegen?

Den hättest du beim Aufruf von w_scan angeben müssen.

Mit der Kombination Treiber/Firmware/Hardware stimmt etwas nicht:
>> (time: 00:00.008) diseqc_send_msg: SEC_TONE_OFF failed.
So wird w_scan nicht korrekt tunen.

Leider kann man bei easyvdr nicht mehr nachsehen, welche Zeile Quellcode des VDR dazu gehört, Patches sei Dank..
Im originalen source von vdr passt dazu keine Zeile.


Apr 20 22:07:14 easyVDR vdr: [2750] ERROR (dvbdevice.c,893): Eingabe-/Ausgabefehler
Apr 20 22:07:14 easyVDR vdr: [2750] ERROR (dvbdevice.c,894): Eingabe-/Ausgabefehler


Zitat:Signal liegt auch nicht an!
Code:
#####################################################
##### femon -H -c5 -a0
Nein, das kann man daraus nicht schlussfolgern.
femon zeigt auf einem frontend nur Signal an, während ein ANDERER Prozess das frontend geöffnet hat UND einen tuning Befehl abgesetzt hat.
Da vdr in der loop stirbt, gibt es keinen Prozess, der dieses frontend geöffnet und getuned hält. Ebenso, wenn vdr läuft aber das frontend nicht getuned hat oder geschlossen, sagt femon auch nix.
Du brauchst Hilfe? Wir brauchen Daten!
while (! asleep()) sheep++;
 Zitieren
#11
Ich habe die Karte einfach mal in den anderen PCIe-Slot gesteckt (war jedes Mal ein x1) und jetzt tun Bild und Ton  Smile

Vielen Dank schon mal für Eure Unterstützung!!! Im Laufe des Wochenendes will ich der Sache mal auf den Grund gehen und werde dann hier meine Erkenntnisse schreiben. Außerdem habe ich die Fernbedienung ja noch nicht ausprobiert...

Am Ende gibt es dann auch einen Wiki-Eintrag zum Thema "getestete Hardware" von mir.

Roland
 Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste